[9fans] P9P acme New/Del bug? - Plan9

This is a discussion on [9fans] P9P acme New/Del bug? - Plan9 ; I'm seeing P9P acme (running in linux on a Wintel PC) crash intermittently when executing "New xxx", and if that doesn't cause a crash middle clicking Del in the tag of the newly created xxx window nearly always causes a ...

+ Reply to Thread
Results 1 to 3 of 3

Thread: [9fans] P9P acme New/Del bug?

  1. [9fans] P9P acme New/Del bug?

    I'm seeing P9P acme (running in linux on a Wintel PC) crash
    intermittently when executing "New xxx", and if that doesn't cause a
    crash middle clicking Del in the tag of the newly created xxx window
    nearly always causes a crash. I just downloaded and installed the
    latest plan9port.tgz to make sure I'm current and I still see the
    problem

    The couple times I saw the crash when executing New, the following
    message was written to stdout or stderr:
    devdraw: reading wsys msg: Connection reset by peer

    In the cases where New xxx doesn't cause acme to crash, it creates a
    +Errors window containing the line
    can't open xxx: No such file or directory
    as well as creating the window for the file xxx.
    If I then try to Del the xxx window, acme crashes after writing the
    following message to stdout or stderr:
    acme: can't find text in filedeltext: No such file or directory
    or
    acme: can't find text in filedeltext: Success
    Several times when it crashed Del-ing the window I got a message like:
    *** glibc detected *** corrupted double-linked list: 0x080e8328 ***

    I haven't figured out how to debug P9P programs using either acid or gdb
    (breakpoints don't seem to work), so I haven't had any luck tracking
    this down.

    Has anyone else noticed these problems? Have any ideas what is going wrong?

    thanks,
    vbnut



  2. Re: [9fans] P9P acme New/Del bug?

    > Has anyone else noticed these problems? Have any ideas what is going wrong?

    Found using libefence, and fixed. Thanks for the detailed recipe
    for making it crash. I saw this once about six months ago,
    but I couldn't reproduce it.

    Russ

  3. Re: [9fans] P9P acme New/Del bug?

    On Sun, 2007-02-11 at 13:44 -0500, Russ Cox rsc-at-swtch.com |9fans|
    wrote:
    > > Has anyone else noticed these problems? Have any ideas what is going wrong?

    >
    > Found using libefence, and fixed. Thanks for the detailed recipe
    > for making it crash. I saw this once about six months ago,
    > but I couldn't reproduce it.


    Hey, that's great. Thanks for the quick fix.



+ Reply to Thread