[9fans] connecting venti: no route - Plan9

This is a discussion on [9fans] connecting venti: no route - Plan9 ; Moin, I boot my Plan 9 cpu/fileserver with venti=/dev/sdC0/arenas in plan9.ini. Now I need to store some files with vac over network and changed the line in plan9.ini to venti=/dev/sdC0/arenas tcp!*!17034 tcp!127.1!8000. and try to reboot. That gives me connecting ...

+ Reply to Thread
Results 1 to 5 of 5

Thread: [9fans] connecting venti: no route

  1. [9fans] connecting venti: no route

    Moin,

    I boot my Plan 9 cpu/fileserver with venti=/dev/sdC0/arenas in
    plan9.ini. Now I need to store some files with vac over network and
    changed the line in plan9.ini to venti=/dev/sdC0/arenas tcp!*!17034
    tcp!127.1!8000. and try to reboot.

    That gives me

    connecting venti: no route

    How do I make venti available on all network interfaces?

    Many thanks
    Matthias

  2. Re: [9fans] connecting venti: no route

    Sounds correct to me.

    The magic that parses this and sets up venti is
    in /sys/src/9/boot/local.c.

    I cannot see fossil started with a -h to give it a host/ip to attach to.

    >From my reading of this file you may have fallen through the cracks in

    the config used. I think people generally use either a combined venti and
    fossil server or completely seperate machines.

    I must admit I have not read the code carefully and have already opened
    a bottle (its chirstmas after all) but perhaps this gives you a lead in.

    -Steve

  3. Re: [9fans] connecting venti: no route

    > Moin,
    >
    > I boot my Plan 9 cpu/fileserver with venti=/dev/sdC0/arenas in
    > plan9.ini. Now I need to store some files with vac over network and
    > changed the line in plan9.ini to venti=/dev/sdC0/arenas tcp!*!17034
    > tcp!127.1!8000. and try to reboot.
    >
    > That gives me
    >
    > connecting venti: no route
    >
    > How do I make venti available on all network interfaces?


    Perhaps venti='/dev/sdC0/arenas tcp!*!17034'?

    Heiko


  4. Re: [9fans] connecting venti: no route

    "Steve Simon" writes:

    > Sounds correct to me.
    >
    > The magic that parses this and sets up venti is
    > in /sys/src/9/boot/local.c.
    >
    > I cannot see fossil started with a -h to give it a host/ip to attach to.

    ....

    casually I needed to connect fossil to a hand started venti for some
    repair work.

    The environment variable 'venti' holds the 'net!host!port'
    information, but you can also specify the venti host on the fossil
    console with "fsys venti '

    If dns is not running you may need to specify the ip and port
    numerically.

    I guess you will find fossil beeing started up with the -f switch, it
    will read in its configuration from there. Adapting the respective
    'fsys
    venti' command there is a way to get another venti.

    Variables defined in plan9.ini become env variables, my plan9.ini's
    have a "venti=..." line for all computers running venti.

    Regards

    Jorge-León

  5. Re: [9fans] connecting venti: no route

    ,s:dns:ndb:g

    On Sat Dec 9 14:20:56 EST 2006, jorge-plan9@magma.com.ni wrote:
    > If dns is not running you may need to specify the ip and port
    > numerically.


+ Reply to Thread