Hello 9fans,

I have been talking with Benavento and Lucio to get a 486 terminal
working. I decided to share it with you to get some ideas of where
to start debugging.

> I created a boot floppy, to configure a plan9 terminal using
> sirviente.9grid.es as cpu, and got a tons of lines with:
> "mapfree unallocated unmapped physical memory"

I have discarded hardware problems because I tested the machine with a
QNX floppy and the network card worked. I could browse through some
www pages.

The previous errors were produced because the kernel was trying to
allocate more memory than the system had.

I added *maxmem=67108864 to PLAN9.INI (the system has 64Mb of RAM) and
these errors dissapeared.

Following Lucio suggestion I also added *noe820scan=1.

I reach the prompt:

#l0: NE2000: 10Mbps port 0x300 irq 9 addr 0x4000 size 0x4000: 004f4c0141b5
64M memory: 27M kernel data, 36M user, 163M swap
root is from (tcp) [tcp -g ether /net/ether0]:
user[none]: vejeta
boot: can't connect to file server: connection time out
panic: boot process died: unknown
panic: boot process died: unknown
dumpstack disabled
cpu0 exiting
- - - - - - - - - - - - - - - - - - - -

I tested the same floppy in another machine, a Pentium II with same
network card, and it could boot successfully and reach 9grid.net as
cpu server. So I have discarded router misconfigurations too.

Launching a sniffer and monitoring the network in another machine showed
that there weren't any output coming from

My current PLAN9.INI is as follows:
- - - - - - - - - - - - - - - - - - - - - - - - - - -
ether0=type=ne2000 port=0x300 irq=9 mem=0x4000
# nodummyrr



auth= authdom=
bootargs=tcp -g ether /net/ether0




mouseport=0 #0 para el COM1 y 1 para el COM2

Fidonet: 2:345/432.2