Re: [9fans] assembly loading - Plan9

This is a discussion on Re: [9fans] assembly loading - Plan9 ; On Mon, Feb 25, 2008 at 4:59 PM, Charles Forsyth wrote: > > doing something wrong? > > > > TEXT main+0(SB),0,$0 > > MOVW array +0(SB), R5 > for anyone wanting to know, it has been resolved thanks to ...

+ Reply to Thread
Results 1 to 3 of 3

Thread: Re: [9fans] assembly loading

  1. Re: [9fans] assembly loading

    On Mon, Feb 25, 2008 at 4:59 PM, Charles Forsyth wrote:
    > > doing something wrong?
    > >
    > > TEXT main+0(SB),0,$0
    > > MOVW array<>+0(SB), R5

    >


    for anyone wanting to know, it has been resolved thanks to jmk.

    MOVW $setR30(SB), R30
    right in the program beginning sets up the static base register.

    and Charles, I'm doing MOVW $array<>+0(SB), R5, it was a typo. thanks
    for noting.

    iru

  2. Re: [9fans] assembly loading

    >for anyone wanting to know, it has been resolved thanks to jmk.

    >MOVW $setR30(SB), R30
    >right in the program beginning sets up the static base register.


    that should be done by _main, which is why i didn't suggest it.

  3. Re: [9fans] assembly loading

    On Tue, Feb 26, 2008 at 11:45 AM, C H Forsyth wrote:
    > >for anyone wanting to know, it has been resolved thanks to jmk.

    >
    > >MOVW $setR30(SB), R30
    > >right in the program beginning sets up the static base register.

    >
    > that should be done by _main, which is why i didn't suggest it.
    >


    ah, sure. in fact, this is a standalone program, so main is the real
    entry point for now.

    iru

+ Reply to Thread