[9fans] QEMU question - Plan9

This is a discussion on [9fans] QEMU question - Plan9 ; Hello. I switched to using QEMU so I now have Internet :-) But when I boot, i get this: http://myskitch.com/pietrogagliardi/..._plan_9_on_q_- _what_is_this_-20071109-151831.png I always say 1 for the prompt. What's going on? - Pietro...

+ Reply to Thread
Results 1 to 5 of 5

Thread: [9fans] QEMU question

  1. [9fans] QEMU question

    Hello. I switched to using QEMU so I now have Internet :-) But when I
    boot, i get this:

    http://myskitch.com/pietrogagliardi/..._plan_9_on_q_-
    _what_is_this_-20071109-151831.png

    I always say 1 for the prompt. What's going on? - Pietro

  2. Re: [9fans] QEMU question

    > Hello. I switched to using QEMU so I now have Internet :-) But when I
    > boot, i get this:
    >
    > http://myskitch.com/pietrogagliardi/..._plan_9_on_q_-
    > _what_is_this_-20071109-151831.png
    >
    > I always say 1 for the prompt. What's going on? - Pietro


    Odd. I use plan9 under qemu and I've never seen anything like it.
    What is your plan9.ini and what does disk/fdisk show?
    --
    John Stalker
    School of Mathematics
    Trinity College Dublin
    tel +353 1 896 1983
    fax +353 1 896 2282

  3. Re: [9fans] QEMU question

    term% disk/fdisk /dev/sdC0/data
    cylinder = 8225280 bytes
    *p1 0 522 (522 cylinders, 3.99 GB) PLAN(
    >>> q

    term% 9fat: ; cat /n/9fat/plan9.ini
    bootfile=sdC0!9fat!9pcf
    bootargs=local!#S/sdC0/fossil
    bootdisk=local!#S/sdC0/fossil

    *nomp=1
    *nodumpstack=1
    partition=new
    dmamode=ask

    *nobiosload=1
    *noahciload=1

    *nobiosload=1
    *noahciload=1

    *debugload=1
    mouseport=ps2
    monitor=vesa
    vgasize=1024x768x24

    audio0=sb16

    ether0=ne2000
    term%

    Note that there are, in fact, two *nbiosload=1 lines and two
    *noahciload=1 lines.

    On Nov 9, 2007, at 7:24 PM, John Stalker wrote:

    >> Hello. I switched to using QEMU so I now have Internet :-) But when I
    >> boot, i get this:
    >>
    >> http://myskitch.com/pietrogagliardi/..._plan_9_on_q_-
    >> _what_is_this_-20071109-151831.png
    >>
    >> I always say 1 for the prompt. What's going on? - Pietro

    >
    > Odd. I use plan9 under qemu and I've never seen anything like it.
    > What is your plan9.ini and what does disk/fdisk show?
    > --
    > John Stalker
    > School of Mathematics
    > Trinity College Dublin
    > tel +353 1 896 1983
    > fax +353 1 896 2282



  4. Re: [9fans] QEMU question

    > Note that there are, in fact, two *nbiosload=1 lines and two
    > *noahciload=1 lines.


    why?

    - erik


  5. Re: [9fans] QEMU question

    Hi,

    On Nov 9, 2007 9:20 PM, Pietro Gagliardi wrote:
    > Hello. I switched to using QEMU so I now have Internet :-) But when I
    > boot, i get this:
    >
    > http://myskitch.com/pietrogagliardi/..._plan_9_on_q_-
    > _what_is_this_-20071109-151831.png
    >
    > I always say 1 for the prompt. What's going on? - Pietro


    I just installed Plan 9 from the 20071222 image, and get the same menu
    when booting. The menu is indeed caused by the duplicate *nobiosload
    entry, and as such it can easily be fixed, but I'm wondering why a
    fresh install has this duplicate entry? As it can be somewhat
    confusing for a newbie, I think this should be fixed if possible.

    Greetings, Sander.

+ Reply to Thread