LITE-ON DVDRW LH-20A1H on VIA 571 - OS2

This is a discussion on LITE-ON DVDRW LH-20A1H on VIA 571 - OS2 ; This is the second copy of LITE-ON DVDRW LH-20A1H I'm trying to use. Burning is fine, however, it would not read anything in bus master mode. I upgraded to the DaniS508 R1.7.10 - same result. Controller:1 Port:0170 IRQ:0F Status:OK BusMaster ...

+ Reply to Thread
Page 1 of 2 1 2 LastLast
Results 1 to 20 of 21

Thread: LITE-ON DVDRW LH-20A1H on VIA 571

  1. LITE-ON DVDRW LH-20A1H on VIA 571


    This is the second copy of LITE-ON DVDRW LH-20A1H I'm trying to use.
    Burning is fine, however, it would not read anything in bus master
    mode.

    I upgraded to the DaniS508 R1.7.10 - same result.

    Controller:1 Port:0170 IRQ:0F Status:OK BusMaster Scatter/Gather
    VIA 571 PATA host (1106:0571 rev:10) on PCI 0:4.1 @33MHz
    Unit:1 Status:OK ATAPI BusMaster UltraDMA4/PIO4
    Model:LITE-ON DVDRW LH-20A1H LL0B

    Techsupport is Windows-only, and says that they know no
    incompatibility with VIA chipsets. NEC 2500 works OK in the same
    configuration.

    Any ideas? It is a slave to an Maxtor HD.

    Thanks,
    Ilya

  2. Re: LITE-ON DVDRW LH-20A1H on VIA 571

    [A complimentary Cc of this posting was NOT [per weedlist] sent to
    Ilya Zakharevich
    ], who wrote in article :
    > This is the second copy of LITE-ON DVDRW LH-20A1H I'm trying to use.
    > Burning is fine, however, it would not read anything in bus master
    > mode.


    In fact, with the second copy (and after all the upgrades I did
    burning is not working too - drive got stuck at "0MB written" state).

    > Techsupport is Windows-only, and says that they know no
    > incompatibility with VIA chipsets. NEC 2500 works OK in the same
    > configuration.
    >
    > Any ideas? It is a slave to an Maxtor HD.


    Meanwhile I exchanged the cable to a different one (all 80wires), and
    tried the master mode (with the HD on the same channel removed from
    the cable). Does not fix it...

    Since the errors happen at the start of the disk, when the read/write
    speed is not very high, I do not expect it is a failure of controller
    to write/read at high speed. But what is it?

    Thanks,
    Ilya

  3. Re: LITE-ON DVDRW LH-20A1H on VIA 571

    Hi Ilya

    Ilya Zakharevich wrote:
    > [A complimentary Cc of this posting was NOT [per weedlist] sent to
    > Ilya Zakharevich
    > ], who wrote in article :
    >> This is the second copy of LITE-ON DVDRW LH-20A1H I'm trying to use.
    >> Burning is fine, however, it would not read anything in bus master
    >> mode.

    >
    > In fact, with the second copy (and after all the upgrades I did
    > burning is not working too - drive got stuck at "0MB written" state).
    >
    >> Techsupport is Windows-only, and says that they know no
    >> incompatibility with VIA chipsets. NEC 2500 works OK in the same
    >> configuration.
    >>
    >> Any ideas? It is a slave to an Maxtor HD.

    >
    > Meanwhile I exchanged the cable to a different one (all 80wires), and
    > tried the master mode (with the HD on the same channel removed from
    > the cable). Does not fix it...
    >
    > Since the errors happen at the start of the disk, when the read/write
    > speed is not very high, I do not expect it is a failure of controller
    > to write/read at high speed. But what is it?
    >
    > Thanks,
    > Ilya



    Might be an idea to check buildlevel of drivers involved - some builds
    of os2cdrom.dmd and os2dasd.dmd are not as burner friendly as they
    should have been.

    Regards

    Pete

  4. Re: LITE-ON DVDRW LH-20A1H on VIA 571

    [A complimentary Cc of this posting was sent to
    Peter Brown
    ], who wrote in article :
    > Might be an idea to check buildlevel of drivers involved - some builds
    > of os2cdrom.dmd and os2dasd.dmd are not as burner friendly as they
    > should have been.


    At least the first drive burned fine; it is during the read when the
    errors happen. And reading fails even with dvddao, which, AFAIU, does
    not use os2cdrom or os2dasd.

    Thanks anyway,
    Ilya

  5. Re: LITE-ON DVDRW LH-20A1H on VIA 571

    Hi Ilya

    Ilya Zakharevich wrote:
    > [A complimentary Cc of this posting was sent to
    > Peter Brown
    > ], who wrote in article :
    >> Might be an idea to check buildlevel of drivers involved - some builds
    >> of os2cdrom.dmd and os2dasd.dmd are not as burner friendly as they
    >> should have been.

    >
    > At least the first drive burned fine; it is during the read when the
    > errors happen. And reading fails even with dvddao, which, AFAIU, does
    > not use os2cdrom or os2dasd.
    >
    > Thanks anyway,
    > Ilya



    What software is in use for burning? - and what version/release?

    Post buildlevels of all drivers involved.

    Are the discs in use compatible with the burner? - check manufacturers
    media recommendations.

    Might also be worth checking if there is a firmware update available for
    the burner.

    Regards

    Pete

  6. Re: LITE-ON DVDRW LH-20A1H on VIA 571

    [A complimentary Cc of this posting was sent to
    Peter Brown
    ], who wrote in article :
    > What software is in use for burning? - and what version/release?


    Errors are during reading. Even with dvddao (in ASPIROUTE mode).

    > Post buildlevels of all drivers involved.


    As I said, Dani is the latest one. ASPIROUTE is 11-15-01.

    > Are the discs in use compatible with the burner? - check manufacturers
    > media recommendations.


    I'm not discussion the burner part now.

    > Might also be worth checking if there is a firmware update available for
    > the burner.


    Nope. As shipped, it has the latest one.

    Thanks,
    Ilya

  7. Re: LITE-ON DVDRW LH-20A1H on VIA 571

    Hi Ilya

    Ilya Zakharevich wrote:
    > [A complimentary Cc of this posting was sent to
    > Peter Brown
    > ], who wrote in article :
    >> What software is in use for burning? - and what version/release?

    >
    > Errors are during reading. Even with dvddao (in ASPIROUTE mode).
    >



    Read errors can be the result of burn errors.


    >> Post buildlevels of all drivers involved.

    >
    > As I said, Dani is the latest one. ASPIROUTE is 11-15-01.
    >



    ASPIROUT.SYS looks old, current version has files dated 2005
    http://home.clara.net/orac/files/os2/aspirb10.zip

    What buildlevels of the following are in use:-

    os2cdrom.dmd
    os2dasd.dmd
    daniatapi.flt
    os2aspi.dmd

    >> Are the discs in use compatible with the burner? - check manufacturers
    >> media recommendations.

    >
    > I'm not discussion the burner part now.
    >



    You may be missing a point: there may be a problem burning which is not
    obvious until the disc is read - or not.


    >> Might also be worth checking if there is a firmware update available for
    >> the burner.

    >
    > Nope. As shipped, it has the latest one.
    >
    > Thanks,
    > Ilya



    Do you have udf216 installed? If "Yes" you could try udf formatting a
    DVD RW disc and seeing if that works.

    Regards

    Pete

  8. Re: LITE-ON DVDRW LH-20A1H on VIA 571

    On Sun, 15 Jul 2007 20:47:55 +0000 (UTC), Ilya Zakharevich
    wrote:

    >> What software is in use for burning? - and what version/release?

    >
    > Errors are during reading. Even with dvddao (in ASPIROUTE mode).


    What errors? Why do yo never post any useful information?

    >> Post buildlevels of all drivers involved.

    >
    > As I said, Dani is the latest one.


    You clueless ****er. Why anyone bothers with you I really don't know.

    > ASPIROUTE is 11-15-01.


    That means nothing. If that refers to some unspecified date format where I
    guess you mean the year is 2001, then you are on an ancient old version.
    Why do you find it so difficult to post a BLDLEVEL string?

    > I'm not discussion the burner part now.


    I'm having read errors with what you write as well.

  9. Re: LITE-ON DVDRW LH-20A1H on VIA 571

    [A complimentary Cc of this posting was NOT [per weedlist] sent to
    Paul Ratcliffe
    ], who wrote in article :
    > > Errors are during reading. Even with dvddao (in ASPIROUTE mode).


    > What errors?


    Depend on the application. If reading the filesystem, the error is
    not very informative. If reading DVD sectors directly, one gets a
    similarly generic error

    Error : Sense on 0x28 cmd : SK 0x04 ASC 0x08 ASCQ 0x03 (LOGICAL UNIT
    COMMUNICATION CRC ERROR (ULTRA-DMA/32))
    Error : Src: Cant read 32 blocks (total 32 failed) at pos 1312 (ets
    1): 31
    Error : Cant read enough data (2686976 of 16777216 done) from <>
    source
    Error : Read only 2686976 bytes of 16777216 requested. rc 31


    > Why do yo never post any useful information?


    Sigh; some people just never learn to read...

    > > ASPIROUTE is 11-15-01.

    >
    > That means nothing. If that refers to some unspecified date format where I
    > guess you mean the year is 2001, then you are on an ancient old version.
    > Why do you find it so difficult to post a BLDLEVEL string?


    OK, if you are so smart:

    File ASPIROUT.SYS has no LAN component-style version string.
    No driver EA's were found

    Thanks for your valuable attention,
    Ilya

    P.S. Reading the code of ASPIROUT.SYS, I see

    ASPI Router V1.1 Beta 5 Copyright (c) Paul Ratcliffe Nov. 2001

    I see there is a newer version on Hobbes. Will report.

  10. Re: LITE-ON DVDRW LH-20A1H on VIA 571

    [A complimentary Cc of this posting was sent to
    Peter Brown
    ], who wrote in article <0wwmi.27415$%Z3.5737@newsfe3-gui.ntli.net>:
    > > Errors are during reading. Even with dvddao (in ASPIROUTE mode).


    > Read errors can be the result of burn errors.


    Sure. And, as I said, they are not.

    > ASPIROUT.SYS looks old, current version has files dated 2005
    > http://home.clara.net/orac/files/os2/aspirb10.zip


    It is on hobbes too. I will retry.

    > What buildlevels of the following are in use:-


    > os2cdrom.dmd
    > os2dasd.dmd
    > daniatapi.flt
    > os2aspi.dmd


    Do not think they are relevant for dvddao reading method. Will check

    > You may be missing a point: there may be a problem burning which is not
    > obvious until the disc is read - or not.


    Sure. And, as I said, I'm not discussing burning. The problem is
    that disks are not readable - unless I switch off busmastering.

    > Do you have udf216 installed? If "Yes" you could try udf formatting a
    > DVD RW disc and seeing if that works.


    Let me repeat: disks are not readable - ON THE LOWEST LEVEL. Changing
    the filesystem won't change this.

    Thanks anyway,
    Ilya

  11. Re: LITE-ON DVDRW LH-20A1H on VIA 571

    [A complimentary Cc of this posting was NOT [per weedlist] sent to
    Paul Ratcliffe
    ], who wrote in article :
    > > ASPIROUTE is 11-15-01.

    >
    > That means nothing. If that refers to some unspecified date format where I
    > guess you mean the year is 2001, then you are on an ancient old version.


    Of course, updating to b10 does not change anything (AFAIU, this level
    knows nothing about busmaster/whatever, so it should not matter).
    (Both aspiroute and os2aspi updated.)

    Thanks,
    Ilya

  12. Re: LITE-ON DVDRW LH-20A1H on VIA 571

    [A complimentary Cc of this posting was sent to
    Peter Brown
    ], who wrote in article <0wwmi.27415$%Z3.5737@newsfe3-gui.ntli.net>:

    > os2cdrom.dmd


    Irrelevant at such a low level: 10.139

    > os2dasd.dmd


    Irrelevant: Nonesuch. DaniDasd is 1.4.4 DANI:1.4#@##1## 31.10.2001 8:28:45

    > daniatapi.flt


    0.3.14 DANI:0.3#@##1## 14.2.2003 9:47:41

    > os2aspi.dmd


    Downgraded (?) to Paul's version. 10.070 ===> 10.043

    Thanks,
    Ilya



  13. Re: LITE-ON DVDRW LH-20A1H on VIA 571

    Ilya Zakharevich wrote:

    ....
    >
    > Sure. And, as I said, I'm not discussing burning. The problem is
    > that disks are not readable - unless I switch off busmastering.
    >
    >

    Have you read Dani's documentation regarding busmastering?

    Quote:

    ....

    Some ATAPI units still fail running on DMA, so you have to disable DMA
    busmastering for these units (/A:x /U:x /!BM).

    Sounds like you have one of the units she is referring to.

  14. Re: LITE-ON DVDRW LH-20A1H on VIA 571

    [A complimentary Cc of this posting was sent to
    James J. Weinkam
    ], who wrote in article :

    > Some ATAPI units still fail running on DMA, so you have to disable DMA
    > busmastering for these units (/A:x /U:x /!BM).


    > Sounds like you have one of the units she is referring to.


    How do you imagine 20x DVD unit working without busmastering?! Of
    course it should work; but it might be that on Win* it makes some
    "tweaks of the system", or the VIA driver makes them...

    One more pieces of information:

    the bridge is 686A rev 22 (this is not reported by DaniS506, but by pci.exe)

    limiting the speed of device: No UDMA modes work (down to UDMA0),
    MwordDMA2 works (it has the same speed as UDMA0, 16MB/sec; too low
    for this device); done via /MR:034.

    Puzzled,
    Ilya

  15. Re: LITE-ON DVDRW LH-20A1H on VIA 571

    On Mon, 16 Jul 2007 03:00:02 UTC, Ilya Zakharevich
    wrote:

    > 0.3.14 DANI:0.3#@##1## 14.2.2003 9:47:41


    Why don't you try to the latest versions of DaniAtapi
    and DaniS506 ? If it still fails, ask Dani.


    --
    Ruediger "Rudi" Ihle [S&T Systemtechnik GmbH, Germany]
    http://www.s-t.de
    Please remove all characters left of the "R" in my email address


  16. Re: LITE-ON DVDRW LH-20A1H on VIA 571

    [A complimentary Cc of this posting was NOT [per weedlist] sent to
    Ilya Zakharevich
    ], who wrote in article :
    > limiting the speed of device: No UDMA modes work (down to UDMA0),
    > MwordDMA2 works (it has the same speed as UDMA0, 16MB/sec; too low
    > for this device); done via /MR:034.


    Unfortunately, while reading with MwordDMA2 works, burning traps the
    system (somewhere in 32-bit code, nothing more detailed).

    cs=2a68 (acc=909b) ss=1550 (acc=c093)
    ds=es=gs=0160 Trap e

    is what I extracted from the trap info...

    Hmm,
    Ilya


  17. Re: LITE-ON DVDRW LH-20A1H on VIA 571

    [A complimentary Cc of this posting was sent to
    Ruediger Ihle
    ], who wrote in article :
    > On Mon, 16 Jul 2007 03:00:02 UTC, Ilya Zakharevich
    > wrote:
    >
    > > 0.3.14 DANI:0.3#@##1## 14.2.2003 9:47:41

    >
    > Why don't you try to the latest versions of DaniAtapi


    Good idea. (But upgrading did not help...)

    > and DaniS506 ?


    as I said, it is the latest one.

    > If it still fails, ask Dani.


    IIRC, she usually monitors this newsgroup. I plan to wait a couple
    more days before contacting her directly...

    Thanks,
    Ilya

  18. Re: LITE-ON DVDRW LH-20A1H on VIA 571

    On Mon, 16 Jul 2007 02:32:03 +0000 (UTC), Ilya Zakharevich
    wrote:

    > Error : Sense on 0x28 cmd : SK 0x04 ASC 0x08 ASCQ 0x03 (LOGICAL UNIT
    > COMMUNICATION CRC ERROR (ULTRA-DMA/32))
    > Error : Src: Cant read 32 blocks (total 32 failed) at pos 1312 (ets
    > 1): 31
    > Error : Cant read enough data (2686976 of 16777216 done) from <>
    > source
    > Error : Read only 2686976 bytes of 16777216 requested. rc 31


    So why didn't you post this the first time? It's pretty clear you have either
    a hardware problem or a problem with the lowest level base driver.
    Why waste time mucking about with OS2DASD, OS2ASPI, ASPIROUT etc. when the
    lower levels are not working?

    >> Why do yo never post any useful information?

    >
    > Sigh; some people just never learn to read...


    You never learnt to write properly.

    >> > ASPIROUTE is 11-15-01.

    >>
    >> That means nothing. If that refers to some unspecified date format where I
    >> guess you mean the year is 2001, then you are on an ancient old version.
    >> Why do you find it so difficult to post a BLDLEVEL string?

    >
    > OK, if you are so smart:
    >
    > File ASPIROUT.SYS has no LAN component-style version string.
    > No driver EA's were found


    That confirms you are on an ancient version. It didn't have a BLDLEVEL string.
    But you could have reported that fact, which in itself is useful information.

  19. Re: LITE-ON DVDRW LH-20A1H on VIA 571

    On Mon, 16 Jul 2007 02:54:03 +0000 (UTC), Ilya Zakharevich
    wrote:

    >> That means nothing. If that refers to some unspecified date format where I
    >> guess you mean the year is 2001, then you are on an ancient old version.

    >
    > Of course, updating to b10 does not change anything (AFAIU, this level
    > knows nothing about busmaster/whatever, so it should not matter).


    Of course not. The evidence from that CRC error message states as much.
    You chose not to post it, yet you must have known about it at the time.

  20. Re: LITE-ON DVDRW LH-20A1H on VIA 571

    On Mon, 16 Jul 2007 03:00:02 +0000 (UTC), Ilya Zakharevich
    wrote:

    >> os2aspi.dmd

    >
    > Downgraded (?) to Paul's version. 10.070 ===> 10.043


    There is no difference between the IBM 10.043 and 10.070 apart from the version
    number.
    My 10.043 is the same as the IBM 10.043 apart from that it has one very minor
    fix to some information reported that most people will never need to see.

+ Reply to Thread
Page 1 of 2 1 2 LastLast