I just bought my first two SATA disks. I cloned both from the PATA main
disk in this eCS system in order to among other things run Sysbench to
compare performance.

Right now I'm using the following motherboard on the bench before
installing it for use as my normal eCS system:
http://www.pcchips.com.tw/PCCWeb/Pro...=Specification
What that site fails to make clear is that the Intel ICH6 controller
supports only one PATA channel (master/slave), along with two SATA
channels (master/slave, master/slave). It does have a separate ITE 8212
controller that I have disabled for this exercise.

With BIOS IDE/SATA setting "enhanced", and 3 connected SATA devices,
IBMS506$ reports:
R1.7.1 /V
Daniela's Bus Master IDE Driver for OS/2 Version 1.7.1
Controller:0 Port:01F0 IRQ:0E Status:OK BusMaster Scatter/Gather
Intel ICH6 PATA host (8086:266F rev:03) on PCI 0:31.1 @33MHz
Unit:0 Status:OK ATAPI BusMaster MWordDMA1/PIO3
Model:MAT****A CR-585 ZB21
Controller:2 Port400 IRQ:0B Status:OK BusMaster Scatter/Gather
Intel ICH6 SATA host (8086:2651 rev:03) on PCI 0:31.2 @33MHz
Unit:0 Status:OK SMS:16 LBA NL:126 BusMaster UltraDMA5/PIO4 BPB
Model:IC35L090AVV207-0 V23OA66A
OS2:log phys BPB/BIOS IDE:log phys Total Sectors
C 10011 65535 65535 16383 Avail 160836480
H 255 16 255 16 16 OS2 160826715
S 63 63 63 63 63 % Used 99.99
Unit:1 Status:OK SMS:16 LBA NL:126 BusMaster UltraDMA6/PIO4 BPB
Model:SAMSUNG SP1614C SW100-30
OS2:log phys BPB/BIOS IDE:log phys Total Sectors
C 19457 65535 65535 16383 Avail 312581808
H 255 16 255 16 16 OS2 312576705
S 63 63 63 63 63 % Used 99.99
Controller:3 Port000 IRQ:0B Status:OK BusMaster Scatter/Gather
Intel ICH6 SATA host (8086:2651 rev:03) on PCI 0:31.2 @33MHz
Unit:0 Status:OK SMS:16 LBA NL:126 BusMaster UltraDMA5/PIO4 BPB
Model:HDS722580VLSA80 V32OA6MA
OS2:log phys BPB/BIOS IDE:log phys Total Sectors
C 10011 65535 65535 16383 Avail 160836480
H 255 16 255 16 16 OS2 160826715
S 63 63 63 63 63 % Used 99.99

To summarize HDs above:

HD1 80G PATA on SATA adapter on controller 2 master (connector-SATA1)
HD2 160G SATA on controller 2 slave (connector-SATA3)
HD3 80G SATA on controller 3 master (connector-SATA2)

Stenciled on the motherboard and in the manual the SATA connectors are
labeled as follows:

SATA1 SATA2
____| ____|

____| ____|
SATA3 SATA4

In the AMI BIOS, when I change from "enhanced" to "compatible", the
following two alternate sets of settings are displayed:

IDE Channels PATA Pri, SATA Sec
Compatible Mode Use SATAs SATA 1,2
or
IDE Channels SATA Pri, PATA Sec
Compatible Mode Use SATAs SATA 4,3

Testing all the logical combinations of 1, 2 or 3 SATA drives reveals
that in order for everything to work according to the SATA connector
labels, the BIOS settings above should be:

IDE Channels PATA Pri, SATA Sec
Compatible Mode Use SATAs SATA 2,4
or
IDE Channels SATA Pri, PATA Sec
Compatible Mode Use SATAs SATA 1,3

with PATA priority set making the SATA2 secondary master and SATA4 the
secondary slave, and with SATA priority set making the SATA1 primary
master and SATA3 primary slave.

Is my only problem a misleading BIOS? Is this how PATA & SATA are
supposed to play together when legacy software requires use of
compatible mode?
--
"In everything, do to others what you would have them do to you."
Matthew 7:12 NIV

Team OS/2 ** Reg. Linux User #211409

Felix Miata *** http://members.ij.net/mrmazda/partitioningindex.html

----== Posted via Newsfeeds.Com - Unlimited-Uncensored-Secure Usenet News==----
http://www.newsfeeds.com The #1 Newsgroup Service in the World! 120,000+ Newsgroups
----= East and West-Coast Server Farms - Total Privacy via Encryption =----