Compaq AP550 (piece of crap) + Adaptec 7892 problems - OS2

This is a discussion on Compaq AP550 (piece of crap) + Adaptec 7892 problems - OS2 ; Hi2all, against my better judgment I ignored my long standing principle of NEVER buying Compaq crap, and succumbed to getting an AP550, because I couldn't resist the offer.... Anyway this box has 2xPIII/866, 512M RIMM, 36G & 9G SCSI, LS120, ...

+ Reply to Thread
Results 1 to 8 of 8

Thread: Compaq AP550 (piece of crap) + Adaptec 7892 problems

  1. Compaq AP550 (piece of crap) + Adaptec 7892 problems

    Hi2all,

    against my better judgment I ignored my long standing principle of NEVER
    buying Compaq crap, and succumbed to getting an AP550, because I
    couldn't resist the offer....

    Anyway this box has 2xPIII/866, 512M RIMM, 36G & 9G SCSI, LS120, Matrox
    G400 and 40xCD

    The problem I am having is the onboard Adaptec 7892 generates a trap D
    ewhen I use the AICU160.add driver
    I have tried 2 versions that I have been able to find,

    6-01-00 11:29a 164,332 0 a--- AICU160.ADD v10.0 dated 2000
    06 01
    10-25-01 9:17a 169,548 0 ---- aicu160.add v10.3 dated
    2001.10.15

    Not being very up on Adaptec, this is my first (and definitely LAST)
    exposure, I have not applied any switches to see if this will affect
    matters......So 2 questions....

    1) anyone know of other drivers I could try.... if so feel free to email
    me
    2) any suggestions as to which (if any) switches might help....

    thanks in advance for any help....
    --
    Britt - britt os2ecs co uk...
    Winxx.. keep the apps.. junk the OS.. => http://www.ecomstation.com
    System uptime is 15 days 11:58 hrs/mins

  2. Re: Compaq AP550 (piece of crap) + Adaptec 7892 problems

    In article
    invalid@os2ecs.co.uk "Britt Turnbull" writes:

    > [(bought Compaq && not happy) == TRUE]
    >
    > The problem I am having is the onboard Adaptec 7892 generates a
    > trap D ewhen I use the AICU160.add driver
    > I have tried 2 versions that I have been able to find,
    >
    > [...]
    >
    > 10-25-01 9:17a 169,548 0 ---- aicu160.add
    > v10.3 dated 2001.10.15


    If it helps, I've been using the 169,548 version for ages now,
    without apparent problems, originally under Warp-4.52 and more
    recently under eCS-1.1 (randomised installation ). The card
    is a 29160N. Perhaps your card needs a firmware upgrade?
    --
    Andrew Stephenson


  3. Re: Compaq AP550 (piece of crap) + Adaptec 7892 problems

    Hi, I remember Folkert (Adaptec guru on comp.periphs.scsi) saying that the oem
    bios's can be flashed with the non-oem bios without a problem. Though
    should there be a problem, you can simply restore the OEM bios which was
    saved automatically when upgrading to the new bios.
    Before doing that, you might want to try giving the adapter a different
    irq through bios settings or maybe even that pci irq changer on hobbes,
    it could be conflicting with something causing the trap. Or perhaps
    even try the new testcase kernel (from 1/26) which is supposed to have
    fixed some irq issues.

    best of luck,
    regards,
    - dink

    On 26 Jan 2004 12:54:00 GMT, Britt Turnbull wrote:

    :Hi2all,
    :
    :against my better judgment I ignored my long standing principle of NEVER
    :buying Compaq crap, and succumbed to getting an AP550, because I
    :couldn't resist the offer....
    :
    :Anyway this box has 2xPIII/866, 512M RIMM, 36G & 9G SCSI, LS120, Matrox
    :G400 and 40xCD
    :
    :The problem I am having is the onboard Adaptec 7892 generates a trap D
    :ewhen I use the AICU160.add driver
    :I have tried 2 versions that I have been able to find,
    :
    : 6-01-00 11:29a 164,332 0 a--- AICU160.ADD v10.0 dated 2000
    :06 01
    :10-25-01 9:17a 169,548 0 ---- aicu160.add v10.3 dated
    :2001.10.15
    :
    :Not being very up on Adaptec, this is my first (and definitely LAST)
    :exposure, I have not applied any switches to see if this will affect
    :matters......So 2 questions....
    :
    :1) anyone know of other drivers I could try.... if so feel free to email
    :me
    :2) any suggestions as to which (if any) switches might help....
    :
    :thanks in advance for any help....
    :--
    :Britt - britt os2ecs co uk...
    :Winxx.. keep the apps.. junk the OS.. => http://www.ecomstation.com
    :System uptime is 15 days 11:58 hrs/mins




  4. Re: Compaq AP550 (piece of crap) + Adaptec 7892 problems


    On Mon, 26 Jan 2004 Britt Turnbull wrote:

    > against my better judgment I ignored my long standing principle of NEVER
    > buying Compaq crap, and succumbed to getting an AP550, because I
    > couldn't resist the offer....


    That principle should read "... NEVER buying crap with proprietary hardware
    ....", since it applies to HP as well. I don't know what IBM uses/used in
    their x86 desktops/servers.

    > The problem I am having is the onboard Adaptec 7892 generates a trap D
    > ewhen I use the AICU160.add driver
    > I have tried 2 versions that I have been able to find,


    > 6-01-00 11:29a 164,332 0 a--- AICU160.ADD v10.0 dated 2000
    > 06 01
    > 10-25-01 9:17a 169,548 0 ---- aicu160.add v10.3 dated
    > 2001.10.15


    > Not being very up on Adaptec, this is my first (and definitely LAST)
    > exposure, I have not applied any switches to see if this will affect
    > matters......So 2 questions....


    > 1) anyone know of other drivers I could try.... if so feel free to email
    > me


    Try:
    ftp://ftp.compaq.com/pub/softpaq/sp2...00/SP21853.txt
    ftp://ftp.compaq.com/pub/softpaq/sp2...00/SP21853.EXE

    You can extract the proprietary diskette images to a virtual floppy by
    running QRST5 -i,.* in a DOS box, then extract the resulting
    qimage?.img with tools like image.exe.

    The Symbios drivers don't work with the LSI/SYM53C8XX chips Compaq used,
    but with their own driver from Compaq. Maybe it's similar with the
    AIC-7892/7899 chips.

    /Olli/
    --
    WarpUpdates International/Deutschland
    http://www.warpupdates.mynetcologne.de/


  5. Spiirq Re: Compaq AP550 (piece of crap) + Adaptec 7892 problems

    Sir:

    dinkmeister wrote:
    > Hi, I remember Folkert (Adaptec guru on comp.periphs.scsi) saying that the oem
    > bios's can be flashed with the non-oem bios without a problem. Though
    > should there be a problem, you can simply restore the OEM bios which was
    > saved automatically when upgrading to the new bios.
    > Before doing that, you might want to try giving the adapter a different
    > irq through bios settings or maybe even that pci irq changer on hobbes,
    > it could be conflicting with something causing the trap. Or perhaps
    > even try the new testcase kernel (from 1/26) which is supposed to have
    > fixed some irq issues.
    >


    That IRQ router sys driver only seems to be able to map PCI irq pins
    #A-D to irq numbers, but not slots to irq numbers, in spite of it asking
    for card type and other info. If one has one or more cards that use all
    four PCI irq pins #A-D, then it cannot find an unique irq for a card
    that uses only one PCI irq pin on my machine.

    BTW, my machine only has irq 5, 9, 10, & 11 available and not
    preassigned to ISA & IDE. But I've mapped in BIOS all my PCI cards to
    irq 11 and they all work (except the sound card, which has a blown
    output amp, but the driver loads fine). This was an experiment I did a
    few days ago while checking out the sound card. The sound card does not
    work even if it is the only PCI card beside the video card installed, so
    that is not an issue.

    If I am wrong, please tell me how to change the setup (and boy I am
    going to be pissed if the new audio card drivers won't share irq).
    --
    Bill
    Thanks a Million!


  6. Re: Compaq AP550 (piece of crap) + Adaptec 7892 problems

    In article
    invalid@os2ecs.co.uk "Britt Turnbull" writes:

    > Thanks to the eCs installer, I was able to apply this
    > replacement driver using the update floppy, which applies the
    > new driver during the installer initialisation.....
    >
    > It works.....


    One is happy for you.

    > Now on to other Compaq stupidities......


    Thy cup of joy runneth over, methunks.
    --
    Andrew Stephenson


  7. Re: Compaq AP550 (piece of crap) + Adaptec 7892 problems

    I've got a 7895p (twin bus) in an Intellistation and it uses AIC7870 ok.
    I had to upgrade the PC bios to get over a few funnies.

    Oliver Rick wrote:
    > On Mon, 26 Jan 2004 Britt Turnbull wrote:
    >
    >
    >>against my better judgment I ignored my long standing principle of NEVER
    >>buying Compaq crap, and succumbed to getting an AP550, because I
    >>couldn't resist the offer....

    >
    >
    > That principle should read "... NEVER buying crap with proprietary hardware
    > ...", since it applies to HP as well. I don't know what IBM uses/used in
    > their x86 desktops/servers.
    >
    >
    >>The problem I am having is the onboard Adaptec 7892 generates a trap D
    >>ewhen I use the AICU160.add driver
    >>I have tried 2 versions that I have been able to find,

    >
    >
    >> 6-01-00 11:29a 164,332 0 a--- AICU160.ADD v10.0 dated 2000
    >>06 01
    >>10-25-01 9:17a 169,548 0 ---- aicu160.add v10.3 dated
    >>2001.10.15

    >
    >
    >>Not being very up on Adaptec, this is my first (and definitely LAST)
    >>exposure, I have not applied any switches to see if this will affect
    >>matters......So 2 questions....

    >
    >
    >>1) anyone know of other drivers I could try.... if so feel free to email
    >>me

    >
    >
    > Try:
    > ftp://ftp.compaq.com/pub/softpaq/sp2...00/SP21853.txt
    > ftp://ftp.compaq.com/pub/softpaq/sp2...00/SP21853.EXE
    >
    > You can extract the proprietary diskette images to a virtual floppy by
    > running QRST5 -i,.* in a DOS box, then extract the resulting
    > qimage?.img with tools like image.exe.
    >
    > The Symbios drivers don't work with the LSI/SYM53C8XX chips Compaq used,
    > but with their own driver from Compaq. Maybe it's similar with the
    > AIC-7892/7899 chips.
    >
    > /Olli/



  8. Re: Compaq AP550 (piece of crap) + Adaptec 7892 problems


    On Wed, 28 Jan 2004 Britt Turnbull wrote:

    >> Try:
    >> ftp://ftp.compaq.com/pub/softpaq/sp2...00/SP21853.txt
    >> ftp://ftp.compaq.com/pub/softpaq/sp2...00/SP21853.EXE


    > OK, I would have got to this eventually.... I dl'd the allfiles.txt and
    > was making my way thro' to get a list of all SP's for this box....


    allfiles.txt wasn't updated since "10/22/2002 - 5:23:09 AM" (see first line
    of file), but the HP site search revealed no new OS/2 support diskette for
    Compaq machines. Maybe someday when I'm stoned, I'll generate an ASCII file
    with Rexx to automatically download the text files from the ftp server and
    run grep over it to check for new OS/2 archives.

    Great to read that the even more bloated Compaq driver works now. :-)

    /Olli/
    --
    WarpUpdates International/Deutschland
    http://www.warpupdates.mynetcologne.de/


+ Reply to Thread