Warp3 on AMD64 box - OS2

This is a discussion on Warp3 on AMD64 box - OS2 ; Struggled for weeks to get Warp 452 working and with the help of this NG I finally got it going. Thought I would just see if Warp3 FP43 would work on the new box: (Motherboard MSI6741 with VIA K8T800 chipset ...

+ Reply to Thread
Results 1 to 7 of 7

Thread: Warp3 on AMD64 box

  1. Warp3 on AMD64 box

    Struggled for weeks to get Warp 452 working and with the help of this NG
    I finally got it going. Thought I would just see if Warp3 FP43 would
    work on the new box: (Motherboard MSI6741 with VIA K8T800 chipset and
    VIA 8237 South Bridge, CPU=AMD64 3400+, 1024 MB RAM, SATA 2x200GB drives
    and GeForce FX5200 video card). It did work!

    Did the following:
    1. Extracted a rar backup file of an Warp3 partition from the old box
    to a newly formatted HPFS partition on the new box.
    2. Edited (from XP using Hpfswk2.zip) the config.sys: REMMED old sound
    driver, old NIC driver, APM.SYS and VAPM.SYS and MOUSE.SYS and added
    AMOUSE.SYS (plus its directory).
    3. Replaced TESTCFG.SYS with Daniela´s patched version
    4. Used newest IBM basedevice drivers and of Daniela´s only
    DANIS506.ADD. (This might be peculiar to my box possibly due to buggy
    partitions, but had difficulty with other combination to get disk access.
    5. Change to VGA by ALT-F1 + V
    6. ALT-F1 + C to patch OS2LDR with PatchLDR.exe
    7. Reboot. Voila - first time

  2. Re: Warp3 on AMD64 box

    Krister Hallergard wrote:
    > Struggled for weeks to get Warp 452 working and with the help of this NG
    > I finally got it going. Thought I would just see if Warp3 FP43 would
    > work on the new box: (Motherboard MSI6741 with VIA K8T800 chipset and
    > VIA 8237 South Bridge, CPU=AMD64 3400+, 1024 MB RAM, SATA 2x200GB drives
    > and GeForce FX5200 video card). It did work!
    >
    > Did the following:
    > 1. Extracted a rar backup file of an Warp3 partition from the old box
    > to a newly formatted HPFS partition on the new box.
    > 2. Edited (from XP using Hpfswk2.zip) the config.sys: REMMED old sound
    > driver, old NIC driver, APM.SYS and VAPM.SYS and MOUSE.SYS and added
    > AMOUSE.SYS (plus its directory).
    > 3. Replaced TESTCFG.SYS with Daniela´s patched version
    > 4. Used newest IBM basedevice drivers and of Daniela´s only
    > DANIS506.ADD. (This might be peculiar to my box possibly due to buggy
    > partitions, but had difficulty with other combination to get disk access.
    > 5. Change to VGA by ALT-F1 + V
    > 6. ALT-F1 + C to patch OS2LDR with PatchLDR.exe
    > 7. Reboot. Voila - first time


    Proceded to install NIC and USP printer without problems, but Uniaud
    gave this message from config.sys when booting: "SYS1718: The system
    cannot find the file KEE specified in the DEVICE statment ..............
    unable to open 32-bit driver...." so neither Uniaud32.sys nor
    Unaud16.sys were loaded.

    Thought that maybe this was due to an IRQ conflict, as with Warp3 don´t
    have any updated kernel (with Warp4 I had kernel dated 2005-03-17) that
    perhaps doesn´t support IRQ sharing. To test this I installed the audio
    driver 823xAC97, which initially had given me an IRQ confilict message.
    No, it installed but gave med that loud 100 dB tone, so the problem is
    problably not an IRQ conflict. Now what?

  3. Re: Warp3 on AMD64 box

    On Wed, 30 Mar 2005 08:03:24 UTC, Krister Hallergard
    wrote:

    > "SYS1718: The system
    > cannot find the file KEE specified in the DEVICE statment
    > unable to open 32-bit driver...."


    The KEE API was introduced with Warp4/FP13 Kernels. So
    no wonder, that a driver using it will not work on Warp3.
    There might, however, be a non-KEE version of UNIAUD.

    --
    Ruediger "Rudi" Ihle [S&T Systemtechnik GmbH, Germany]
    http://www.s-t.de
    Please remove all characters left of the "R" in my email address


  4. Re: Warp3 on AMD64 box

    On Wed, 30 Mar 2005 08:03:24 UTC in comp.os.os2.setup.misc, Krister
    Hallergard wrote:

    > Uniaud
    > gave this message from config.sys when booting: "SYS1718: The system
    > cannot find the file KEE specified in the DEVICE statment ..............
    > unable to open 32-bit driver...."


    That means that Uniaud requires a Warp 4 (actually a 4.5x) kernel.

    --
    Trevor Hemsley, Brighton, UK.
    Trevor-Hemsley at dsl dot pipex dot com

  5. Re: Warp3 on AMD64 box

    Ruediger Ihle wrote:
    > On Wed, 30 Mar 2005 08:03:24 UTC, Krister Hallergard
    > wrote:
    >
    >
    >>"SYS1718: The system
    >>cannot find the file KEE specified in the DEVICE statment
    >>unable to open 32-bit driver...."

    >
    >
    > The KEE API was introduced with Warp4/FP13 Kernels. So
    > no wonder, that a driver using it will not work on Warp3.
    > There might, however, be a non-KEE version of UNIAUD.
    >

    Thak you Rudi. Where could I find a non-KEE version? My search so far
    has only brought me back to version 1.0.4 of april 2003 which is a KEE
    version.

  6. Re: Warp3 on AMD64 box

    Hi Krister

    Krister Hallergard wrote:
    > Ruediger Ihle wrote:
    >
    >> On Wed, 30 Mar 2005 08:03:24 UTC, Krister Hallergard
    >> wrote:
    >>
    >>
    >>> "SYS1718: The system cannot find the file KEE specified in the
    >>> DEVICE statment
    >>> unable to open 32-bit driver...."

    >>
    >>
    >>
    >> The KEE API was introduced with Warp4/FP13 Kernels. So
    >> no wonder, that a driver using it will not work on Warp3.
    >> There might, however, be a non-KEE version of UNIAUD.
    >>

    > Thak you Rudi. Where could I find a non-KEE version? My search so far
    > has only brought me back to version 1.0.4 of april 2003 which is a KEE
    > version.



    I think, but may be wrong, that the later uniaud drivers do not use the
    kee api.

    Have a look here for some later versions ftp://ftp.os2.kiev.ua/uniaud/

    Maybe this page will tell you which version to use for whatever sound
    chip you are using http://www.os2usr.org/os2sound.html

    Hope the above helps.

    Pete

  7. Re: Warp3 on AMD64 box

    Peter Brown wrote:
    > Hi Krister
    >
    > Krister Hallergard wrote:
    >
    >> Ruediger Ihle wrote:
    >>
    >>> On Wed, 30 Mar 2005 08:03:24 UTC, Krister Hallergard
    >>> wrote:
    >>>
    >>>
    >>>> "SYS1718: The system cannot find the file KEE specified in the
    >>>> DEVICE statment
    >>>> unable to open 32-bit driver...."
    >>>
    >>>
    >>>
    >>>
    >>> The KEE API was introduced with Warp4/FP13 Kernels. So
    >>> no wonder, that a driver using it will not work on Warp3.
    >>> There might, however, be a non-KEE version of UNIAUD.
    >>>

    >> Thak you Rudi. Where could I find a non-KEE version? My search so
    >> far has only brought me back to version 1.0.4 of april 2003 which is a
    >> KEE version.

    >
    >
    >
    > I think, but may be wrong, that the later uniaud drivers do not use the
    > kee api.
    >
    > Have a look here for some later versions ftp://ftp.os2.kiev.ua/uniaud/
    >
    > Maybe this page will tell you which version to use for whatever sound
    > chip you are using http://www.os2usr.org/os2sound.html
    >
    > Hope the above helps.
    >
    > Pete


    Thanks, have not found anything here that works with Warp3.

+ Reply to Thread