Exiftool - OS2

This is a discussion on Exiftool - OS2 ; The ExifTool 743 WPI package requires perl 5.8.8 installed. I already have perl 5.10 installed and working. The WPI will not allow installation unless I install an older version of perl (and then, only via a WPI)? Do I have ...

+ Reply to Thread
Page 2 of 2 FirstFirst 1 2
Results 21 to 25 of 25

Thread: Exiftool

  1. ExifTool 743 & perl 5.10

    The ExifTool 743 WPI package requires perl 5.8.8 installed. I already
    have perl 5.10 installed and working. The WPI will not allow
    installation unless I install an older version of perl (and then, only
    via a WPI)?

    Do I have to resort to WIC?

  2. Re: ExifTool 743 & perl 5.10

    On Fri, 19 Sep 2008 01:37:03 UTC, "Al Savage" wrote:

    > The ExifTool 743 WPI package requires perl 5.8.8 installed. I already
    > have perl 5.10 installed and working. The WPI will not allow
    > installation unless I install an older version of perl (and then, only
    > via a WPI)?
    >
    > Do I have to resort to WIC?


    For others who may run into this situation:

    I let WI install the perl 5.5.8 WPI package (downloaded from Paul
    Smedley's site), but WI still refused to install the ExifTool 7.43 WPI
    from hobbes ("perl ...5/8/8 not installed" or similar), so I gave up,
    used WIC to extract the ExifTool files. ExifTool works fine (AFAICT) at
    the commandline with perl 5.10 . The WarpIn installation was useless
    for me.

    I did let WI deinstall the outdated perl 5.8.8 package though, and that
    seemed to go OK. :roll:

  3. Re: ExifTool 743 & perl 5.10

    On Sun, 21 Sep 2008 12:43:06 -0500, Al Savage wrote:

    >> The ExifTool 743 WPI package requires perl 5.8.8 installed. I already
    >> have perl 5.10 installed and working. The WPI will not allow
    >> installation unless I install an older version of perl (and then, only
    >> via a WPI)?
    >>
    >> Do I have to resort to WIC?

    >
    > For others who may run into this situation:
    >
    > I let WI install the perl 5.5.8 WPI package (downloaded from Paul
    > Smedley's site), but WI still refused to install the ExifTool 7.43 WPI
    > from hobbes ("perl ...5/8/8 not installed" or similar), so I gave up,
    > used WIC to extract the ExifTool files. ExifTool works fine (AFAICT) at
    > the commandline with perl 5.10 . The WarpIn installation was useless
    > for me.
    >
    > I did let WI deinstall the outdated perl 5.8.8 package though, and that
    > seemed to go OK. :roll:


    Did you send feedback to the Exiftool package maintainer? No, of course
    you didn't.

    Perl 5.8.8 uses a different package ID:
    Paul Smedley\Perl\Perl\5\8\8
    to what ExifTool 7.43 does:
    Paul Smedley\Perl\Base\5\8\8
    so it is hardly surprising that it doesn't work.

    Perl 5.10.0 doesn't seem to have a WPI version as far as I can see, so I
    don't know how Oliver managed to get it to install on his system, using
    either version of Perl.
    I would suggest he takes the REQUIRES out in the circumstances.

    There, I've done something constructive and I don't even use any of this
    stuff. Now you do something constructive.

  4. Re: ExifTool 743 & perl 5.10

    Paul Ratcliffe wrote:
    > Perl 5.10.0 doesn't seem to have a WPI version as far as I can see, so I


    perl5100.wpi on hobbes

    piersante

  5. Re: ExifTool 743 & perl 5.10

    On Wed, 24 Sep 2008 07:25:10 +0200, piesse wrote:

    > Paul Ratcliffe wrote:
    >> Perl 5.10.0 doesn't seem to have a WPI version as far as I can see, so I

    >
    > perl5100.wpi on hobbes


    Which shows that the package ID there is
    "Paul Smedley\Perl\Base\5\10\0"
    which is compatible with that in the EXIFTOOL743.WPI

+ Reply to Thread
Page 2 of 2 FirstFirst 1 2