memory problem on a new machine - OS2

This is a discussion on memory problem on a new machine - OS2 ; On a new system with more physical ram than the old one (2 gig now, 1 gig before), when I execute the following rexx code the system churns and hangs and eventually (a long tim) there is an error message ...

+ Reply to Thread
Results 1 to 3 of 3

Thread: memory problem on a new machine

  1. memory problem on a new machine

    On a new system with more physical ram than the old one
    (2 gig now, 1 gig before), when I execute the following rexx
    code the system churns and hangs and eventually (a long
    tim) there is an error message saying memory full

    /* */
    src = sysfiletree('*',dirdata.,'FT')
    say src
    exit

    Sysfiletree is a rexx utilty function that just loads all the
    names of files in a directory into an array. There are only
    800 file in the directory in question. This works without trouble
    and instantly on all my other os2/ecs machines.

    So now on a newly configured machine somehow all available
    memory is being used up.

    Does anyone have any ideas about what configuration parameter
    may be the trouble? I've looked through config.sys for clues but
    haven't seen them, but I've never encountered anything like this
    and am not sure what to look for.

    Thanks,

    Tim Stephen


  2. Re: memory problem on a new machine

    On Tue, 20 May 2008 19:07:12 UTC, root@fast.foo.bar () wrote:

    > On a new system with more physical ram than the old one
    > (2 gig now, 1 gig before), when I execute the following rexx
    > code the system churns and hangs and eventually (a long
    > tim) there is an error message saying memory full
    >
    > /* */
    > src = sysfiletree('*',dirdata.,'FT')
    > say src
    > exit
    >
    > Sysfiletree is a rexx utilty function that just loads all the
    > names of files in a directory into an array. There are only
    > 800 file in the directory in question. This works without trouble
    > and instantly on all my other os2/ecs machines.
    >
    > So now on a newly configured machine somehow all available
    > memory is being used up.
    >
    > Does anyone have any ideas about what configuration parameter
    > may be the trouble? I've looked through config.sys for clues but
    > haven't seen them, but I've never encountered anything like this
    > and am not sure what to look for.
    >
    > Thanks,
    >
    > Tim Stephen


    The code works fine, for me, on my 2 GiB system. I think I would be
    seriously looking at doing a memory test.

    > http://www.memtest.org/download/1.70...+-1.70.iso.zip


    is highly recommended...

    One other thing, but it doesn't really seem to make any difference, is
    that the code should be:
    /* */
    src = sysfiletree('*','dirdata.','FT')
    say src
    exit

    with the word dirdata. in quotes (at least that is what the examples
    show).

    --
    From the eComStation 2.0 RC2 of Doug Bissett
    dougb007 at telus dot net
    (Please make the obvious changes, to e-mail me)


  3. Re: memory problem on a new machine

    On Tue, 20 May 2008 19:07:12 UTC, root@fast.foo.bar () wrote:

    > Does anyone have any ideas about what configuration parameter
    > may be the trouble?


    Most likely VIRTUALADDRESSLIMIT. Try to lower it's value.




    --
    Ruediger "Rudi" Ihle [S&T Systemtechnik GmbH, Germany]
    http://www.s-t.de
    Please remove all characters left of the "R" in my email address


+ Reply to Thread