On Wed, Oct 15, 2008 at 07:15:22PM -0400, French, Warron S CTR DISA NS wrote:

> Classification: UNCLASSIFIED
> Caveats: NONE
>
> I have downloaded, extracted, and compiled openssl a few times in the last
> week for use with apache-1.3.41 and mod_ssl-2.8.31-1.3.41, and for the first
> time today with php-5.2.6.


The install step likely failed to complete. When I built 0.9.8 for
the same platform, I got in the "lib" directory of the install tree:

lib/engines/libatalla.so
lib/engines/libaep.so
lib/engines/lib4758cca.so
lib/engines/libsureware.so
lib/engines/libgmp.so
lib/engines/libcswift.so
lib/engines/libchil.so
lib/engines/libnuron.so
lib/engines/libubsec.so
lib/pkgconfig/libcrypto.pc
lib/pkgconfig/libssl.pc
lib/pkgconfig/openssl.pc
lib/libssl.so.0.9.8
lib/libcrypto.so -> libcrypto.so.0.9.8
lib/libssl.so -> libssl.so.0.9.8
lib/libcrypto.so.0.9.8

>
> There was a link created from the libcrypto.so -> libcrypto.so.0.9.8.
>
> What's the problem? The file libcrypto.so.0.9.8 is never created. The
> libssl.so.0.9.8 is created and it is linked to from libssl.so, but not the
> file I need libcrypto.so.0.9.8.
>


Read the output of "make install" more carefully.

> I am working on building this on a SUN Sunfire T-2000 running Solaris
> (SPARC) 10 8/07 with kernel patch 127127-11 applied.


$ uname -srvi
SunOS 5.10 Generic_127127-11 SUNW,Sun-Fire-V440

--
Viktor.
__________________________________________________ ____________________
OpenSSL Project http://www.openssl.org
User Support Mailing List openssl-users@openssl.org
Automated List Manager majordomo@openssl.org