I read on a website (http://developer.mozilla.org/en/docs/NSS_FAQ) that OpenSSL does not support the PKCS #11 chip by default. I'm aware there is a patch for this, but I'm not sure if it's already installed. I'm currently working on an OpenSPARC. By typing "openssl version -a" in the terminal, I recieved the following informaiton:

OpenSSL 0.9.7d 17 Mar 2004 (+ security patches to 2006-09-29)
built on: date not available
platform: information not available
options: bn(64,32) md2(int) rc4(ptr,char) des(ptr,risc1,16,long) blowfish(ptr)
compiler: information not available
OPENSSLDIR: "/etc/sfw/openssl"

Is there a way to determine if the patch is installed and if the backend is set up? Any help would be greatly appreciated.

-Chris