I fixed it -- removed FIXCRIO from my qmail smtpd/run file
Sorry for the posting when this wasn't really an openssl problem... but I'd
like to post this follow up just in case someone googles it in the future if
they made the same mistake as me!

On Mon, Jun 30, 2008 at 1:32 PM, fbc wrote:

> I'm running a qmail server on Fedora Core 6 and have the latest version of
> OpenSSL (in the official fc6 yum repositories) for it:
> *[root@mail control]#* openssl version
> *OpenSSL 0.9.8b 04 May 2006*
>
> Since I upgraded to this newest version, no mail servers have been able to
> make encrypted connections, because of an error:
> *[root@mail control]#* openssl s_client -starttls smtp -crlf -connect
> mail.myhost.tld:25
> *CONNECTED(00000003)
> 24182:error:0D07209B:asn1 encoding routines:ASN1_get_object:too
> long:asn1_lib.c:142:
> 24182:error:0D068066:asn1 encoding routines:ASN1_CHECK_TLEN:bad object
> header:tasn_dec.c:1278:
> 24182:error:0D07803A:asn1 encoding routines:ASN1_ITEM_EX_D2I:nested asn1
> error:tasn_dec.c:208:Type=ASN1_PRINTABLE
> 24182:error:0D08303A:asn1 encoding routines:ASN1_TEMPLATE_NOEXP_D2I:nested
> asn1 error:tasn_dec.c:749:Field=value, Type=X509_NAME_ENTRY
> 24182:error:0D08303A:asn1 encoding routines:ASN1_TEMPLATE_NOEXP_D2I:nested
> asn1 error:tasn_dec.c:710:
> 24182:error:0D08303A:asn1 encoding routines:ASN1_TEMPLATE_NOEXP_D2I:nested
> asn1 error:tasn_dec.c:710:
> 24182:error:0D08303A:asn1 encoding routines:ASN1_TEMPLATE_NOEXP_D2I:nested
> asn1 error:tasn_dec.c:749:Field=issuer, Type=X509_CINF
> 24182:error:0D08303A:asn1 encoding routines:ASN1_TEMPLATE_NOEXP_D2I:nested
> asn1 error:tasn_dec.c:749:Field=cert_info, Type=X509
> 24182:error:1409000D:SSL routines:SSL3_GET_SERVER_CERTIFICATE:ASN1
> lib:s3_clnt.c:866:*
>
> Has anyone seen this before? Google searching and searching the mailing
> list archives hasn't returned anything for me.
> The way I setup qmail (www.qmailtoaster.org) has me setting up the pem
> file like this:
> http://wiki.qmailtoaster.com/index.p...&printable=yes
> Anyone forsee a problem with putting the key, cert and ca bundle of certs
> into one file?
> Thanks for any help
>