------=_Part_919_23293660.1206024943528
Content-Type: text/plain; charset=ISO-8859-1
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

Thanks Steve.

If this helps anyone fixing this issue here is the backtrace once SSL_accept
hangs:

SSL_accept
ssl23_accept
ssl23_get_client_hello
ssl23_read_bytes
BIO_read
sock_read
__read_nocancel



Thanks

On Thu, Mar 20, 2008 at 8:22 AM, Steve West wrote:

> We experienced a similar problem and had to back rev to 9.8.d
>
> Steve
>
> ----- Original Message -----
> *From:* Md Lazreg
> *To:* openssl-users@openssl.org
> *Sent:* Wednesday, March 19, 2008 8:04 PM
> *Subject:* SSL_accept hangs
>
> Hi,
>
> I have setup an SSL server that works fine up to 400 connected clients.
>
> When I try to have more then 400 clients, then my server hangs in the
> SSL_accept call.... This happens very randomly, sometimes beyond 1000
> connected clients...
>
> The server is dead once this happen and no other client can connect.
>
> Please note that I am using non blocking sockets so SSL_accept _should_
> return... but for whatever reason it does not.
>
> I am using openssl-0.9.8e
>
>
> Any suggestions please?
>
> Thanks
>
> ------------------------------
>
> No virus found in this incoming message.
> Checked by AVG.
> Version: 7.5.519 / Virus Database: 269.21.7/1335 - Release Date: 3/19/2008
> 9:54 AM
>
>


------=_Part_919_23293660.1206024943528
Content-Type: text/html; charset=ISO-8859-1
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

Thanks Steve.

If this helps anyone fixing this issue here is the backtrace once SSL_accept hangs:

SSL_accept
ssl23_accept
ssl23_get_client_hello
ssl23_read_bytes
BIO_read
sock_read
__read_nocancel




Thanks

On Thu, Mar 20, 2008 at 8:22 AM, Steve West <swest@cyglan.com> wrote:








We experienced a similar problem and had to back rev to
9.8.d

 

Steve


----- Original Message -----


From:
Md Lazreg



Sent: Wednesday, March 19, 2008 8:04
PM

Subject: SSL_accept hangs



Hi,

I have setup an SSL server that works fine up to 400
connected clients.

When I try to have more then 400 clients, then my
server hangs in the SSL_accept call.... This happens very randomly, sometimes
beyond 1000 connected clients...

The server is dead once this happen
and no other client can connect.

Please note that I am using non
blocking sockets so SSL_accept _should_ return... but for whatever reason it
does not.

I am using openssl-0.9.8e


Any suggestions
please?

Thanks





No virus found in this incoming message.
Checked by AVG.

Version: 7.5.519 / Virus Database: 269.21.7/1335 - Release Date: 3/19/2008
9:54 AM




------=_Part_919_23293660.1206024943528--
__________________________________________________ ____________________
OpenSSL Project http://www.openssl.org
User Support Mailing List openssl-users@openssl.org
Automated List Manager majordomo@openssl.org