I downloaded a snapshot and compiled with Apache2.2 with ssl3 and tls1
enabled.
When I connect with s_client -ssl3 or -tls1 I got the wrong version
number error.

openssl s_client -tls1 -connect localhost:8443
CONNECTED(00000003)
13464:error:1408F10B:SSL routines:SSL3_GET_RECORD:wrong version
number:s3_pkt.c:318:

openssl s_client -ssl3 -connect localhost:8443
CONNECTED(00000003)
13178:error:1408F10B:SSL routines:SSL3_GET_RECORD:wrong version
number:s3_pkt.c:318


/openssl s_client -connect localhost:8443
CONNECTED(00000003)
13444:error:140770FC:SSL routines:SSL23_GET_SERVER_HELLO:unknown
protocol:s23_clnt.c:631:


Anyone knows the latest stable snapshot?

Thanks,
Wei