Hello Everyone,

I have this peculiar problem where in who does not
list the right output or even no output. This is
however not the case when I login over telnet or even
HPUX Secure Shell (built on OpenSSH version 4.3p2)
(OpenSSH_4.3p2-hpn, OpenSSL 0.9.7i 14 Oct 2005
HP-UX Secure Shell-A.04.30.007, HP-UX Secure Shell
version)

Here is the sample when using OpenSSH 4.5p1:
After login with my user id and switching to root, I
issue following commands:

[root@bdhp4639:/root]
# who -m
[root@bdhp4639:/root]
# who am i
[root@bdhp4639:/root]
# whoami
root
[root@bdhp4639:/root]
# who
bi5822 pts/3 Dec 18 06:16

Now I logout and issue same commands:

[root@bdhp4639:/root]
# exit
logout

[az8793@bdhp4639:/home/az8793]
$ who -m
[az8793@bdhp4639:/home/az8793]
$ who am i
[az8793@bdhp4639:/home/az8793]
$ whoami
az8793
[az8793@bdhp4639:/home/az8793]
$

Notice that I am not identified as my user id; az8793
and user bi5822 is not even logged on. I have moved
/var/adm/wtmp and wtmps and touched them already.

I am running OpenSSH v4.5p1 and OpenSSL 0.9.8d on HPUX
11iv2 IA64:

[az8793@bdhp4639:/home/az8793]
$ ssh -V
OpenSSH_4.5p1, OpenSSL 0.9.7l 28 Sep 2006
[az8793@bdhp4639:/home/az8793]
$ openssl version
OpenSSL 0.9.8d 28 Sep 2006

Any help is greatly appreciated.

Thanks in advance.

Sharad Saraswat


__________________________________________________ __________________________________
Be a better friend, newshound, and
know-it-all with Yahoo! Mobile. Try it now. http://mobile.yahoo.com/;_ylt=Ahu06i...Dypao8Wcj9tAcJ