Try installing zlib-devel.

If you can apt-get install zlib, why can't you install openssh the
same way? Probably better than compiling from source anyway.

Scott

EJG wrote:
> On Debian Linux, kernel linux-image-2.6.15-1-486,
> after I donload the file: openssh-4.3p2.tar.gz, untar
> this and then execute ./configure
> After some lines, the proccess stop with this msg:
> ....
> checking for library containing basename... none
> required
> checking for deflate in -lz... no
> configure: error: *** zlib missing - please install
> first or check config.log ***
>
> I installed zlib package, with apt-get install, but
> dont solve the problem.
>
> Can anybody help me? thanks for all.
>
>
>
> __________________________________________________
> Do You Yahoo!?
> Tired of spam? Yahoo! Mail has the best spam protection around
> http://mail.yahoo.com
>
>


--
Scott Baker - RHCE
Canby Telcom System Administrator
503.266.8253