The more I look for the reason for this, I seem to have come to the conclusion that either the openssl version and the openssh versions are not compatable (seems likely) or there is a bug in the release of openssh. Some have had good result to carefully match the openss* versions and others have found that recompiling the openssh from source from the latest solved it. Of course the recompile sort of does the same thing as matching the versions in some cases. At anyrate, I hope this helps a little.

I will post again once I myself try the recompile option.