Were bthe keys ftped to your system in ascii or binary
format. They need to be transferred to your system in binary
format to keep the encoding correct. Check the keys again.
They might have got corrupted.

Cheers,
Varun

-----Original Message-----
From: Frans Englich [mailto:frans.englich@telia.com]
Sent: 26 May 2006 11:22
To: secureshell@securityfocus.com
Subject: Publick key authentication problem


Hi everyone,

I have trouble connection to a server with ssh. I've tried
solving this before, but failed. I won't stop this time
until this works.

These are the commands I execute:

--------------------------------
bash-2.05b$ exec ssh-agent bash
bash-2.05b$ export CVS_RSH=`which ssh`
bash-2.05b$ ssh-add
Enter passphrase for /home/frans/.ssh/id_dsa:
Identity added: /home/frans/.ssh/id_dsa
(/home/frans/.ssh/id_dsa)
--------------------------------

Running `ssh-add -l' in the current shell gives:

--------------------------------
2048 2e:f5:49:d6:21:a0:50:83:1e:a4:fd:90:66:5a:f5:76
/home/frans/.ssh/id_dsa
(DSA)
--------------------------------

Now, running `ssh -vvv englich@HOSTNAME 2> ssh.log' gives
"Permission denied (publickey)." The full output is
attached, ssh.log.


This is how my .ssh/ directory looks:

--------------------------------
bash-2.05b$ ls -alFh .ssh/
total 30K
drwx------ 2 frans users 136 May 17 19:38 ./
drwx------ 81 frans users 5.0K May 26 10:00 ../
-rw------- 1 frans users 1.3K May 17 18:28
id_dsa
-rw-r--r-- 1 frans users 1.1K May 17 18:28
id_dsa.pub
-rw-r--r-- 1 frans users 15K May 26 09:49
known_hosts

--------------------------------

Before identifying any problems, you should know that I
manage to *commit*
with CVS over ssh to another server, so something with my
ssh setup seems to
be right.

In my .ssh/known_hosts file, the server I'm having trouble
connecting to has
"ssh-rsa", while my files are "DSA" -- could this have to do
with it?
However, the server I can connect to is also "ssh-rsa", so
that seems to rule
it out.

What is wrong?

One might argue that my public key is corrupt on the server
side, but I sent
it as an email attachment(with the same MUA) in the same way
to the admins of
both servers.

I would really appreciate help on this, I've run out of
ideas. Let me know if
I can supply anymore info.


Cheers,

Frans


================================================== ================================================== ========================

Tech Mahindra, formerly Mahindra-British Telecom.


Disclaimer:


The contents of this E-mail (including the contents of the enclosure(s) or attachment(s) if any) are privileged and confidential material of Tech Mahindra and should not be disclosed to, used by or copied in any manner by anyone other than the intended addressee(s). In case you are not the desired addressee, you should delete this message and/or re-direct it to the sender. The views expressed in this E-mail message (including the enclosure(s) or attachment(s) if any) are those of the individual sender, except where the sender expressly, and with authority, states them to be the views of Tech Mahindra.


This e-mail message including attachment/(s), if any, is believed to be free of any virus. However, it is the responsibility of the recipient to ensure that it is virus free and Tech Mahindra is not responsible for any loss or damage arising in any way from its use.

================================================== ================================================== ========================