I am trying to scp a file to windows box running sshd from openssh. I
have keys setup and thus it authenticates, but when it's time to copy
it doesn't. I am not sure why. Also when I remove the keys and manually
enter the password, it works. Can't deduce the apparent reason in
anomaly. Below are the excerpt logs:

debug1: expecting SSH2_MSG_NEWKEYS
debug1: SSH2_MSG_NEWKEYS received
debug1: SSH2_MSG_SERVICE_REQUEST sent
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug1: Authentications that can continue:
publickey,password,keyboard-interactive
debug1: Next authentication method: publickey
debug1: Offering public key: /home/phoenix/.ssh/id_rsa
debug1: Authentications that can continue:
publickey,password,keyboard-interactive
debug1: Offering public key: /home/phoenix/.ssh/id_dsa
debug1: Server accepts key: pkalg ssh-dss blen 433
debug1: read PEM private key done: type DSA
debug1: Authentication succeeded (publickey).
debug1: channel 0: new [client-session]
debug1: Entering interactive session.
debug3: Trying to reverse map address 171.11.121.110.
Last login: Wed Oct 11 12:42:36 2006 from dbdev1.sd.intuit.com
debug1: permanently_set_uid: 1016/513
setreuid 1016: No such process
debug1: do_cleanup
debug1: client_input_channel_req: channel 0 rtype exit-status reply 0
debug1: channel 0: free: client-session, nchannels 1
Connection to 172.17.128.132 closed.
debug1: Transferred: stdin 0, stdout 0, stderr 38 bytes in 0.5 seconds
debug1: Bytes per second: stdin 0.0, stdout 0.0, stderr 77.3
debug1: Exit status 255