Loomis, Rip wrote:
> Jason.C.Burns@wellsfargo.com wrote:
> > I have a quick question. I'm building an rpm (ssh 4.2p1) for some RH-AS
> > machines and it's been working just fine. However, I needed to install
> > it on an older box (AS 2.1), and received the following error:

> [[deleted]]
> > My only question is that is openssh dependant on libc >= 2.3,
> > or is this due to the version of libc on my build machine?

>
> This is due to the version of libc on your build machine.
> If you need to support an older box you're going to either
> need to build on that box (or one with a compatible set of
> libraries) or else find a way to specify linkage with the
> older set of libraries.
>
> The usual solution is the former--I still have functional
> Solaris 2.5.1 boxes here just in case, to use as build hosts.


An alternative solution if building on an older machine just won't
work for some reason is to keep a chroot on the newer machine. I do
this and it is quite useful to build for the older platform. Create a
complete copy of the older system in a sub-directory and then use
chroot(1) to that location and build.

Bob

_______________________________________________
openssh-unix-dev mailing list
openssh-unix-dev@mindrot.org
http://www.mindrot.org/mailman/listi...enssh-unix-dev