> I have a quick question. I'm building an rpm (ssh 4.2p1) for
> some RH-AS
> machines and it's been working just fine. However, I needed
> to install
> it on an older box (AS 2.1), and received the following error:

> My only question is that is openssh dependant on libc >= 2.3,
> or is this due to the version of libc on my build machine?

This is due to the version of libc on your build machine.
If you need to support an older box you're going to either
need to build on that box (or one with a compatible set of
libraries) or else find a way to specify linkage with the
older set of libraries.

The usual solution is the former--I still have functional
Solaris 2.5.1 boxes here just in case, to use as build hosts.

Hope this helps--

openssh-unix-dev mailing list