Okay.

Uninstalled OpenSSL 0.9.7e, re-compiled and installed OpenSSL 0.9.7f.

Removed the copy of the ssh-rand-helper from /usr/local/libexec.

gmake distclean

re-ran config with appropriate params.

re-ran gmake

re-ran gmake tests -

the bug regarding symbolic links appears to be fixed in new openssl release

however, had some issues arise later in tests...

run test multiplex.sh ...
test connection multiplexing: envpass
test connection multiplexing: transfer
scp: failed copy /bin/ls
cmp: cannot open /tech_svc/SSH/openssh-4.0p1/regress/ls.copy
scp: corrupted copy of /bin/ls
test connection multiplexing: status 0
test connection multiplexing: status 1
test connection multiplexing: status 4
test connection multiplexing: status 5
test connection multiplexing: status 44
Master running (pid=10834)
Exit request sent.
failed connection multiplexing
gmake[1]: *** [t-exec] Error 1
gmake[1]: Leaving directory `/tech_svc/SSH/openssh-4.0p1/regress'
gmake: *** [tests] Error 2

Noticed on the console that repeated messages were being sent to console from
sshd daemon...

copied from the /var/adm/syslog...

Mar 24 15:02:43 srvname sshd[4368]: [ID 800047 auth.error] error: setsockopt
SO_KEEPALIVE: Socket operation on non-socket
Mar 24 15:02:46 srvname sshd[4400]: [ID 800047 auth.error] error: setsockopt
SO_KEEPALIVE: Socket operation on non-socket
Mar 24 15:02:47 srvname sshd[4402]: [ID 800047 auth.error] error: setsockopt
SO_KEEPALIVE: Socket operation on non-socket


So, there are still a few issues to resolve.

Thanks,

Larry

_______________________________________________
openssh-unix-dev mailing list
openssh-unix-dev@mindrot.org
http://www.mindrot.org/mailman/listi...enssh-unix-dev