NFS share across subnets - NFS

This is a discussion on NFS share across subnets - NFS ; Hi folks I'm having an issue mounting NFS shares where the clients and server are on different subnets. Here is the basic layout: Subnet 1 NFS Server 1 running RHEL NFS Server 2 running OS X Server 10.4 Subnet 2 ...

+ Reply to Thread
Results 1 to 2 of 2

Thread: NFS share across subnets

  1. NFS share across subnets

    Hi folks

    I'm having an issue mounting NFS shares where the clients and server
    are on different subnets. Here is the basic layout:

    Subnet 1
    NFS Server 1 running RHEL
    NFS Server 2 running OS X Server 10.4

    Subnet 2
    NFS Server 2 is multi-homed, so the second NIC is on Subnet 2 as
    192.168.0.1
    NFS Client 1 running OS X Server 10.4

    Now, I tried mounting the NFS share on NFS Client 1. This is the error
    I get:
    nfs server NFSServer2:/NFSDirectory: not responding
    mount_nfs: /local_directory: Input/output error

    Same thing if I try and mount the share from NFS Server 1.

    I know the network is configured properly because I can ssh to NFS
    Server 1 & 2 from NFS Client 1.

    I can also mount the share from NFS Server 2 on NFS Client 1 using the
    IP address 192.168.0.1, the mount only fails when using the external
    interface.

    Any idea on what I am doing wrong here? Is there a better solution I
    should be thinking of?

    -ben


  2. Re: NFS share across subnets


    devlyn76 wrote:
    > Hi folks
    >
    > I'm having an issue mounting NFS shares where the clients and server
    > are on different subnets. Here is the basic layout:
    >
    > Subnet 1
    > NFS Server 1 running RHEL
    > NFS Server 2 running OS X Server 10.4
    >
    > Subnet 2
    > NFS Server 2 is multi-homed, so the second NIC is on Subnet 2 as
    > 192.168.0.1
    > NFS Client 1 running OS X Server 10.4
    >
    > Now, I tried mounting the NFS share on NFS Client 1. This is the error
    > I get:
    > nfs server NFSServer2:/NFSDirectory: not responding
    > mount_nfs: /local_directory: Input/output error
    >
    > Same thing if I try and mount the share from NFS Server 1.
    >
    > I know the network is configured properly because I can ssh to NFS
    > Server 1 & 2 from NFS Client 1.
    >
    > I can also mount the share from NFS Server 2 on NFS Client 1 using the
    > IP address 192.168.0.1, the mount only fails when using the external
    > interface.
    >
    > Any idea on what I am doing wrong here? Is there a better solution I
    > should be thinking of?


    I'm guessing you are using UDP/IP. Perhaps there are re-assembly
    timeouts
    cuased by the extra hops, perhaps the MTUs mismatch and the fragments
    from one subnet are bigger than the other. TCP/.IP is your friend.

    >
    > -ben



+ Reply to Thread