No such device after kernel upgrade - Networking

This is a discussion on No such device after kernel upgrade - Networking ; I upgrade kernel from 2.6.18 to 2.6.26 on debian-40r4a. The network doesn't work after boot 2.6.26, but it works with 2.6.18 kernel. I've tried to rename the z25_persistent-net.rules file, but no new z25_persistent-net.rules generated after boot with 2.6.26, so the ...

+ Reply to Thread
Results 1 to 2 of 2

Thread: No such device after kernel upgrade

  1. No such device after kernel upgrade

    I upgrade kernel from 2.6.18 to 2.6.26 on debian-40r4a. The network
    doesn't work after boot 2.6.26, but it works with 2.6.18 kernel.

    I've tried to rename the z25_persistent-net.rules file, but no new
    z25_persistent-net.rules generated after boot with 2.6.26, so the
    problem remains.

    Thank you for your time.

    # /etc/init.d/networking restart
    Reconfiguring network interfaces...SIOCSIFADDR: No such device
    eth0: ERROR while getting interface flags: No such device
    SIOCSIFNETMASK: No such device
    eth0: ERROR while getting interface flags: No such device
    Failed to bring up eth0
    done.

    # ifconfig -a
    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:8 errors:0 dropped:0 overruns:0 frame:0
    TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:560 (560.0 b) TX bytes:560 (560.0 b)

    sit0 Link encap:IPv6-in-IPv4
    NOARP MTU 1480 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

    # cat /etc/network/interfaces
    auto lo
    iface lo inet loopback

    allow-hotplug eth0
    auto eth0
    iface eth0 inet static
    address 192.168.3.108
    netmask 255.255.255.0
    gateway 192.168.3.1
    #

  2. Re: No such device after kernel upgrade

    On Aug 21, 2:44*pm, "lovecreatesbea...@gmail.com"
    wrote:

    > eth0: ERROR while getting interface flags: No such device


    > sit0 * *Link encap:IPv6-in-IPv4


    My eth0 is missing and there is ``sit0'' which I've not specified in
    interfaces file. What's this sit0 thing?

+ Reply to Thread