Hi...
on my system (SuSE 10.3 64Bit 2.6.22.17-0.1-default) I will use a
WLAN-USB Stick (Device 008: ID 0bda:8187 Realtek Semiconductor Corp.).
I have installed the actual RTL8187 driver provided by YAST and so far
all dings seems ok.
When I plug the dongel dmesg notifies:
[...]
Feb 16 11:09:06 alpha kernel: usb 4-6: new high speed USB device using
ehci_hcd and address 9
Feb 16 11:09:06 alpha kernel: usb 4-6: new device found, idVendor=0bda,
idProduct=8187
Feb 16 11:09:06 alpha kernel: usb 4-6: new device strings: Mfr=1,
Product=2, SerialNumber=3
Feb 16 11:09:06 alpha kernel: usb 4-6: Product: RTL8187_Wireless_LAN_Adapter
Feb 16 11:09:06 alpha kernel: usb 4-6: Manufacturer:
Manufacturer_Realtek_RTL8187_
Feb 16 11:09:06 alpha kernel: usb 4-6: SerialNumber: 00E04C0712CC
Feb 16 11:09:06 alpha kernel: usb 4-6: configuration #1 chosen from 1 choice
Feb 16 11:09:06 alpha kernel: wmaster0: Selected rate control algorithm
'simple'
Feb 16 11:09:06 alpha kernel: phy3: hwaddr 00:e0:4c:07:12:cc, rtl8187 V1
+ rtl8225z2
Feb 16 11:09:06 alpha ifup: interface 'wmaster0' is a wlan helper
interface. Exiting.
Feb 16 11:09:06 alpha ifup: Network interface is managed from NetworkManager
Feb 16 11:09:06 alpha ifup: NetworkManager will be advised to set up wlan0
Feb 16 11:09:06 alpha ifup: but it cannot be assured from here.
[...]

so far, so good but when I choose the device by the network manager I get:
[...]
Feb 16 11:10:57 alpha kernel: wlan0: Initial auth_alg=0
Feb 16 11:10:57 alpha kernel: wlan0: authenticate with AP 00:0c:f6:0f:5d:37
Feb 16 11:10:57 alpha kernel: wlan0: RX authentication from
00:0c:f6:0f:5d:37 (alg=0 transaction=2 status=0)
Feb 16 11:10:57 alpha kernel: wlan0: authenticated
Feb 16 11:10:57 alpha kernel: wlan0: associate with AP 00:0c:f6:0f:5d:37
Feb 16 11:10:57 alpha kernel: wlan0: RX AssocResp from 00:0c:f6:0f:5d:37
(capab=0x431 status=0 aid=2)
Feb 16 11:10:57 alpha kernel: wlan0: associated
Feb 16 11:10:59 alpha dhclient: wmaster0: unknown hardware address type 801
Feb 16 11:10:59 alpha dhclient: wmaster0: unknown hardware address type 801
Feb 16 11:11:03 alpha dhclient: DHCPDISCOVER on wlan0 to 255.255.255.255
port 67 interval 5
Feb 16 11:11:08 alpha dhclient: DHCPDISCOVER on wlan0 to 255.255.255.255
port 67 interval 9
Feb 16 11:11:17 alpha dhclient: DHCPDISCOVER on wlan0 to 255.255.255.255
port 67 interval 12
Feb 16 11:11:29 alpha dhclient: DHCPDISCOVER on wlan0 to 255.255.255.255
port 67 interval 15
Feb 16 11:11:29 alpha dhclient: DHCPDISCOVER on wlan0 to 255.255.255.255
port 67 interval 15
Feb 16 11:11:44 alpha dhclient: caught deadly SIGTERM
Feb 16 11:11:44 alpha dhclient: could not restore resolv.conf: No such
file or directory
Feb 16 11:11:44 alpha dhclient: wmaster0: unknown hardware address type 801
[...]

Who can explain what's going wrong???

Thanks...

Bye