Problems with wireless card AirLink101-AWLC3026 on Linux (it shutsdown sporadically and can't connect to protected networks) - Networking

This is a discussion on Problems with wireless card AirLink101-AWLC3026 on Linux (it shutsdown sporadically and can't connect to protected networks) - Networking ; I switched my friend's laptop from Windows into Linux (Gentoo). Kernel is 2.6.19-gentoo-rc5. Wireless card worked on Windows with no problems. But on Linux there are two problems: 1. Card connects ok to unprotected network (no password) but shuts down ...

+ Reply to Thread
Results 1 to 2 of 2

Thread: Problems with wireless card AirLink101-AWLC3026 on Linux (it shutsdown sporadically and can't connect to protected networks)

  1. Problems with wireless card AirLink101-AWLC3026 on Linux (it shutsdown sporadically and can't connect to protected networks)

    I switched my friend's laptop from Windows into Linux (Gentoo). Kernel
    is 2.6.19-gentoo-rc5.
    Wireless card worked on Windows with no problems.

    But on Linux there are two problems:
    1. Card connects ok to unprotected network (no password) but shuts
    down periodically (after ~15 mins) for no apparent reason. Power light
    stays up but signal light doesn't flash at all. Once it is shut down
    'ifconfig' still shows it as 'UP' but no packets go through.

    2. It somehow doesn't connect to encrypted wireless network.
    Key on Windows was 10 zeros (0000000000). But when I set this through
    iwconfig:
    iwconfig wlan0 essid
    iwconfig wlan0 key s:0000000000
    ifconfig wlan0 up
    dhcpcd wlan0

    I tried to drop "s:' but still the same problem.
    Power light on the card begins flashing which means that it can't
    connect. My card is AirLink101 and I use binary blob driver with
    NDISwrapper.

  2. Re: Problems with wireless card AirLink101-AWLC3026 on Linux (itshuts down sporadically and can't connect to protected networks)

    I solved the problem myself.
    When the problem was happening I used 2.6.19 kernel with
    ndiswrapper-1.51.
    2.6.19 was released in the early 2007. And ndiswrapper-1.51 -- just
    recently in December 2007.

    Problem is gone once I upgraded the kernel to 2.6.23.


+ Reply to Thread