Hi all, I'm trying to configure my dhcpd server (3.0.1) so it can assing
an ip address after matching specific value for the option User Class
Information. All my client are windows XP SP2 so i set the ClassID on
each machine through the command:

ipconfig /setclassid "Con*" "USERCLASS"

Printing the network information i got a result as follow

----------------------------------------------------------
Scheda Ethernet Connessione alla rete locale (LAN):

Suffisso DNS specifico per connessione: dominio.it
Indirizzo IP. . . . . . . . . . . . . : 0.0.0.0
Subnet mask . . . . . . . . . . . . . : 0.0.0.0
Gateway predefinito . . . . . . . . . : 0.0.0.0
ID classe DHCP . . . . . . . . . . . : USERCLASS

-------------------------------------------------------

This is the configuration of my dhcpd server that seems working but it
doesn't match anythings

---------------------------------------------------------------
#code classid Windows
option classid code 77 = string;

#Declaration
class "sistema" {
match if substring(option classid,0,7) = "SYSEDIT";
}

subnet 10.10.10.0 netmask 255.255.255.0 {
authoritative;
pool {
allow members of "sistema";
deny unknown-clients;
range 10.10.10.39 10.10.10.40;
}
}
----------------------------------------------------------------

Looking into the packet with a sniffer I found the option information
like ascii-code as you can see follow

------------------------------------------------------------
Option: (t=77, l=7) User Class Information
Option (77) User Class Information
Length: 7
Value: 53595345444954
------------------------------------------------------------

Plaese help me to understand why isn't working and if is possible to get
back work.

thank you

Hermes