Hibernation problems - Networking

This is a discussion on Hibernation problems - Networking ; I have an acer aspire laptop. After hibernate, eth0 and ath0 do not want to work, I go tyhrough the motions saying ifconfig eth0 up etc, but it has no effect and the card seems to be boycotting me. It ...

+ Reply to Thread
Results 1 to 4 of 4

Thread: Hibernation problems

  1. Hibernation problems

    I have an acer aspire laptop. After hibernate, eth0 and ath0 do not
    want to work, I go tyhrough the motions saying ifconfig eth0 up etc,
    but it has no effect and the card seems to be boycotting me. It seems
    to return no errors, yet no pings get through. Any ideas?

  2. Re: Hibernation problems

    In comp.os.linux.networking Ignoramus5826 wrote:
    > I have an acer aspire laptop. After hibernate, eth0 and ath0 do not
    > want to work, I go tyhrough the motions saying ifconfig eth0 up etc,
    > but it has no effect and the card seems to be boycotting me. It seems
    > to return no errors, yet no pings get through. Any ideas?


    FWIW I have to use pccardctl to eject and insert an Atheros cardbus
    wireless card after suspend to disk or ram to get it to work again.

    Jerry

  3. Re: Hibernation problems

    On Tue, 14 Aug 2007 20:48:57 GMT, Jerry Peters wrote:
    > In comp.os.linux.networking Ignoramus5826 wrote:
    >> I have an acer aspire laptop. After hibernate, eth0 and ath0 do not
    >> want to work, I go tyhrough the motions saying ifconfig eth0 up etc,
    >> but it has no effect and the card seems to be boycotting me. It seems
    >> to return no errors, yet no pings get through. Any ideas?

    >
    > FWIW I have to use pccardctl to eject and insert an Atheros cardbus
    > wireless card after suspend to disk or ram to get it to work again.
    >


    Jerry, what about internal boards (not PCMCIA cards)? My atheros and
    eth0 are both internal, I have nothing in my PCMCIA slot.

    i

  4. Re: Hibernation problems

    In comp.os.linux.networking Ignoramus32732 wrote:
    > On Tue, 14 Aug 2007 20:48:57 GMT, Jerry Peters wrote:
    >> In comp.os.linux.networking Ignoramus5826 wrote:
    >>> I have an acer aspire laptop. After hibernate, eth0 and ath0 do not
    >>> want to work, I go tyhrough the motions saying ifconfig eth0 up etc,
    >>> but it has no effect and the card seems to be boycotting me. It seems
    >>> to return no errors, yet no pings get through. Any ideas?

    >>
    >> FWIW I have to use pccardctl to eject and insert an Atheros cardbus
    >> wireless card after suspend to disk or ram to get it to work again.
    >>

    >
    > Jerry, what about internal boards (not PCMCIA cards)? My atheros and
    > eth0 are both internal, I have nothing in my PCMCIA slot.
    >


    Try removing the relevant modules before suspending and modprobing
    them on resume might work. There's also a facility in later 2.6
    kernels to rebind a driver to a device that I vaguely recall hearing
    about. IIRC it's some file in sysfs for the device or driver that you
    echo some "magic" value to.

    Jerry

+ Reply to Thread