Squid and localhost - Networking

This is a discussion on Squid and localhost - Networking ; All IE clients when typing in "localhost" or "127.0.0.1" are directed to the squid proxy. I've tried excluding "localhost" and "127.0.0.1" in the proxy.pac file the same way I've excluded other locations on our network and it doesn't seem to ...

+ Reply to Thread
Results 1 to 3 of 3

Thread: Squid and localhost

  1. Squid and localhost

    All IE clients when typing in "localhost" or "127.0.0.1" are directed
    to the squid proxy. I've tried excluding "localhost" and "127.0.0.1"
    in the proxy.pac file the same way I've excluded other locations on
    our network and it doesn't seem to work.

    I would think IE would not send traffic destined for itself to the
    proxy and I would also expect the proxy.pac file to tell IE not use
    the proxy for these addresses. What am I missing?


  2. Re: Squid and localhost

    Nate wrote:
    > All IE clients when typing in "localhost" or "127.0.0.1" are directed
    > to the squid proxy. I've tried excluding "localhost" and "127.0.0.1"
    > in the proxy.pac file the same way I've excluded other locations on
    > our network and it doesn't seem to work.


    Is the particular version of IE you describe actually using your
    proxy.pac? (Check the web logs.)

    Chris

  3. Re: Squid and localhost

    On May 3, 5:54 am, Chris Davies wrote:
    > Nate wrote:
    > > All IE clients when typing in "localhost" or "127.0.0.1" are directed
    > > to the squid proxy. I've tried excluding "localhost" and "127.0.0.1"
    > > in the proxy.pac file the same way I've excluded other locations on
    > > our network and it doesn't seem to work.

    >
    > Is the particular version of IE you describe actually using your
    > proxy.pac? (Check the web logs.)
    >
    > Chris


    The proxy.pac is being used because the other listed exemptions bypass
    the proxy fine. It turns out that, after adding the localhost
    exemptions, the issue is only occurring on the box that I'm testing
    from... go figure. Not sure why this one box uses all the exemptions
    except for localhost (or 127.0.0.1) but all other machines appear to
    be fine. I can't find anything different about the test machine...
    I'll blame Mr. Gates and move on. Appreciate the response.


+ Reply to Thread