ARP problem. - Networking

This is a discussion on ARP problem. - Networking ; Hello, I'm trying to correct firmware for Edimax BR-6204Wg WiFi/router -> RTL-8186(MIPS 4Kc), 2M flash / 16M RAM, kernel 2.4.18. My config is: -------------- | Edimax | | | -------------- | | WiFi | | | -------------- | Switch | ...

+ Reply to Thread
Results 1 to 2 of 2

Thread: ARP problem.

  1. ARP problem.

    Hello,

    I'm trying to correct firmware for Edimax BR-6204Wg WiFi/router ->
    RTL-8186(MIPS 4Kc), 2M flash / 16M RAM, kernel 2.4.18.

    My config is:

    --------------
    | Edimax |
    | |
    --------------
    | |
    WiFi |
    |
    |
    --------------
    | Switch |
    --------------
    |
    WiFi |
    --|------------
    | PC |
    --------------

    Adressing: LAN is 192.168.1.0/24 WiFi is 192.168.2.0/24.
    Edimax is Wireless ISP mode.

    Problem: when I try to send something (ex ping) from Edimax to PC THRU
    WiFi, at the beginning it works. After ARP times out, response is "no
    response from PC". /proc/net/arp shows PC IP addr with zeros (unresloved
    AFAIK).

    If then I issue ex ping from PC -> ARP becomes valid, ping works.

    Question: where to look to try to solve this? Does IPTABLES on PC in
    some kind blocks ARP? (as it name suggests it shouldn't). On PC I have
    full normal "toolkit", but on Edimax my tools are VERY limited.

    Anyone has ideas??

    W.P.

  2. Re: ARP problem -> and solution

    Użytkownik W.P. napisał:
    > Hello,
    >
    > I'm trying to correct firmware for Edimax BR-6204Wg WiFi/router ->
    > RTL-8186(MIPS 4Kc), 2M flash / 16M RAM, kernel 2.4.18.
    >
    > My config is:
    >
    > --------------
    > | Edimax |
    > | |
    > --------------
    > | |
    > WiFi |
    > |
    > |
    > --------------
    > | Switch |
    > --------------
    > |
    > WiFi |
    > --|------------
    > | PC |
    > --------------
    >
    > Adressing: LAN is 192.168.1.0/24 WiFi is 192.168.2.0/24.
    > Edimax is Wireless ISP mode.
    >
    > Problem: when I try to send something (ex ping) from Edimax to PC THRU
    > WiFi, at the beginning it works. After ARP times out, response is "no
    > response from PC". /proc/net/arp shows PC IP addr with zeros (unresloved
    > AFAIK).
    >
    > If then I issue ex ping from PC -> ARP becomes valid, ping works.
    >
    > Question: where to look to try to solve this? Does IPTABLES on PC in
    > some kind blocks ARP? (as it name suggests it shouldn't). On PC I have
    > full normal "toolkit", but on Edimax my tools are VERY limited.
    >
    > Anyone has ideas??
    >
    > W.P.


    Problem was with network driver: it seems that the one located in
    /kernel/rtl8186 (rtl8186.o file, small: 17K) is buggy. When changed to
    driver in /kernel/drivers/net/rtl8186.o (a big one 195K) problem with
    ARP is gone. Switching drivers is mage by kernel .config:

    CONFIG_DRIVER_SPEEDUP=n
    DRIVER_SPEEDUP=n

    in network drivers -> Realtek section.

    W.P.

+ Reply to Thread