FreeBSD/zebraOSPF not updating routingtables - Network

This is a discussion on FreeBSD/zebraOSPF not updating routingtables - Network ; I am trying to get OSPF working but it won't work. I seem to overlook something, but can't figure out what it is. I have no practical experience in OSPF, just theoretical I have no experience in FreeBSD, just Linux ...

+ Reply to Thread
Results 1 to 4 of 4

Thread: FreeBSD/zebraOSPF not updating routingtables

  1. FreeBSD/zebraOSPF not updating routingtables

    I am trying to get OSPF working but it won't work. I seem to overlook
    something, but can't figure out what it is.
    I have no practical experience in OSPF, just theoretical
    I have no experience in FreeBSD, just Linux and solaris.
    I am not using IPv6, at least not conciously...
    The folowing is my situation, consisting of 4 machines:



    Internet
    ^
    |
    |
    +-----+------+
    | matrix |static route: 10.169.0.0/16 gw 10.1.0.2
    | w2K |
    |10.1.0.23/24|
    +-----+------+
    |
    | wired
    --------+-------+--------------+--------
    | |
    | |
    +-------+-------+ +-------+-------+
    | 10.1.0.1/24 | | 10.1.0.2/24 |
    | FreeBSD | | FreeBSD |
    | Vondel | | Patten |
    |10.169.129.1/32| |10.169.129.2/32|
    | DG=10.1.0.23 | | DG=10.1.0.23 |
    |10.169.128.1/24| |10.169.128.2/24|
    +-------+-------+ +-------+-------+
    | |
    | |
    --------+-------+--------------+--------
    | wireless
    |
    +--------+--------+
    |10.169.128.23/24 |
    | w98 |
    | linde |
    | DG=10.169.128.1 |
    +-----------------+


    matrix is a windows 2000 professional PC, routing traffic towards the
    internet
    vondel and Patten are FreeBSD machines, running Zebra OSPFd
    linde is a windows 98 machine for testing purposes

    All directly connected addresses can be pinged
    linde can ping matrix
    Both routers find neigboring interfaces, but no routing tables are updated.
    That is:
    - I cannot ping the dummy address of vondel from patten and v.v. (I even
    cannot ping the dummy addres of patten from patten)
    - when I disconnect the cable from 10.1.0.1, linde cannot ping 10.1.0.2
    anymore, while a route still exists

    What am I overlooking???? Please help!
    what do link#1-link#4 in the routingtables mean?

    Āll relevant configs I can think of can be found below.


    Regards,

    Perjan



    vondel# uname -a
    FreeBSD vondel.cyberkot.nl 5.0-RELEASE FreeBSD 5.0-RELEASE #0: Thu Jan 16
    22:16:53 GMT 2003
    root@hollin.btc.adaptec.com:/usr/obj/usr/src/sys/GENERIC i386
    vondel# ifconfig
    ep1: flags=8843 mtu 1500
    inet 10.1.0.1 netmask 0xffffff00 broadcast 10.1.0.255
    inet6 fe80::220:afff:feca:8099%ep1 prefixlen 64 scopeid 0x1
    ether 00:20:af:ca:80:99
    media: Ethernet 10baseT/UTP
    lo0: flags=8049 mtu 16384
    inet6 ::1 prefixlen 128
    inet6 fe80::1%lo0 prefixlen 64 scopeid 0x2
    inet 127.0.0.1 netmask 0xff000000
    wi0: flags=8843 mtu 1500
    inet 10.169.128.1 netmask 0xffffff00 broadcast 10.169.128.255
    inet6 fe80::202:6fff:fe06:a29e%wi0 prefixlen 64 scopeid 0x3
    ether 00:02:6f:06:a2:9e
    media: IEEE 802.11 Wireless Ethernet DS/11Mbps
    status: associated
    ssid wireless-maarssen 1:wireless-maarssen
    stationname NodeBisonspoor
    channel 3 authmode OPEN powersavemode OFF powersavesleep 100
    wepmode OFF weptxkey 1

    vondel# netstat -rn -f inet
    Routing tables

    Internet:
    Destination Gateway Flags Refs Use Netif Expire
    default 10.1.0.23 UGSc 1 98 ep1
    10.1/24 link#1 UC 3 0 ep1
    10.1.0.1 00:20:af:ca:80:99 UHLW 0 4 lo0
    10.1.0.2 00:20:af:be:80:53 UHLW 1 1698 ep1 257
    10.1.0.23 00:10:a7:05:b5:01 UHLW 3 4573 ep1 892
    10.169.128/24 link#3 UC 3 0 wi0
    10.169.128.1 00:02:6f:06:a2:9e UHLW 0 6 lo0
    10.169.128.2 00:02:6f:06:a2:7b UHLW 0 2 wi0 819
    10.169.128.20 00:02:2d:a5:17:ec UHLW 0 45 wi0 320
    127.0.0.1 127.0.0.1 UH 0 13 lo0



    Zebra-Vondel# sh run

    Current configuration:
    !
    hostname Zebra-Vondel
    password 8 [removed]
    enable password 8 [removed]
    log file /var/log/zebra.log
    service password-encryption
    !
    debug zebra events
    debug zebra kernel
    !
    interface dummy0
    description dummy/loopback interface
    ip address 10.169.129.1/32
    !
    interface ep1
    description wired ethernet
    bandwidth 10240
    ip address 10.1.0.1/24
    !
    interface lo0
    !
    interface wi0
    description wirelessAP
    bandwidth 11264
    ip address 10.169.128.1/24
    !
    !
    line vty
    !
    end

    Zebra-Vondel# sh ip route
    Codes: K - kernel route, C - connected, S - static, R - RIP, O - OSPF,
    B - BGP, > - selected route, * - FIB route

    K>* 0.0.0.0/0 via 10.1.0.23, ep1
    O 10.1.0.0/24 [110/10] is directly connected, ep1, 02:30:55
    C>* 10.1.0.0/24 is directly connected, ep1
    O 10.169.128.0/24 [110/9] is directly connected, wi0, 1d21h31m
    C>* 10.169.128.0/24 is directly connected, wi0
    C>* 127.0.0.0/8 is directly connected, lo0




    OSPF-Vondel# sh run

    Current configuration:
    !
    hostname OSPF-Vondel
    password 8 [removed]
    enable password 8 [removed]
    log file /var/log/ospfd.log
    service password-encryption
    !
    !
    !
    interface ep1
    !
    interface lo0
    !
    interface wi0
    !
    router ospf
    ospf router-id 10.169.129.1
    redistribute kernel
    redistribute connected
    redistribute static
    network 10.1.0.0/24 area 0.0.0.1
    network 10.169.0.0/16 area 0.0.0.1
    !
    line vty
    !
    end

    OSPF-Vondel# sh ip ospf
    OSPF Routing Process, Router ID: 10.169.129.1
    Supports only single TOS (TOS0) routes
    This implementation conforms to RFC2328
    RFC1583Compatibility flag is disabled
    SPF schedule delay 1 secs, Hold time between two SPFs 1 secs
    Refresh timer 10 secs
    This router is an ASBR (injecting external routing information)
    Number of external LSA 0
    Number of areas attached to this router: 1

    Area ID: 0.0.0.1
    Shortcutting mode: Default, S-bit consensus: no
    Number of interfaces in this area: Total: 2, Active: 4
    Number of fully adjacent neighbors in this area: 2
    Area has no authentication
    Number of full virtual adjacencies going through this area: 0
    SPF algorithm executed 16 times
    Number of LSA 4

    OSPF-Vondel# sh ip ospf neigh

    Neighbor ID Pri State Dead Time Address Interface
    RXmtL RqstL DBsmL
    10.169.129.2 1 Full/DR 00:00:35 10.1.0.2
    ep1:10.1.0.1 0 0 0
    10.169.129.2 1 Full/DR 00:00:35 10.169.128.2
    wi0:10.169.128.1 0 0 0

    OSPF-Vondel# sh ip ospf datab

    OSPF Router with ID (10.169.129.1)

    Router Link States (Area 0.0.0.1)

    Link ID ADV Router Age Seq# CkSum Link count
    10.169.129.1 10.169.129.1 1666 0x80000064 0xe0fa 2
    10.169.129.2 10.169.129.2 1668 0x80000063 0xfadd 2

    Net Link States (Area 0.0.0.1)

    Link ID ADV Router Age Seq# CkSum
    10.1.0.2 10.169.129.2 1663 0x8000005b 0x2925
    10.169.128.2 10.169.129.2 1674 0x8000005b 0xbb69




    patten# uname -a
    FreeBSD patten.cyberkot.nl 5.0-RELEASE FreeBSD 5.0-RELEASE #0: Thu Jan 16
    22:16:53 GMT 2003
    root@hollin.btc.adaptec.com:/usr/obj/usr/src/sys/GENERIC i386

    patten# ifconfig
    ed0: flags=8802 mtu 1500
    ether 00:00:b4:59:a7:1b
    ep1: flags=8843 mtu 1500
    inet 10.1.0.2 netmask 0xffffff00 broadcast 10.1.0.255
    inet6 fe80::220:afff:febe:8053%ep1 prefixlen 64 scopeid 0x2
    ether 00:20:af:be:80:53
    media: Ethernet 10baseT/UTP
    lo0: flags=8049 mtu 16384
    inet6 ::1 prefixlen 128
    inet6 fe80::1%lo0 prefixlen 64 scopeid 0x3
    inet 127.0.0.1 netmask 0xff000000
    wi0: flags=8843 mtu 1500
    inet 10.169.128.2 netmask 0xffffff00 broadcast 10.169.128.255
    inet6 fe80::202:6fff:fe06:a27b%wi0 prefixlen 64 scopeid 0x4
    ether 00:02:6f:06:a2:7b
    media: IEEE 802.11 Wireless Ethernet autoselect (DS/11Mbps)
    status: associated
    ssid wireless-maarssen 1:wireless-maarssen
    stationname Bisonpoorclient
    channel 3 authmode OPEN powersavemode OFF powersavesleep 100
    wepmode OFF weptxkey 1

    patten# netstat -rn -f inet
    Routing tables

    Internet:
    Destination Gateway Flags Refs Use Netif Expire
    default 10.1.0.23 UGSc 1 6 ep1
    10.1/24 link#2 UC 3 0 ep1
    10.1.0.1 00:20:af:ca:80:99 UHLW 0 5 ep1 178
    10.1.0.2 00:20:af:be:80:53 UHLW 0 4 lo0
    10.1.0.23 00:10:a7:05:b5:01 UHLW 3 1645 ep1 1158
    10.169.128/24 link#4 UC 4 0 wi0
    10.169.128.1 00:02:6f:06:a2:9e UHLW 0 4 wi0 888
    10.169.128.2 00:02:6f:06:a2:7b UHLW 0 4 lo0
    10.169.128.20 00:02:2d:a5:17:ec UHLW 0 2885 wi0 1193
    10.169.128.50 link#4 UHLW 1 1 wi0
    127.0.0.1 127.0.0.1 UH 0 28 lo0


    Zebra-Patten# sh run

    Current configuration:
    !
    hostname Zebra-Patten
    password 8 [removed]
    enable password 8 [removed]
    log file /var/log/zebra.log
    service password-encryption
    !
    debug zebra events
    debug zebra kernel
    !
    interface dummy0
    description dummy/loopback interface
    ip address 10.169.129.2/32
    !
    interface ed0
    !
    interface ep1
    description wired ethernet
    bandwidth 10240
    ip address 10.1.0.2/24
    !
    interface lo0
    !
    interface wi0
    description wirelessAP
    bandwidth 11264
    ip address 10.169.128.2/24
    !
    !
    line vty
    !
    end

    Zebra-Patten# sh ip route
    Codes: K - kernel route, C - connected, S - static, R - RIP, O - OSPF,
    B - BGP, > - selected route, * - FIB route

    K>* 0.0.0.0/0 via 10.1.0.23, ep1
    O 10.1.0.0/24 [110/10] is directly connected, ep1, 02:29:12
    C>* 10.1.0.0/24 is directly connected, ep1
    O 10.169.128.0/24 [110/9] is directly connected, wi0, 1d21h29m
    C>* 10.169.128.0/24 is directly connected, wi0
    C>* 127.0.0.0/8 is directly connected, lo0


    OSPF-Patten# sh run

    Current configuration:
    !
    hostname OSPF-Patten
    password 8 [removed]
    enable password 8 [removed]
    log file /var/log/ospfd.log
    service password-encryption
    !
    !
    !
    interface ed0
    !
    interface ep1
    !
    interface lo0
    !
    interface wi0
    !
    router ospf
    ospf router-id 10.169.129.2
    redistribute kernel
    redistribute connected
    redistribute static
    network 10.1.0.0/24 area 0.0.0.1
    network 10.169.0.0/16 area 0.0.0.1
    !
    line vty
    !
    end

    OSPF-Patten# sh ip ospf
    OSPF Routing Process, Router ID: 10.169.129.2
    Supports only single TOS (TOS0) routes
    This implementation conforms to RFC2328
    RFC1583Compatibility flag is disabled
    SPF schedule delay 1 secs, Hold time between two SPFs 1 secs
    Refresh timer 10 secs
    This router is an ASBR (injecting external routing information)
    Number of external LSA 0
    Number of areas attached to this router: 1

    Area ID: 0.0.0.1
    Shortcutting mode: Default, S-bit consensus: no
    Number of interfaces in this area: Total: 2, Active: 4
    Number of fully adjacent neighbors in this area: 2
    Area has no authentication
    Number of full virtual adjacencies going through this area: 0
    SPF algorithm executed 14 times
    Number of LSA 4

    OSPF-Patten# sh ip ospf neigh

    Neighbor ID Pri State Dead Time Address Interface
    RXmtL RqstL DBsmL
    10.169.129.1 1 Full/Backup 00:00:31 10.1.0.1
    ep1:10.1.0.2 0 0 0
    10.169.129.1 1 Full/Backup 00:00:30 10.169.128.1
    wi0:10.169.128.2 0 0 0
    OSPF-Patten# sh ip ospf datab

    OSPF Router with ID (10.169.129.2)

    Router Link States (Area 0.0.0.1)

    Link ID ADV Router Age Seq# CkSum Link count
    10.169.129.1 10.169.129.1 1475 0x80000064 0xe0fa 2
    10.169.129.2 10.169.129.2 1475 0x80000063 0xfadd 2

    Net Link States (Area 0.0.0.1)

    Link ID ADV Router Age Seq# CkSum
    10.1.0.2 10.169.129.2 1470 0x8000005b 0x2925
    10.169.128.2 10.169.129.2 1481 0x8000005b 0xbb69











  2. Re: FreeBSD/zebraOSPF not updating routingtables

    I don't know if this will fix your problem, but change your area to 0.
    0.0.0.1 is not a valid area number for OSPF.

  3. Re: FreeBSD/zebraOSPF not updating routingtables


    "Beavis" wrote in message
    news:4ce46789.0311041000.53afcbfa@posting.google.c om...
    > I don't know if this will fix your problem, but change your area to 0.
    > 0.0.0.1 is not a valid area number for OSPF.


    Another area is planned to be the backbone area in the future. It is not
    connected yet.
    Why is 0.0.0.1 not a valid area number?



  4. Re: FreeBSD/zebraOSPF not updating routingtables

    "Perjan Moors" wrote in message news:...
    > "Beavis" wrote in message
    > news:4ce46789.0311041000.53afcbfa@posting.google.c om...
    > > I don't know if this will fix your problem, but change your area to 0.
    > > 0.0.0.1 is not a valid area number for OSPF.

    >
    > Another area is planned to be the backbone area in the future. It is not
    > connected yet.
    > Why is 0.0.0.1 not a valid area number?


    Sorry, I was incorrect. I'm more used to area numbers represented as
    integers rather than a dotted form. It looks like everyone's finding
    their neighbors correctly, I don't see what's wrong here.

+ Reply to Thread