Hello

I have the following scenario:

2 sites A and B
each side has 2 adsl lines with static ips
4 draytek vigor 2700g routers (2 on each side)

I want to utilize 2 different site-to-site IPsec VPN tunnels.

Site A:
---------

Vigor #1 config:
-------------------
ip address 192.168.1.1/24
lan subnet 192.168.1.0/24

Vigor #2 config:
-------------------
ip address 192.168.2.1/24
lan subnet 192.168.2.0/24
--------------------------------------------------------------------------

Site B:
--------
Vigor #3 config:
---------------------
ip address 192.168.3.1/24
lan subnet 192.168.3.0/24


Vigor #4 config:
--------------------
ip address 192.168.4.1/24
lan subnet 192.168.4.0/24

-----------------------------------------------------------------------------------------
I have successfully established VPNs between Vigor1 <-> Vigor3
and Vigor2 <-> Vigor4

I can ping from router each site sucessfully.

-------------------------------------------------------------------------------------------


On site A there's a win2k3 server with Terminal Services enabled.
I have configured its network card with the following ip addresses:

192.168.1.5/24
192.168.2.5/24
default gateway: none

2 static route mappings:
route add 192.168.3.0/24 gateway 192.168.1.1
route add 192.168.4.0/24 gateway 192.168.2.1

---------------------------------------------------------------------------------------------

On Site B there is another Win2k3 Server with the following config on its
network card:
IP addresses:

192.168.3.5/24
192.168.4.5/24
default gateway: none

2 static route mappings:

route add 192.168.1.0/24 gateway 192.168.3.1
route add 192.168.2.0/24 gateway 192.168.4.1

---------------------------------------------------------------------------------------------------

When i try to ping from the server on Site A server on site B at ip address
192.168.3.5 i can get reply.
When i try to ping from the server on Site A server on site B at ip address
192.168.4.5 i can also get reply.


The problem is that after some seconds server on Site A stops get ping reply
from Server on Site B at ip adddres 192.168.4.5.
The same happens with server on Site B when tries to ping server on Site A
at ip address 192.168.2.5.

--------------------------------------------------------------------------------------------------------------------

First of all is it possible to to have 2 different VPNs between 2 sites with
2 servers with 1 nic on each server configured with 2 different subnets? Is
there a routing issue? Do i need 2 nics on each server to achieve this?

Thanks for any answers and sorry for any misunderstanding...