DSRepair exits with a -793 Error - Netware

This is a discussion on DSRepair exits with a -793 Error - Netware ; Hi, If anyone has had a similar problem to this or can suggest a solution I would be very grateful indeed... I'm running Netware 6 sp2 DS 10320.29. Our root server crashed this morning with a Netstorage problem that has ...

+ Reply to Thread
Results 1 to 5 of 5

Thread: DSRepair exits with a -793 Error

  1. DSRepair exits with a -793 Error

    Hi,

    If anyone has had a similar problem to this or can suggest a solution
    I would be very grateful indeed...

    I'm running Netware 6 sp2 DS 10320.29. Our root server crashed this
    morning with a Netstorage problem that has been plaguing me for
    several months now. I brought the machine up and ran DSRepair
    (unattended full repair)to rectify any problems caused by the Abend.
    The DSRepair log is attached and flags a -793 error for which I can
    find no info on other than an explanation of the error code in the
    docs:

    "This error is returned by the operating system to the DS when DS made
    a call into the operating system".

    I have purged the SYS volume incase that was causing a problem -
    although it shouldn't.

    Also I have run DSRepair on another server in the tree with a R/W
    replica of root on it. This had no problems.

    I have also run a repair local database on the Root server in case
    there were any issues with the physical structure of the DB and it
    flagged NO errors.

    That it fails during the creation of temporary files makes me wonder
    if it is somehow a permissions problem, but I'm not sure...






    /************************************************** **************************/
    NetWare 6.00 Directory Services Repair 10210.29, DS 10320.29
    Log file for server ".XXXX.XXXX" in tree "XXXX"
    Operation performed by: XXXXXXXXX

    ** Automated Repair Mode **
    Repairing Local Database
    Start: Monday, 22 December 2003 2:26:03 pm Local Time

    ** All disk amounts are approximations **
    ->Current available disk space: 8240 MB
    ->DSRepair may need to use: 6 MB
    ->Disk space remaining after operation: 8240 MB

    Physical Check
    Creating Temporary Files
    ERROR: Operation or update failed with Error: -793


    Repair process aborted

    ** Automated Repair Mode **
    Finish: Monday, 22 December 2003 2:26:07 pm Local Time
    Total repair time: 0:00:04

  2. Re: DSRepair exits with a -793 Error

    Hi again,

    I attempted to reboot the server this morning and it froze on loading
    NWMKDE.NLM.

    I attempted to load using the server -na -kf8 switches and it hangs on
    nlsadpt.nlm. Thinking that the registry might be corrupt I deleted all
    servcfg.* files - but no joy, the server still locks on NWMKDE.NLM.

    Any suggestions?





    p_mackie@hotmail.com (Paul) wrote in message news:...
    > Hi,
    >
    > If anyone has had a similar problem to this or can suggest a solution
    > I would be very grateful indeed...
    >
    > I'm running Netware 6 sp2 DS 10320.29. Our root server crashed this
    > morning with a Netstorage problem that has been plaguing me for
    > several months now. I brought the machine up and ran DSRepair
    > (unattended full repair)to rectify any problems caused by the Abend.
    > The DSRepair log is attached and flags a -793 error for which I can
    > find no info on other than an explanation of the error code in the
    > docs:
    >
    > "This error is returned by the operating system to the DS when DS made
    > a call into the operating system".
    >
    > I have purged the SYS volume incase that was causing a problem -
    > although it shouldn't.
    >
    > Also I have run DSRepair on another server in the tree with a R/W
    > replica of root on it. This had no problems.
    >
    > I have also run a repair local database on the Root server in case
    > there were any issues with the physical structure of the DB and it
    > flagged NO errors.
    >
    > That it fails during the creation of temporary files makes me wonder
    > if it is somehow a permissions problem, but I'm not sure...
    >
    >
    >
    >
    >
    >
    > /************************************************** **************************/
    > NetWare 6.00 Directory Services Repair 10210.29, DS 10320.29
    > Log file for server ".XXXX.XXXX" in tree "XXXX"
    > Operation performed by: XXXXXXXXX
    >
    > ** Automated Repair Mode **
    > Repairing Local Database
    > Start: Monday, 22 December 2003 2:26:03 pm Local Time
    >
    > ** All disk amounts are approximations **
    > ->Current available disk space: 8240 MB
    > ->DSRepair may need to use: 6 MB
    > ->Disk space remaining after operation: 8240 MB
    >
    > Physical Check
    > Creating Temporary Files
    > ERROR: Operation or update failed with Error: -793
    >
    >
    > Repair process aborted
    >
    > ** Automated Repair Mode **
    > Finish: Monday, 22 December 2003 2:26:07 pm Local Time
    > Total repair time: 0:00:04


  3. Re: DSRepair exits with a -793 Error

    Rename the NWMKDE.NLM to NWMKDE.OLD. This should get the server back up. It sounds like you have damaged NLM's. Depending on your NDS version, re-apply the latest NDS service pack and reboot. If the server is still at Nw6sp2, get the box to NW6sp3 ASAP. This patch has been extremely stable. Apply edir862sp5.exe in addition to the service pack.

    Have you been backing up NDS DIBs on this server? We can patch the server, then load Dsrepair with a hidden option to restore the DIB.


    Craig L Winberg
    Office 801-861-8261
    Cell 801-362-9842
    cwinberg@novell.com
    Novell, Inc., The leading provider of informatioN solutioNs
    www.novell.com


    >>> Paul 12/23/2003 4:01:18 AM >>>

    Hi again,

    I attempted to reboot the server this morning and it froze on loading
    NWMKDE.NLM.

    I attempted to load using the server -na -kf8 switches and it hangs on
    nlsadpt.nlm. Thinking that the registry might be corrupt I deleted all
    servcfg.* files - but no joy, the server still locks on NWMKDE.NLM.

    Any suggestions?





    p_mackie@hotmail.com (Paul) wrote in message news:...
    > Hi,
    >
    > If anyone has had a similar problem to this or can suggest a solution
    > I would be very grateful indeed...
    >
    > I'm running Netware 6 sp2 DS 10320.29. Our root server crashed this
    > morning with a Netstorage problem that has been plaguing me for
    > several months now. I brought the machine up and ran DSRepair
    > (unattended full repair)to rectify any problems caused by the Abend.
    > The DSRepair log is attached and flags a -793 error for which I can
    > find no info on other than an explanation of the error code in the
    > docs:
    >
    > "This error is returned by the operating system to the DS when DS made
    > a call into the operating system".
    >
    > I have purged the SYS volume incase that was causing a problem -
    > although it shouldn't.
    >
    > Also I have run DSRepair on another server in the tree with a R/W
    > replica of root on it. This had no problems.
    >
    > I have also run a repair local database on the Root server in case
    > there were any issues with the physical structure of the DB and it
    > flagged NO errors.
    >
    > That it fails during the creation of temporary files makes me wonder
    > if it is somehow a permissions problem, but I'm not sure...
    >
    >
    >
    >
    >
    >
    > /************************************************** **************************/
    > NetWare 6.00 Directory Services Repair 10210.29, DS 10320.29
    > Log file for server ".XXXX.XXXX" in tree "XXXX"
    > Operation performed by: XXXXXXXXX
    >
    > ** Automated Repair Mode **
    > Repairing Local Database
    > Start: Monday, 22 December 2003 2:26:03 pm Local Time
    >
    > ** All disk amounts are approximations **
    > ->Current available disk space: 8240 MB
    > ->DSRepair may need to use: 6 MB
    > ->Disk space remaining after operation: 8240 MB
    >
    > Physical Check
    > Creating Temporary Files
    > ERROR: Operation or update failed with Error: -793
    >
    >
    > Repair process aborted
    >
    > ** Automated Repair Mode **
    > Finish: Monday, 22 December 2003 2:26:07 pm Local Time
    > Total repair time: 0:00:04




  4. Re: DSRepair exits with a -793 Error

    Craig

    Thankyou very much for getting back to me.

    I ended up opening a ticket to resolve the corruption to the DS,
    rebuilding the server, applying sp3 and restoring all data over the
    holidays.

    I've never worked with DIBS before, but would appreciate advice to
    allow me to do this.

    All the best.


    Paul

    "Craig Winberg" wrote in message news:...
    > Rename the NWMKDE.NLM to NWMKDE.OLD. This should get the server back up. It sounds like you have damaged NLM's. Depending on your NDS version, re-apply the latest NDS service pack and reboot. If the server is still at Nw6sp2, get the box to NW6sp3 ASAP. This patch has been extremely stable. Apply edir862sp5.exe in addition to the service pack.
    >
    > Have you been backing up NDS DIBs on this server? We can patch the server, then load Dsrepair with a hidden option to restore the DIB.
    >
    >
    > Craig L Winberg
    > Office 801-861-8261
    > Cell 801-362-9842
    > cwinberg@novell.com
    > Novell, Inc., The leading provider of informatioN solutioNs
    > www.novell.com
    >
    >
    > >>> Paul 12/23/2003 4:01:18 AM >>>

    > Hi again,
    >
    > I attempted to reboot the server this morning and it froze on loading
    > NWMKDE.NLM.
    >
    > I attempted to load using the server -na -kf8 switches and it hangs on
    > nlsadpt.nlm. Thinking that the registry might be corrupt I deleted all
    > servcfg.* files - but no joy, the server still locks on NWMKDE.NLM.
    >
    > Any suggestions?
    >
    >
    >
    >
    >
    > p_mackie@hotmail.com (Paul) wrote in message news:...
    > > Hi,
    > >
    > > If anyone has had a similar problem to this or can suggest a solution
    > > I would be very grateful indeed...
    > >
    > > I'm running Netware 6 sp2 DS 10320.29. Our root server crashed this
    > > morning with a Netstorage problem that has been plaguing me for
    > > several months now. I brought the machine up and ran DSRepair
    > > (unattended full repair)to rectify any problems caused by the Abend.
    > > The DSRepair log is attached and flags a -793 error for which I can
    > > find no info on other than an explanation of the error code in the
    > > docs:
    > >
    > > "This error is returned by the operating system to the DS when DS made
    > > a call into the operating system".
    > >
    > > I have purged the SYS volume incase that was causing a problem -
    > > although it shouldn't.
    > >
    > > Also I have run DSRepair on another server in the tree with a R/W
    > > replica of root on it. This had no problems.
    > >
    > > I have also run a repair local database on the Root server in case
    > > there were any issues with the physical structure of the DB and it
    > > flagged NO errors.
    > >
    > > That it fails during the creation of temporary files makes me wonder
    > > if it is somehow a permissions problem, but I'm not sure...
    > >
    > >
    > >
    > >
    > >
    > >
    > > /************************************************** **************************/
    > > NetWare 6.00 Directory Services Repair 10210.29, DS 10320.29
    > > Log file for server ".XXXX.XXXX" in tree "XXXX"
    > > Operation performed by: XXXXXXXXX
    > >
    > > ** Automated Repair Mode **
    > > Repairing Local Database
    > > Start: Monday, 22 December 2003 2:26:03 pm Local Time
    > >
    > > ** All disk amounts are approximations **
    > > ->Current available disk space: 8240 MB
    > > ->DSRepair may need to use: 6 MB
    > > ->Disk space remaining after operation: 8240 MB
    > >
    > > Physical Check
    > > Creating Temporary Files
    > > ERROR: Operation or update failed with Error: -793
    > >
    > >
    > > Repair process aborted
    > >
    > > ** Automated Repair Mode **
    > > Finish: Monday, 22 December 2003 2:26:07 pm Local Time
    > > Total repair time: 0:00:04


  5. Re: DSRepair exits with a -793 Error

    On Tue, 06 Jan 2004 18:09:29 GMT, Craig Winberg wrote:
    > Have you been backing up NDS DIBs on this server? We can patch the
    > server, then load Dsrepair with a hidden option to restore the DIB.


    Ok, Craig, don't tease... Hidden switch for DSRepair that will restore a
    DIB set (from DSREPAIR -rc, I assume)?

    I know DSDump can restore these, but this is the first I've heard that
    there may be a way for us mere mortals to do it without having to call NTS
    and get a dialin.

    How's it done?


    --
    | David Gersic dgersic_@_niu.edu |
    | Chevrolet: Car Has Extensive Valve Rattle On Long Extended Trips. |
    | Email address is munged to avoid spammers. Remove the underscores. |

+ Reply to Thread