Re: Adding to Address Book not working. TB 3.0.1 - Mozilla

This is a discussion on Re: Adding to Address Book not working. TB 3.0.1 - Mozilla ; On 3 Feb., 08:36, John Doue wrote: > On 2/2/2010 11:27 PM, Ron Hunter wrote: > > > On 2/2/2010 10:20 AM, John Doue wrote: > >> On 2/2/2010 5:54 PM, Ron Hunter wrote: > >>> On 2/2/2010 2:46 AM, ...

+ Reply to Thread
Results 1 to 2 of 2

Thread: Re: Adding to Address Book not working. TB 3.0.1

  1. Re: Adding to Address Book not working. TB 3.0.1

    On 3 Feb., 08:36, John Doue wrote:
    > On 2/2/2010 11:27 PM, Ron Hunter wrote:
    >
    > > On 2/2/2010 10:20 AM, John Doue wrote:
    > >> On 2/2/2010 5:54 PM, Ron Hunter wrote:
    > >>> On 2/2/2010 2:46 AM, John Doue wrote:
    > >>>> Ron Hunter wrote:
    > >>>>> On 2/1/2010 9:34 AM, John Doue wrote:
    > >>>>>> On 2/1/2010 3:29 PM, Ron Hunter wrote:
    > >>>>>>> On 2/1/2010 6:01 AM, John Doue wrote:
    > >>>>>>>> On 2/1/2010 10:09 AM, Man-wai Chang to The Door (24000bps)
    > >>>>>>>> wrote:
    > >>>>>>>>> You using any add-on?

    >
    > >>>>>>>>>> When right-clicking on an emailaddressshowing in a
    > >>>>>>>>>> header, and selecting Add toAddressBook, nothing happens.
    > >>>>>>>>>> Any ideas why and how to solve this?

    >
    > >>>>>>>> Yes, I do! But the problem is there too in safe mode, so
    > >>>>>>>> add-ons do not appear to be an issue.

    >
    > >>>>>>> You might check the file attributes on youraddressbookfile to
    > >>>>>>> make sure it hasn't been set to 'read only'. Do you get an error
    > >>>>>>> message? Anything in 'activity monitor'?

    >
    > >>>>>> Ron, no error message, no activity whatsoever, nothing in Activity
    > >>>>>> Manager with respect to adding anaddress. The file is not
    > >>>>>> read-only, I just edited one contact without a hitch.

    >
    > >>>>> Have you checked to see if it is adding to your 'collected addresses'
    > >>>>> instead of the PersonalAddressBook?

    >
    > >>>> As I said in a previous post, I have disabled collected addresses. And
    > >>>> adding anaddressshould any way trigger a change in the UI so that
    > >>>> details to the addedaddresscan be entered. Here, nothing! And this
    > >>>> profile was created from scratch when 3.0.0 became public.

    >
    > >>>> I have tried going back to 2.xx (being careful, I had saved it
    > >>>> completely) and upgrade via Upgrade in Help. Same thing.

    >
    > >>>>> Since it is NOT working that way for others, likely this is either an
    > >>>>> option setting, or something messed up in the profile. That is not a
    > >>>>> TB3 bug. If you don't have the star after your 'from:'address
    > >>>>> entry, something is not right. I found that when I created a new
    > >>>>> profile, and only moved in my Inbox and Sent files, things worked a
    > >>>>> lot better.

    >
    > >>>> Eventually, I will try recreating my profile from scratch, time
    > >>>> permitting.

    >
    > >>>> I did not say it was a TB3 bug; until a cause is found or the problem
    > >>>> can be replicated in an identifiable manner, it is not possible to say
    > >>>> whether it is or not; the fact is I am not the only one in this
    > >>>> situation and finding the cause of this problem would be interesting
    > >>>> any
    > >>>> how.

    >
    > >>> Check Tools/Options/Composition/Addressing. Make sure you have the
    > >>> personaladdressbookselected there.

    >
    > >> Ron, I show LocalAddressBookselected. That is what you meant?

    >
    > >> After several hours of experimenting, decidedly, there is a problem in
    > >> my installation. I managed to get Add toAddressBookto work, even with
    > >> Nautipolis. So far, I still cannot identify the cause of my problem. But
    > >> I am not giving up.

    >
    > > A am not sure what 'LocalAddressBook' means. I have "PersonalAddress
    > >Book", and "Collected Addresses". I am sure you could define other
    > >addressbooks, and they would be listed in the list in the dialog box.
    > > Just make sure that is theaddressbookyou have been looking in for
    > > your new addresses.
    > > Do you have other .mab files in your profile?

    >
    > Ron, you are referring to addresses saved on outgoing emails (function
    > which I do not use) , which indeed shows PersonalAddressBook.
    >
    > As I explain in a prior post, the problem has been solved and its cause
    > found. When I add addresses from the header, they get added to my
    > Personaladdressbookand not to "Collected", exactly as I want. So, I
    > am now a happy camper!
    >
    > Now, since I do not use collectedaddress, the history.mab file is of no
    > use to me, but it keeps being recreated each time I launch TB. No harm
    > in that, but just a small detail I would like to correct if I can.
    >
    > Thanks for your help, which helped convince me not to give on trying to
    > find the cause of the problem.
    >
    > --
    > John Doue


    Those of you which miss the TD2 function to add an email address to a
    *selected* address book should vote on
    http://getsatisfaction.com/mozilla_m...as_good_as_2_0

    Erik

  2. Re: Adding to Address Book not working. TB 3.0.1

    On Feb 5, 9:08*pm, ErikThe3rd wrote:
    > On 3 Feb., 08:36, John Doue wrote:
    >
    >
    >
    > > On 2/2/2010 11:27 PM, Ron Hunter wrote:

    >
    > > > On 2/2/2010 10:20 AM, John Doue wrote:
    > > >> On 2/2/2010 5:54 PM, Ron Hunter wrote:
    > > >>> On 2/2/2010 2:46 AM, John Doue wrote:
    > > >>>> Ron Hunter wrote:
    > > >>>>> On 2/1/2010 9:34 AM, John Doue wrote:
    > > >>>>>> On 2/1/2010 3:29 PM, Ron Hunter wrote:
    > > >>>>>>> On 2/1/2010 6:01 AM, John Doue wrote:
    > > >>>>>>>> On 2/1/2010 10:09 AM, Man-wai Chang to The Door (24000bps)
    > > >>>>>>>> wrote:
    > > >>>>>>>>> You using any add-on?

    >
    > > >>>>>>>>>> When right-clicking on an emailaddressshowing in a
    > > >>>>>>>>>> header, and selecting Add toAddressBook, nothing happens.
    > > >>>>>>>>>> Any ideas why and how to solve this?

    >
    > > >>>>>>>> Yes, I do! But the problem is there too in safe mode, so
    > > >>>>>>>> add-ons do not appear to be an issue.

    >
    > > >>>>>>> You might check the file attributes on youraddressbookfile to
    > > >>>>>>> make sure it hasn't been set to 'read only'. Do you get an error
    > > >>>>>>> message? Anything in 'activity monitor'?

    >
    > > >>>>>> Ron, no error message, no activity whatsoever, nothing in Activity
    > > >>>>>> Manager with respect to adding anaddress. The file is not
    > > >>>>>> read-only, I just edited one contact without a hitch.

    >
    > > >>>>> Have you checked to see if it is adding to your 'collected addresses'
    > > >>>>> instead of the PersonalAddressBook?

    >
    > > >>>> As I said in a previous post, I have disabled collected addresses.And
    > > >>>> adding anaddressshould any way trigger a change in the UI so that
    > > >>>> details to the addedaddresscan be entered. Here, nothing! And this
    > > >>>> profile was created from scratch when 3.0.0 became public.

    >
    > > >>>> I have tried going back to 2.xx (being careful, I had saved it
    > > >>>> completely) and upgrade via Upgrade in Help. Same thing.

    >
    > > >>>>> Since it is NOT working that way for others, likely this is either an
    > > >>>>> option setting, or something messed up in the profile. That is not a
    > > >>>>> TB3 bug. If you don't have the star after your 'from:'address
    > > >>>>> entry, something is not right. I found that when I created a new
    > > >>>>> profile, and only moved in my Inbox and Sent files, things workeda
    > > >>>>> lot better.

    >
    > > >>>> Eventually, I will try recreating my profile from scratch, time
    > > >>>> permitting.

    >
    > > >>>> I did not say it was a TB3 bug; until a cause is found or the problem
    > > >>>> can be replicated in an identifiable manner, it is not possible tosay
    > > >>>> whether it is or not; the fact is I am not the only one in this
    > > >>>> situation and finding the cause of this problem would be interesting
    > > >>>> any
    > > >>>> how.

    >
    > > >>> Check Tools/Options/Composition/Addressing. Make sure you have the
    > > >>> personaladdressbookselected there.

    >
    > > >> Ron, I show LocalAddressBookselected. That is what you meant?

    >
    > > >> After several hours of experimenting, decidedly, there is a problem in
    > > >> my installation. I managed to get Add toAddressBookto work, even with
    > > >> Nautipolis. So far, I still cannot identify the cause of my problem.But
    > > >> I am not giving up.

    >
    > > > A am not sure what 'LocalAddressBook' means. I have "PersonalAddress
    > > >Book", and "Collected Addresses". I am sure you could define other
    > > >addressbooks, and they would be listed in the list in the dialog box.
    > > > Just make sure that is theaddressbookyou have been looking in for
    > > > your new addresses.
    > > > Do you have other .mab files in your profile?

    >
    > > Ron, you are referring to addresses saved on outgoing emails (function
    > > which I do not use) , which indeed shows PersonalAddressBook.

    >
    > > As I explain in a prior post, the problem has been solved and its cause
    > > found. When I add addresses from the header, they get added to my
    > > Personaladdressbookand not to "Collected", exactly as I want. So, I
    > > am now a happy camper!

    >
    > > Now, since I do not use collectedaddress, the history.mab file is of no
    > > use to me, but it keeps being recreated each time I launch TB. No harm
    > > in that, but just a small detail I would like to correct if I can.

    >
    > > Thanks for your help, which helped convince me not to give on trying to
    > > find the cause of the problem.

    >
    > > --
    > > John Doue

    >
    > Those of you which miss the TD2 function to add an email address to a
    > *selected* *address book should vote onhttp://getsatisfaction.com/mozilla_messaging/topics/tb3_0_multiple_ad...
    >
    > Erik


    A temporary solution was developed by a TB developer. See
    https://bugzilla.mozilla.org/show_bug.cgi?id=456167#c34

+ Reply to Thread