Bugzilla 3.4.4 Upgrade/Perl module version problem - Mozilla

This is a discussion on Bugzilla 3.4.4 Upgrade/Perl module version problem - Mozilla ; Greetings Running Red Hat Linux RHEL4. I'm trying to upgrade my 3.2.3 Bugzilla to 3.4.4. I cannot get 'checksetup.pl --check-modules' past the perl module DateTime::TimeZone. The error seems to be: Checking for DateTime-TimeZone (v0.71) found unknown version using the command ...

+ Reply to Thread
Results 1 to 2 of 2

Thread: Bugzilla 3.4.4 Upgrade/Perl module version problem

  1. Bugzilla 3.4.4 Upgrade/Perl module version problem

    Greetings
    Running Red Hat Linux RHEL4.

    I'm trying to upgrade my 3.2.3 Bugzilla to 3.4.4. I cannot get
    'checksetup.pl --check-modules' past the perl module
    DateTime::TimeZone. The error seems to be:
    Checking for DateTime-TimeZone (v0.71) found unknown version

    using the command checksetup.pl prints out tells me I'm up to date:
    /usr/bin/perl install-module.pl DateTime::TimeZone
    CPAN: Storable loaded ok (v2.13)
    Going to read '/root/.cpan/Metadata'
    Database was generated on Thu, 07 Jan 2010 00:31:40 GMT
    Installing DateTime::TimeZone version 1.08...
    DateTime::TimeZone is up to date (1.08).

    I even went so far as to comment out the check in Requirements.pm but
    then checksetup.pl blows up with:
    Can't locate Params/Validate.pm in @INC (@INC contains: . lib/x86_64-
    linux-thread-multi lib /usr/lib64/perl5/5.8.5/x86_64-linux-thread-
    multi /usr/lib/perl5/5.8.5 /usr/lib64/perl5/site_perl/5.8.5/x86_64-
    linux-thread-multi /usr/lib/perl5/site_perl/5.8.5 /usr/lib/perl5/
    site_perl /usr/lib64/perl5/vendor_perl/5.8.5/x86_64-linux-thread-
    multi /usr/lib/perl5/vendor_perl/5.8.5 /usr/lib64/perl5/vendor_perl/
    5.8.3/x86_64-linux-thread-multi /usr/lib/perl5/vendor_perl) at lib/
    DateTime/TimeZone/OffsetOnly.pm line 12, line 225.

    BEGIN failed--compilation aborted at lib/DateTime/TimeZone/
    OffsetOnly.pm line 12, line 225.
    Compilation failed in require at (eval 334) line 3, line 225.


    Is there any way for me to get past this? I can't manually locate a
    Validate.pm file on my system either. Anyplace, let alone Params
    (which isn't there either.)

    Thanks so much for your help...glenn

  2. Re: Bugzilla 3.4.4 Upgrade/Perl module version problem

    Tim
    That did it! you get this week's prize for "Nicest Guy on the Net".
    (No cash stipend, however.)

    The date/time modules appear to be something of a rats nest.

    Thanks again for your help. Very cool....g


+ Reply to Thread