Bugzilla authentication for VPN access - Mozilla

This is a discussion on Bugzilla authentication for VPN access - Mozilla ; Greetings again, I encountered another problem: when accessing the bugzilla server (3.4.2) via VPN, the authentication is not cached - this means the according cookie is not set. This happens although I configured Firefox to allow all cookies from everywhere, ...

+ Reply to Thread
Results 1 to 2 of 2

Thread: Bugzilla authentication for VPN access

  1. Bugzilla authentication for VPN access

    Greetings again,

    I encountered another problem: when accessing the bugzilla server
    (3.4.2) via VPN, the authentication is not cached - this means the
    according cookie is not set. This happens although I configured
    Firefox to allow all cookies from everywhere, and I do not restrict
    the bugzilla session validity to a single IP.

    I'm using OpenVPN, and the VPN assigns another IP to my machine - I
    guess this causes the problem. Bugzilla is not usable as is, as it
    requests login every 2nd click, and sometimes (like when submitting a
    search) goes into an endless loop of login requests.

    Is there a solution or workaround?

    thanks, Joachim

  2. Re: Bugzilla authentication for VPN access

    On Sep 18, 6:36 am, James Barwick wrote:
    > Just so we can be sure:
    >
    > You set "loginnetmask" to 32 yes? It must be 32.
    >
    > You can find this on the User Authentication section in the Administration Parameters.
    >
    > make sure the cookie domain "cookiedomain" is not set (leave blank) IF you have problems. Else it's simply a good thing to keep around.


    James, thanks for pointing me into the right direction. I found the
    culprit: the cookie domain was set to the remote domain, and me coming
    in via VPN obviously have another domain. I cleared the cookie domain
    (as recommended), and now it works as expected.

    The loginnetmask is 0, still. I'll leave it like this as things work
    now.

    > Are you accessing Bugzilla server via a name ("bugzilla.mydomain.com") or by IP address ("10.0.3.233")???


    Via the IP for now, but will try the hostname once it is set up in our
    DNS.

    > I'd be curious to know if using an IP address works well with bugzilla...anyway, the "urlbase" and "sslbase" would have to match I guess.


    Yes, they are currently set to the IP-based path.

    thanks, Joachim

+ Reply to Thread