Re: Getting the correct CGI.pm for 3.4.2 - Mozilla

This is a discussion on Re: Getting the correct CGI.pm for 3.4.2 - Mozilla ; On Sep 13, 1:25*pm, Scott Barnes wrote: > David Miller (justd...@bugzilla.org) says... > > > Check in the /lib directory that's in the same directory with the rest > > of Bugzilla. *If you used the "install-module.pl" script to upgrade ...

+ Reply to Thread
Results 1 to 6 of 6

Thread: Re: Getting the correct CGI.pm for 3.4.2

  1. Re: Getting the correct CGI.pm for 3.4.2

    On Sep 13, 1:25*pm, Scott Barnes wrote:
    > David Miller (justd...@bugzilla.org) says...
    >
    > > Check in the /lib directory that's in the same directory with the rest
    > > of Bugzilla. *If you used the "install-module.pl" script to upgrade it
    > > in the past, it will have put it in that directory.

    >
    > Thanks Dave, you were right on the money. *Checksetup is now failing
    > during the database conversion, but I'll post a separate message for
    > that.
    >
    > -- Scott


    I'm hitting the same issue. I've checked bugzilla/lib/ and CGI.pm is
    in there. (I installed it using install-module.pl).

    I've tried deleting the file and re-running install-module.pl but it's
    still not being recognized.

    What can I do?

  2. Re: Getting the correct CGI.pm for 3.4.2

    On Sep 15, 6:19*am, Gervase Markham wrote:
    > On 15/09/09 00:40, TheMystic.ca wrote:
    >
    > > I'm hitting the same issue. I've checked bugzilla/lib/ and CGI.pm is
    > > in there. (I installed it using install-module.pl).

    >
    > > I've tried deleting the file and re-running install-module.pl but it's
    > > still not being recognized.

    >
    > "The file"? in the lib directory there's a CGI.pm file but also an
    > entire CGI directory. I think you need to delete that too.
    >
    > Gerv


    So I got it working by downloading CGI from CPAN.

    The problem was due to install-module.pl installing the latest version
    of CGI from CPAN not the correct (second latest) version.

  3. Re: Getting the correct CGI.pm for 3.4.2

    On Sep 15, 11:49*am, "TheMystic.ca" wrote:
    > On Sep 15, 6:19*am, Gervase Markham wrote:
    >
    > > On 15/09/09 00:40, TheMystic.ca wrote:

    >
    > > > I'm hitting the same issue. I've checked bugzilla/lib/ and CGI.pm is
    > > > in there. (I installed it using install-module.pl).

    >
    > > > I've tried deleting the file and re-running install-module.pl but it's
    > > > still not being recognized.

    >
    > > "The file"? in the lib directory there's a CGI.pm file but also an
    > > entire CGI directory. I think you need to delete that too.

    >
    > > Gerv

    >
    > So I got it working by downloading CGI from CPAN.
    >
    > The problem was due to install-module.pl installing the latest version
    > of CGI from CPAN not the correct (second latest) version.


    I have the same problem. When I tried to install from CPAN I still
    got v 3.47.
    Any Ideas

    Lee

  4. Re: Getting the correct CGI.pm for 3.4.2

    Guys, good morning!

    I had the same problem, and I only resolved after install the exact
    request module. For example :
    Request CGI.pm (v3.21) Found v3.47 blacklisted - I removed the 3.47
    and installed 3.21.

    I don't know why, and I didn't need the version 3.47, I needed that my
    bugzilla run...so, it resolved my problem...

    Best regards,
    Mariana Hoffart Dias


  5. Re: Getting the correct CGI.pm for 3.4.2

    On Sep 16, 2:29*pm, Lee wrote:
    > On Sep 15, 11:49*am, "TheMystic.ca" wrote:
    >
    >
    >
    > > On Sep 15, 6:19*am, Gervase Markham wrote:

    >
    > > > On 15/09/09 00:40, TheMystic.ca wrote:

    >
    > > > > I'm hitting the same issue. I've checked bugzilla/lib/ and CGI.pm is
    > > > > in there. (I installed it using install-module.pl).

    >
    > > > > I've tried deleting the file and re-running install-module.pl but it's
    > > > > still not being recognized.

    >
    > > > "The file"? in the lib directory there's a CGI.pm file but also an
    > > > entire CGI directory. I think you need to delete that too.

    >
    > > > Gerv

    >
    > > So I got it working by downloading CGI from CPAN.

    >
    > > The problem was due to install-module.pl installing the latest version
    > > of CGI from CPAN not the correct (second latest) version.

    >
    > I have the same problem. *When I tried to install from CPAN I still
    > got v 3.47.
    > Any Ideas
    >
    > Lee


    This worked for me to get from from the blacklisted 3.47 CGI back down
    to version 3.33:

    # CGI 3.47 was blacklisted, get back to 3.33
    pushd /tmp
    wget -P /tmp http://backpan.perl.org/authors/id/L...pm-3.33.tar.gz
    rm -rf CGI.pm-3.33
    tar zxvf CGI.pm-3.33.tar.gz
    cd CGI.pm-3.33
    perl Makefile.PL
    make
    make test
    # even if a newer CGI ws installed, installing an older module will
    overwrite (as w$
    make install
    popd
    pushd /var/www/html/bugzilla
    ../checksetup.pl

  6. Re: Getting the correct CGI.pm for 3.4.2

    On Sep 20, 9:29*pm, Taylor Monacelli
    wrote:
    > On Sep 16, 2:29*pm, Lee wrote:
    >
    >
    >
    > > On Sep 15, 11:49*am, "TheMystic.ca" wrote:

    >
    > > > On Sep 15, 6:19*am, Gervase Markham wrote:

    >
    > > > > On 15/09/09 00:40, TheMystic.ca wrote:

    >
    > > > > > I'm hitting the same issue. I've checked bugzilla/lib/ and CGI.pmis
    > > > > > in there. (I installed it using install-module.pl).

    >
    > > > > > I've tried deleting the file and re-running install-module.pl butit's
    > > > > > still not being recognized.

    >
    > > > > "The file"? in the lib directory there's a CGI.pm file but also an
    > > > > entire CGI directory. I think you need to delete that too.

    >
    > > > > Gerv

    >
    > > > So I got it working by downloading CGI from CPAN.

    >
    > > > The problem was due to install-module.pl installing the latest version
    > > > of CGI from CPAN not the correct (second latest) version.

    >
    > > I have the same problem. *When I tried to install from CPAN I still
    > > got v 3.47.
    > > Any Ideas

    >
    > > Lee

    >
    > This worked for me to get from from the blacklisted 3.47 CGI back down
    > to version 3.33:
    >
    > # CGI 3.47 was blacklisted, get back to 3.33
    > pushd /tmp
    > wget -P /tmphttp://backpan.perl.org/authors/id/L/LD/LDS/CGI.pm-3.33.tar.gz
    > rm -rf CGI.pm-3.33
    > tar zxvf CGI.pm-3.33.tar.gz
    > cd CGI.pm-3.33
    > perl Makefile.PL
    > make
    > make test
    > # even if a newer CGI ws installed, installing an older module will
    > overwrite (as w$
    > make install
    > popd
    > pushd /var/www/html/bugzilla
    > ./checksetup.pl


    Had the same problem:
    Bugzilla installer checksetup.pl continually asks to run:

    /usr/bin/perl install-module.pl CGI

    It would run successfully but checksetup.pl would not recognized that
    it was installed.
    Here is a recap of the steps from above:

    Download this file and extract it:
    wget http://backpan.perl.org/authors/id/L...pm-3.33.tar.gz
    tar zxvf CGI.pm-3.33.tar.gz

    Go into the folder build it:
    cd CGI.pm-3.33
    perl Makefile.PL
    make
    make test
    make install

    This will create a file and a folder:
    CGI.pm
    CGI

    Take these and replace the ones in the lib folder of your bugzilla
    installation.

    Then running ./checksetup.pl will acknowlege that you have installed
    the module and move forward on the installation.

+ Reply to Thread