Apache virtual host and bugzilla problem - Mozilla

This is a discussion on Apache virtual host and bugzilla problem - Mozilla ; Hi all, I'm facing a problem while I'm trying to configure multiple instances of bugzilla with apache virtual host. I've 3 bugzilla's instances named A, B and C. I would like that they run on A.mydomain.my B.mydomain.my and C.mydomain.my I ...

+ Reply to Thread
Results 1 to 2 of 2

Thread: Apache virtual host and bugzilla problem

  1. Apache virtual host and bugzilla problem

    Hi all,
    I'm facing a problem while I'm trying to configure multiple instances
    of bugzilla with apache virtual host.
    I've 3 bugzilla's instances named A, B and C. I would like that they
    run on A.mydomain.my B.mydomain.my and C.mydomain.my
    I configured apache virtual host in this way:

    NameVirtualHost


    ServerName A.mydomain.my
    serverAlias A
    DocumentRoot "/data/programs/bugzilla-3.0.2"
    SetEnv PROJECT A

    AddHandler cgi-script .cgi
    Options +Indexes +ExecCGI +FollowSymLinks
    DirectoryIndex index.cgi
    AllowOverride Limit
    Order allow,deny
    Allow from all

    AddType application/vnd.mozilla.xul+xml .xul
    AddType application/rdf+xml .rdf



    ServerName B.mydomain.my
    ServerAlias B
    DocumentRoot "/data/programs/bugzilla-3.0.2"
    SetEnv PROJECT B

    AddHandler cgi-script .cgi
    Options +Indexes +ExecCGI +FollowSymLinks
    DirectoryIndex index.cgi
    AllowOverride Limit
    Order allow,deny
    Allow from all

    AddType application/vnd.mozilla.xul+xml .xul
    AddType application/rdf+xml .rdf



    ServerName C.mydomain.my
    serverAlias C
    DocumentRoot "/data/programs/bugzilla-3.2.3"
    SetEnv PROJECT C

    AddHandler cgi-script .cgi
    Options +Indexes +ExecCGI +FollowSymLinks
    DirectoryIndex index.cgi
    AllowOverride Limit
    Order allow,deny
    Allow from all

    AddType application/vnd.mozilla.xul+xml .xul
    AddType application/rdf+xml .rdf


    Instance A and B works fine but instance C compose in wrong way some
    urls on the index page.
    In fact going to http://C.mydomain.my i got the right index page of
    PROJECT C but the link "Install the Quick Search plugin" is
    "javascript:window.external.AddSearchProvider('http ://A.mydomain.my/
    search_plugin.cgi')"
    and the link "LogIn" is "http://A.mydomain.my/?GoAheadAndLogIn=1"
    It causes that when I log in I log in in A instance instead of C!

    I can't undertsand if this is an apache problem or a problem located
    in bugzilla configuration.

    Could you help me to understand where I should look into?

    Thank You

    Regards

    Mauro


  2. Re: Apache virtual host and bugzilla problem

    On Apr 24, 5:08*pm, "Tosh, Michael J" wrote:
    > > Instance A and B works fine but instance C compose in wrong way some
    > > urls on the index page.

    >
    > Sounds like your urlbase parameter. *Take a look at
    > /data/programs/bugzilla-3.2.3/data/params.C and look for the link to
    > A.mydomain.my.


    You are right Michael!
    Because I'm upgrading from an older version of bugzilla I copied the
    bugzilla-x-x-x/data in the new bugzilla-3.2.3/data and because, before
    releasing the new version of bugzilla, I wanted to do some test, I
    created a new "environment" with a new "urlbase" but in params file
    there was the old value!

    Thank You very much

    Regards

    Mauro

+ Reply to Thread