Get Bugzilla running - Mozilla

This is a discussion on Get Bugzilla running - Mozilla ; Hi, I have been trying to install Bugzilla on my Ubuntu 8.04 system but i cant get it running. The remaining issues I have are: * When accessing the Bugzilla directory (on local Apache server) I get this error message: ...

+ Reply to Thread
Results 1 to 2 of 2

Thread: Get Bugzilla running

  1. Get Bugzilla running

    Hi,

    I have been trying to install Bugzilla on my Ubuntu 8.04 system but i
    cant get it running.
    The remaining issues I have are:
    * When accessing the Bugzilla directory (on local Apache server) I get
    this error message:
    ---------
    Software error:

    The ./data/params file does not exist. You probably need to run
    checksetup.pl. at Bugzilla/Config.pm line 326.
    Compilation failed in require at /var/www/bugzilla-3.0.8/index.cgi
    line 34.
    BEGIN failed--compilation aborted at /var/www/bugzilla-3.0.8/index.cgi
    line 34.
    ---------

    *When running checksetup.pl it generates the below error:
    --------
    desktop:/var/www/bugzilla-3.0.8$ perl ./checksetup.pl

    * This is Bugzilla 3.0.8 on perl 5.8.8
    * Running on Linux 2.6.22-14-generic #1 SMP Sun Oct 14 23:05:12 GMT
    2007

    Checking perl modules...
    Checking for CGI.pm (v2.93) ok: found v3.43
    Checking for TimeDate (v2.21) ok: found v2.22
    Checking for DBI (v1.41) ok: found v1.607
    Checking for PathTools (v0.84) ok: found v3.29
    Checking for Template-Toolkit (v2.12) ok: found v2.20
    Checking for Email-Send (v2.00) ok: found v2.194
    Checking for Email-MIME (v1.861) ok: found v1.863
    Checking for Email-MIME-Modifier (v1.442) ok: found v1.443

    Checking available perl DBD modules...
    Checking for DBD-Pg (v1.45) not found
    Checking for DBD-mysql (v2.9003) ok: found v4.005

    The following Perl modules are optional:
    Checking for GD (v1.20) ok: found v2.35
    Checking for Template-GD (any) not found
    Checking for Chart (v1.0) ok: found v2.4.1
    Checking for GDGraph (any) ok: found v1.44
    Checking for GDTextUtil (any) ok: found v0.86
    Checking for XML-Twig (any) ok: found v3.32
    Checking for MIME-tools (v5.406) ok: found v5.427
    Checking for libwww-perl (any) ok: found v2.036
    Checking for PatchReader (v0.9.4) not found
    Checking for PerlMagick (any) ok: found v6.3.7
    Checking for perl-ldap (any) not found
    Checking for SOAP-Lite (any) not found
    Checking for HTML-Parser (v3.40) ok: found v3.56
    Checking for HTML-Scrubber (any) not found
    Checking for Email-MIME-Attachment-Stripper (any) not found
    Checking for Email-Reply (any) not found
    Checking for mod_perl (v1.999022) not found
    Checking for CGI.pm (v3.11) ok: found v3.43

    * NOTE: You must run any commands listed below as root.

    ************************************************** ********************
    * OPTIONAL MODULES *
    ************************************************** ********************
    * Certain Perl modules are not required by Bugzilla, but by *
    * installing the latest version you gain access to additional *
    * features. *
    * *
    * The optional modules you do not have installed are listed below, *
    * with the name of the feature they enable. If you want to install *
    * one of these modules, just run the appropriate command in the *
    * "COMMANDS TO INSTALL" section. *
    ************************************************** ********************

    ************************************************** *********************
    * MODULE NAME * ENABLES FEATURE(S)
    *
    ************************************************** *********************
    * Template-GD * Graphical Reports
    *
    * Email-Reply * Inbound Email
    *
    * Email-MIME-Attachment-Stripper * Inbound Email
    *
    * perl-ldap * LDAP Authentication
    *
    * HTML-Scrubber * More HTML in Product/Group
    Descriptions *
    * PatchReader * Patch Viewer
    *
    * SOAP-Lite * XML-RPC Interface
    *
    * mod_perl * mod_perl
    *
    ************************************************** *********************
    COMMANDS TO INSTALL:

    Template-GD: /usr/bin/perl -MCPAN -e 'install
    "Template::Plugin::GD::Image"'
    Email-Reply: /usr/bin/perl -MCPAN -e 'install "Email::Reply"'
    Email-MIME-Attachment-Stripper: /usr/bin/perl -MCPAN -e 'install
    "Email::MIME::Attachment::Stripper"'
    perl-ldap: /usr/bin/perl -MCPAN -e 'install "Net::LDAP"'
    HTML-Scrubber: /usr/bin/perl -MCPAN -e 'install "HTML::Scrubber"'
    PatchReader: /usr/bin/perl -MCPAN -e 'install "PatchReader"'
    SOAP-Lite: /usr/bin/perl -MCPAN -e 'install "SOAP::Lite"'
    mod_perl: /usr/bin/perl -MCPAN -e 'install "mod_perl2"'
    Reading ./localconfig...

    OPTIONAL NOTE: If you want to be able to use the 'difference between
    two
    patches' feature of Bugzilla (which requires the PatchReader Perl
    module
    as well), you should install patchutils from:

    http://cyberelk.net/tim/patchutils/

    Checking for DBD-mysql (v2.9003) ok: found v4.005
    Checking for MySQL (v4.1.2) ok: found v5.0.51a-3ubuntu5.4

    DBD::mysql::st execute failed: No database selected [for Statement
    "SHOW TABLE STATUS"] at Bugzilla/DB/Mysql.pm line 264
    Bugzilla:B::Mysql::bz_setup_database('Bugzilla:B::Mysql=HASH
    (0x97c12dc)') called at ./checksetup.pl line 144
    -------


    When running testserver.pl I got below result:
    ------
    TEST-OK Webserver is running under group id in $webservergroup.
    TEST-OK Got front picture.
    TEST-OK Webserver is executing CGIs via mod_cgi.
    TEST-FAILED Webserver is permitting fetch of http://127.0.0.1/bugzilla-3.0.8/localconfig.
    This is a serious security problem.
    Check your webserver configuration.
    -------

    I know I should fix the security issue but shouldn't Bugzilla be able
    to run anyway?
    I have tried to follow all instructions (changed httpd.conf file etc),
    the Apache servere is running fine showing CGI scripts etc.
    Have anyone experienced these problems and have any suggestions?

    Thanks!
    Jocke

  2. Re: Get Bugzilla running

    On 16 Apr, 13:15, Max Kanat-Alexander wrote:
    > jocke...@gmail.com wrote:
    > > DBD::mysql::st execute failed: No database selected [for Statement
    > > "SHOW TABLE STATUS"] at Bugzilla/DB/Mysql.pm line 264

    >
    > * * * * Wow, um, that is really weird. Are you sure that the settings in your
    > "localconfig" file are correct?
    >
    > * * * * -Max
    > --http://www.everythingsolved.com/
    > Competent, Friendly Bugzilla and Perl Services. Everything Else, too.


    The MySql seems to be running. When I use mysql-admin I can log in
    with an empty login name and pwd. Corresponding fields in
    localconfig.pl is also empty.
    Could that be a problem? That I have to have a account with a login
    name?

    Thanks for the help!

    //Jocke

+ Reply to Thread