Can't locate Authen/SASL.pm error when configuring e-mail in Bugzilla - Mozilla

This is a discussion on Can't locate Authen/SASL.pm error when configuring e-mail in Bugzilla - Mozilla ; I tried to configure the e-mail by changing the parameters as follows but no luck. I used the exact same settings that I got from mthe third party e-mail that I was able to configure in my outlook express, but ...

+ Reply to Thread
Results 1 to 3 of 3

Thread: Can't locate Authen/SASL.pm error when configuring e-mail in Bugzilla

  1. Can't locate Authen/SASL.pm error when configuring e-mail in Bugzilla

    I tried to configure the e-mail by changing the parameters as follows
    but no luck. I used the exact same settings that I got from mthe third
    party e-mail that I was able to configure in my outlook express, but
    was not sure where I can mention the port numbers:

    mail_delivery_method :
    SMTP

    mailfrom:
    my working e-mail address:
    asdf@mywebdomain.com

    smtpserver:
    smtpout.mywebdomain.net

    smtp_username:
    asdf@mywebdomain.com

    smtp_password:
    mypassword

    smtp_debug:
    on


    And get this error when I attempt to save the changes:

    The new value for smtp_username is invalid: Error requiring
    Authen::SASL: 'Can't locate Authen/SASL.pm in @INC (@INC contains: .
    lib C:/Perl/site/lib C:/Perl/lib) at
    (eval 104) line 3.

    And by enabling the debug on, where is the error log being updated?

    Interestingly, when I remove the smtp_username I don't get the error
    anymore!

    Regards
    Krishna

  2. Re: Can't locate Authen/SASL.pm error when configuring e-mail inBugzilla

    On Apr 13, 11:27*am, krishna81m wrote:
    > smtp_username:
    > asdf@mywebdomain.com
    > The new value for smtp_username is invalid:


    Change this to asdf. Usually you remove the @domain.name from the
    email to get the smtp username.

  3. Re: Can't locate Authen/SASL.pm error when configuring e-mail inBugzilla

    On 13 avr, 17:27, krishna81m wrote:
    > I tried to configure the e-mail by changing the parameters as follows
    > but no luck. I used the exact same settings that I got from mthe third
    > party e-mail that I was able to configure in my outlook express, but
    > was not sure where I can mention the port numbers:
    >
    > mail_delivery_method :
    > SMTP
    >
    > mailfrom:
    > my working e-mail address:
    > a...@mywebdomain.com
    >
    > smtpserver:
    > smtpout.mywebdomain.net
    >
    > smtp_username:
    > a...@mywebdomain.com
    >
    > smtp_password:
    > mypassword
    >
    > smtp_debug:
    > on
    >
    > And get this error when I attempt to save the changes:
    >
    > The new value for smtp_username is invalid: Error requiring
    > Authen::SASL: 'Can't locate Authen/SASL.pm in @INC (@INC contains: .
    > lib C:/Perl/site/lib C:/Perl/lib) at
    > (eval 104) line 3.
    >
    > And by enabling the debug on, where is the error log being updated?
    >
    > Interestingly, when I remove the smtp_username I don't get the error
    > anymore!
    >
    > Regards
    > Krishna


    hi,

    I got the same problem. Try to install SASL module for perl. On
    ubuntu it's named libauthen-sasl-perl.

    Cheers

    Jacques P.

+ Reply to Thread