3.0.2. The output generated by whineatnews.pl is showing blanks where
some variables are.

Here's part of whine.txt.tmpl:

All of these [% terms.bugs %] are in the [% status_descs.NEW %] or
[% status_descs.REOPENED %] state, and have not been
touched in [% Param("whinedays") %] days or more.
You need to take a look at them, and decide on an initial action.

And here's the output I get:

are in the or state, and have not been
touched in 2 days or more.
You need to take a look at them, and decide on an initial action.

But some variables are making it through. [% Param("whinedays") %]
above worked, and [% email %] works.

And this code from the template:

[% FOREACH bug = bugs %]
[%+ bug.summary %]
-> [% Param("urlbase") %]show_bug.cgi?id=[% bug.id %]
[% END %]
does generate the right set of bugs.

Also, and this may be related or not, when I run whineatnews.pl, I get
the following output:

sendmail: fatal: No recipient addresses found in message header
Content-Type: text/html

[Wed Nov 19 17:25:16 2008] whineatnews.pl: Use of uninitialized value
in pattern match (m//) at (eval 39) line 4.
[Wed Nov 19 17:25:16 2008] whineatnews.pl: Use of uninitialized value
in pattern match (m//) at (eval 39) line 4.
[Wed Nov 19 17:25:16 2008] whineatnews.pl: Use of uninitialized value
in substitution (s///) at (eval 43) line 45.
[Wed Nov 19 17:25:16 2008] whineatnews.pl: Use of uninitialized value
in substitution (s///) at (eval 43) line 45.

followed by HTML code showing:

Bugzilla has suffered an internal error. Please save this page and
send it to (my email address) with details of what you were doing at
the time this message appeared.
There was an error sending mail from '' to '':error when closing pipe
to /usr/lib/sendmail:

Any suggestions would be appreciated.