Satheesh,

I am having exactly same issue, did you already figure out how to deal
with?

Thanks.

Lee

On Sep 11, 5:05*am, Satheesh wrote:
> Thanks all,
>
> The add-on developed by us is getting installed under this directory
> *({user}/Library/Application
> Support/Mozilla/profiles/{gpou312}.defaults/extension/)* in name of
> toolbar GUID in Mac. More or less the add-on is getting installed in the
> similar folder structure in Windows and Linux box. In Windows and Linux
> the toolbar works fine, whereas it is not working in Mac. After
> investigation, we found all the files related to our toolbar are set
> with read-only setting. For our add-on, we are using sqlite db. Since
> sqlite is made read-only in the installation, toolbar cannot access it
> in write mode and doesn't work.
>
> Out of curiosity, I tried installing other add-ons like web developer
> tool and sqlite manager in Mac and found they are working. Also found
> all the files of those add-ons are having write permission. I have cross
> checked the install.rdf and chrome.manifest file of my add-on with these
> add-ons. I don't find any configuration stating this read-only setting.
>
> Is there any special setting required while packing the XPI files or is
> there any configuration setting to be done anywhere in the add-on.
> Please help in this regards.
>
> Thanks again,
>
> Satheesh
>
>
>
> Terry R. wrote:
> > The date and time was Thursday, September 10, 2009 1:31:55 AM, and on
> > a whim, Satheesh pounded out on the keyboard:

>
> >> Hi,

>
> >> I have created an extension for firefox, which is working fine with
> >> the firefox installed in Ubuntu and Windows OS. But when the same is
> >> installed in MAC OS. The extension folder has /read only/ access. So,
> >> I cannot modify the database which is inside the extension folder.

>
> >> Can you please help me in fixing it. I am struck in there which is
> >> delaying my release.

>
> >> Thank you

>
> >> Satheesh Rajagopal

>
> >> Engineer
> >> Aspire Systems,
> >> Chennai,
> >> Tamilnadu,
> >> India - 41

>
> > Hi Satheesh,

>
> > Is the folder being created in the users home folder? *If it's being
> > created in the Applications folder, I could see permissions being an
> > issue.

>
> > Terry R.