xmarks 3.3.3 will not sync bookmarks with FF 3.5.3 - Mozilla

This is a discussion on xmarks 3.3.3 will not sync bookmarks with FF 3.5.3 - Mozilla ; I have tried this with FF on the MacBook Pro running Snow Leopard and on a PC running WinXP (fresh install with service Pack 3). In both cases, xmarks stops transferring the bookmarks about 3/4 of the way through but ...

+ Reply to Thread
Results 1 to 3 of 3

Thread: xmarks 3.3.3 will not sync bookmarks with FF 3.5.3

  1. xmarks 3.3.3 will not sync bookmarks with FF 3.5.3

    I have tried this with FF on the MacBook Pro running Snow Leopard and
    on a PC running WinXP (fresh install with service Pack 3). In both
    cases, xmarks stops transferring the bookmarks about 3/4 of the way
    through but continues to display a moving status bar. Remaining
    bookmarks are not transferred beyond level 2 and passwords are not
    transferred.

    I have also tried to manually transfer bookmarks from the server to
    the PC/Mac and over-write the local bookmarks with the same result.

    Xmarks 3.3.3 works fine with FF 3.0.14. Xmarks 1.3.1 works fine with
    Safari 4.0.3.

    I have seen similar reports on the Net, but no solutions. Because this
    happens with fresh installs in two operating systems on different
    platforms, I doubt that corrupted profiles are at fault, and I suspect
    that this is a genuine problem with xmarks and FF.

  2. Re: xmarks 3.3.3 will not sync bookmarks with FF 3.5.3

    On Sep 25, 5:56*pm, "David McRitchie" wrote:
    > "Michael Denny" wrote...
    > > I have tried this with FF on the MacBook Pro running Snow Leopard and
    > > on a PC running WinXP (fresh install with service Pack 3). In both
    > > cases, xmarks stops transferring the bookmarks about 3/4 of the way
    > > through but *continues to display a moving status bar. Remaining
    > > bookmarks are not transferred beyond level 2 and passwords are not
    > > transferred.

    >
    > > I have also tried to manually transfer bookmarks from the server to
    > > the PC/Mac and over-write the local bookmarks with the same result.

    >
    > > Xmarks 3.3.3 works fine with FF 3.0.14. Xmarks 1.3.1 works fine with
    > > Safari 4.0.3.

    >
    > > I have seen similar reports on the Net, but no solutions. Because this
    > > happens with fresh installs in two operating systems on different
    > > platforms, I doubt that corrupted profiles are at fault, and I suspect
    > > that this is a genuine problem with xmarks and FF.

    >
    > Hi Michael,
    > I don't have a MAC, *but if you also have *"Sort Places" *extensionthere
    > is a note in the SortPlaces updates that * version 1.6 at author's sitefixes issues
    > caused by Xmarks in FF3.5
    > (see note for July 7, 2009, *updated to 1.6.4 since then)
    > *https://addons.mozilla.org/en-US/fir...ddon/9275*(but see author's site)
    > *http://www.andyhalford.com/sortplaces/index.html
    >
    > I don't have Xmarks (formerly Foxmarks) but the updated version 1.6.4 *of
    > SortPlaces fixed a problem I had with SortPlaces. * I had been asked ifI had
    > ever had Xmarks installed and I had not. * * If SortPlaces does not finish in
    > three seconds it is not working and does nothing, and that is the problemI had
    > even though I didn't have Xmarks.
    >
    > Unrelated sidenote: *Just saw another extension by Andy Halford that helps you create
    > customized most recent bookmarks. *
    > * *SearchPlaces :: Add-ons for Firefox * *(Marked Experimental)
    > * *https://addons.mozilla.org/en-US/firefox/addon/10920
    >
    > --
    > HTH,
    > David McRitchie, * extensions I use are briefly documented on my site
    > Firefox Custom: *http://www.mvps.org/dmcritchie/firefox/firefox.htm


    Thanks, David. I am pretty sure this has to do with the structure of
    my bookmarks, and I will check your suggestion out.

  3. Re: xmarks 3.3.3 will not sync bookmarks with FF 3.5.3

    On Sep 25, 9:02*pm, Michael Denny wrote:
    > On Sep 25, 5:56*pm, "David McRitchie" wrote:
    >
    >
    >
    > > "Michael Denny" wrote...
    > > > I have tried this with FF on the MacBook Pro running Snow Leopard and
    > > > on a PC running WinXP (fresh install with service Pack 3). In both
    > > > cases, xmarks stops transferring the bookmarks about 3/4 of the way
    > > > through but *continues to display a moving status bar. Remaining
    > > > bookmarks are not transferred beyond level 2 and passwords are not
    > > > transferred.

    >
    > > > I have also tried to manually transfer bookmarks from the server to
    > > > the PC/Mac and over-write the local bookmarks with the same result.

    >
    > > > Xmarks 3.3.3 works fine with FF 3.0.14. Xmarks 1.3.1 works fine with
    > > > Safari 4.0.3.

    >
    > > > I have seen similar reports on the Net, but no solutions. Because this
    > > > happens with fresh installs in two operating systems on different
    > > > platforms, I doubt that corrupted profiles are at fault, and I suspect
    > > > that this is a genuine problem with xmarks and FF.

    >
    > > Hi Michael,
    > > I don't have a MAC, *but if you also have *"Sort Places" *extension there
    > > is a note in the SortPlaces updates that * version 1.6 at author's site fixes issues
    > > caused by Xmarks in FF3.5
    > > (see note for July 7, 2009, *updated to 1.6.4 since then)
    > > *https://addons.mozilla.org/en-US/fir...ddon/9275*(but see author's site)
    > > *http://www.andyhalford.com/sortplaces/index.html

    >
    > > I don't have Xmarks (formerly Foxmarks) but the updated version 1.6.4 *of
    > > SortPlaces fixed a problem I had with SortPlaces. * I had been asked if I had
    > > ever had Xmarks installed and I had not. * * If SortPlaces does notfinish in
    > > three seconds it is not working and does nothing, and that is the problem I had
    > > even though I didn't have Xmarks.

    >
    > > Unrelated sidenote: *Just saw another extension by Andy Halford that helps you create
    > > customized most recent bookmarks. *
    > > * *SearchPlaces :: Add-ons for Firefox * *(Marked Experimental)
    > > * *https://addons.mozilla.org/en-US/firefox/addon/10920

    >
    > > --
    > > HTH,
    > > David McRitchie, * extensions I use are briefly documented on my site
    > > Firefox Custom: *http://www.mvps.org/dmcritchie/firefox/firefox.htm

    >
    > Thanks, David. I am pretty sure this has to do with the structure of
    > my bookmarks, and I will check your suggestion out.


    OK -- I traced the problem to corrupted bookmarks file. I have
    hundreds of them and I went through them and removed large sections
    which
    had inconsistencies (revealed by looking at bookmarks organizer). Now
    it works on XP, Vista and Snow Leopard...Passwords, too. Thanks for
    starting me off on this path.

+ Reply to Thread