Re: XMLHttpRequest and multipart form - Mozilla

This is a discussion on Re: XMLHttpRequest and multipart form - Mozilla ; ----- Original Message ---- > From: Innu > To: dev-extensions@lists.mozilla.org > Sent: Tuesday, June 24, 2008 7:29:29 AM > Subject: XMLHttpRequest and multipart form > > Hey, > > I'm trying to send file data to server. After adding headers ...

+ Reply to Thread
Results 1 to 2 of 2

Thread: Re: XMLHttpRequest and multipart form

  1. Re: XMLHttpRequest and multipart form



    ----- Original Message ----
    > From: Innu
    > To: dev-extensions@lists.mozilla.org
    > Sent: Tuesday, June 24, 2008 7:29:29 AM
    > Subject: XMLHttpRequest and multipart form
    >
    > Hey,
    >
    > I'm trying to send file data to server. After adding headers for
    > xmlhttprequest, I get error: "no element found (line 1)".
    > this.file is nsIFile (picked with nsIFilePicker).
    >
    > Code:
    > http://pastie.org/221041


    Some of your parts are binary. Have you tried XMLHttpRequest.sendBinaryContent(aBody)?




  2. Re: XMLHttpRequest and multipart form

    On Jun 24, 5:07*pm, "Eric H. Jung" wrote:
    > ----- Original Message ----
    > > From: Innu
    > > To: dev-extensi...@lists.mozilla.org
    > > Sent: Tuesday, June 24, 2008 7:29:29 AM
    > > Subject: XMLHttpRequest and multipart form

    >
    > > Hey,

    >
    > > I'm trying to send file data to server. After adding headers for
    > > xmlhttprequest, I get error: "no element found (line 1)".
    > > this.file is nsIFile (picked with nsIFilePicker).

    >
    > > Code:
    > >http://pastie.org/221041

    >
    > Some of your parts are binary. Have you tried XMLHttpRequest.sendBinaryContent(aBody)?


    I think you meant sendAsBinary(aBody), but I still get the same error.

+ Reply to Thread