adding langauge pack to firefox 3 b4 brokes firefox - Mozilla

This is a discussion on adding langauge pack to firefox 3 b4 brokes firefox - Mozilla ; Hello, I just changed the maxVersion in the language pack to 3.0.0.* Than ziped it and named .xpi because the language pack was not compatible. After installing and reloading firefox 3 b4 portable firefox was broken. Now I installed firefox ...

+ Reply to Thread
Results 1 to 7 of 7

Thread: adding langauge pack to firefox 3 b4 brokes firefox

  1. adding langauge pack to firefox 3 b4 brokes firefox

    Hello,
    I just changed the maxVersion in the language pack to 3.0.0.* Than ziped
    it and named .xpi because the language pack was not compatible. After
    installing and reloading firefox 3 b4 portable firefox was broken. Now I
    installed firefox once again. I hope this problem will be solved. Does
    anybody have the same problem?

  2. Re: adding langauge pack to firefox 3 b4 brokes firefox

    Spiderman wrote:
    > Hello,
    > I just changed the maxVersion in the language pack to 3.0.0.* Than ziped
    > it and named .xpi because the language pack was not compatible. After
    > installing and reloading firefox 3 b4 portable firefox was broken. Now I
    > installed firefox once again. I hope this problem will be solved. Does
    > anybody have the same problem?


    I would suggest sticking to release versions.
    By 'bumping' the max version of the extension, you are claiming it is
    compatable with the new version, which it probably isn't (yet)

  3. Re: adding langauge pack to firefox 3 b4 brokes firefox

    Moz Champion (Dan) schrieb:
    > Spiderman wrote:
    >> Hello,
    >> I just changed the maxVersion in the language pack to 3.0.0.* Than
    >> ziped it and named .xpi because the language pack was not compatible.
    >> After installing and reloading firefox 3 b4 portable firefox was
    >> broken. Now I installed firefox once again. I hope this problem will
    >> be solved. Does anybody have the same problem?

    >
    > I would suggest sticking to release versions.
    > By 'bumping' the max version of the extension, you are claiming it is
    > compatable with the new version, which it probably isn't (yet)

    Can I disable the compatibility check? and how do I make it? Thanks in
    advance.

  4. Re: adding langauge pack to firefox 3 b4 brokes firefox

    Spiderman wrote:
    > Moz Champion (Dan) schrieb:
    >> Spiderman wrote:
    >>> Hello,
    >>> I just changed the maxVersion in the language pack to 3.0.0.* Than
    >>> ziped it and named .xpi because the language pack was not compatible.
    >>> After installing and reloading firefox 3 b4 portable firefox was
    >>> broken. Now I installed firefox once again. I hope this problem will
    >>> be solved. Does anybody have the same problem?

    >>
    >> I would suggest sticking to release versions.
    >> By 'bumping' the max version of the extension, you are claiming it is
    >> compatable with the new version, which it probably isn't (yet)

    > Can I disable the compatibility check? and how do I make it? Thanks in
    > advance.


    That is exactly what you did when you 'bumped' the max version, it
    disables the compatibility check, you are certifying that the extension
    IS compatible with the version. As I said, it probably isn't (yet)
    compatible, so claiming it is doesn't work.

  5. Re: adding langauge pack to firefox 3 b4 brokes firefox

    Moz Champion (Dan) schrieb:
    > Spiderman wrote:
    >> Moz Champion (Dan) schrieb:
    >>> Spiderman wrote:
    >>>> Hello,
    >>>> I just changed the maxVersion in the language pack to 3.0.0.* Than
    >>>> ziped it and named .xpi because the language pack was not
    >>>> compatible. After installing and reloading firefox 3 b4 portable
    >>>> firefox was broken. Now I installed firefox once again. I hope this
    >>>> problem will be solved. Does anybody have the same problem?
    >>>
    >>> I would suggest sticking to release versions.
    >>> By 'bumping' the max version of the extension, you are claiming it is
    >>> compatable with the new version, which it probably isn't (yet)

    >> Can I disable the compatibility check? and how do I make it? Thanks in
    >> advance.

    >
    > That is exactly what you did when you 'bumped' the max version, it
    > disables the compatibility check, you are certifying that the extension
    > IS compatible with the version. As I said, it probably isn't (yet)
    > compatible, so claiming it is doesn't work.

    I delete firefox and installed it once again without the language pack
    so I haven't disabled the compatibility check. It should be possibel to
    disable it. Maybe somewhere in about:config?

  6. Re: adding langauge pack to firefox 3 b4 brokes firefox

    Spiderman schrieb:
    > Moz Champion (Dan) schrieb:
    >> Spiderman wrote:
    >>> Moz Champion (Dan) schrieb:
    >>>> Spiderman wrote:
    >>>>> Hello,
    >>>>> I just changed the maxVersion in the language pack to 3.0.0.* Than
    >>>>> ziped it and named .xpi because the language pack was not
    >>>>> compatible. After installing and reloading firefox 3 b4 portable
    >>>>> firefox was broken. Now I installed firefox once again. I hope this
    >>>>> problem will be solved. Does anybody have the same problem?
    >>>>
    >>>> I would suggest sticking to release versions.
    >>>> By 'bumping' the max version of the extension, you are claiming it
    >>>> is compatable with the new version, which it probably isn't (yet)
    >>> Can I disable the compatibility check? and how do I make it? Thanks
    >>> in advance.

    >>
    >> That is exactly what you did when you 'bumped' the max version, it
    >> disables the compatibility check, you are certifying that the
    >> extension IS compatible with the version. As I said, it probably isn't
    >> (yet) compatible, so claiming it is doesn't work.

    > I delete firefox and installed it once again without the language pack
    > so I haven't disabled the compatibility check. It should be possibel to
    > disable it. Maybe somewhere in about:config?

    http://www.jamesvandyke.com/2008/01/...irefox-3-beta/

  7. Re: adding langauge pack to firefox 3 b4 brokes firefox [solved]

    Spiderman schrieb:
    > Spiderman schrieb:
    >> Moz Champion (Dan) schrieb:
    >>> Spiderman wrote:
    >>>> Moz Champion (Dan) schrieb:
    >>>>> Spiderman wrote:
    >>>>>> Hello,
    >>>>>> I just changed the maxVersion in the language pack to 3.0.0.* Than
    >>>>>> ziped it and named .xpi because the language pack was not
    >>>>>> compatible. After installing and reloading firefox 3 b4 portable
    >>>>>> firefox was broken. Now I installed firefox once again. I hope
    >>>>>> this problem will be solved. Does anybody have the same problem?
    >>>>>
    >>>>> I would suggest sticking to release versions.
    >>>>> By 'bumping' the max version of the extension, you are claiming it
    >>>>> is compatable with the new version, which it probably isn't (yet)
    >>>> Can I disable the compatibility check? and how do I make it? Thanks
    >>>> in advance.
    >>>
    >>> That is exactly what you did when you 'bumped' the max version, it
    >>> disables the compatibility check, you are certifying that the
    >>> extension IS compatible with the version. As I said, it probably
    >>> isn't (yet) compatible, so claiming it is doesn't work.

    >> I delete firefox and installed it once again without the language pack
    >> so I haven't disabled the compatibility check. It should be possibel
    >> to disable it. Maybe somewhere in about:config?

    > http://www.jamesvandyke.com/2008/01/...irefox-3-beta/
    >

    And now I found the language pack for the newest beta of ff:
    http://releases.mozilla.org/pub/mozi...0b4/win32/xpi/

    So I don't have to disable the compatibility check.

+ Reply to Thread