Use Correct Flash Player for FF - Mozilla

This is a discussion on Use Correct Flash Player for FF - Mozilla ; I am starting this as a new thread because I think I've found out the source of the problem in my thread called "Website with .swf file won't load anymore". Adobe has Flash Player (with Shockwave software included, it seems). ...

+ Reply to Thread
Results 1 to 3 of 3

Thread: Use Correct Flash Player for FF

  1. Use Correct Flash Player for FF

    I am starting this as a new thread because I think I've found out the
    source of the problem in my thread called "Website with .swf file won't
    load anymore".

    Adobe has Flash Player (with Shockwave software included, it seems).
    I had version 9.0 r115 (which was recently downloaded) and it didn't
    work on one site that gave the message "Sorry, Flash 5 needed" -- even
    though the site worked fine for years. Using the addon Flash Switcher
    (for Windows), it showed 9.0 r45 as the latest one to select. As soon
    as I switched to this earlier version of Flash, the site played the
    Shockwave game without problem.

    I suspect that the newer version of Shockwave included in the Flash
    Player does not work well on site created years ago for Shockwave. I
    intend to notify Adobe.

    David

  2. Re: Use Correct Flash Player for FF

    DJAckerman wrote:
    > I am starting this as a new thread because I think I've found out the
    > source of the problem in my thread called "Website with .swf file won't
    > load anymore".
    >
    > Adobe has Flash Player (with Shockwave software included, it seems).
    > I had version 9.0 r115 (which was recently downloaded) and it didn't
    > work on one site that gave the message "Sorry, Flash 5 needed" -- even
    > though the site worked fine for years. Using the addon Flash Switcher
    > (for Windows), it showed 9.0 r45 as the latest one to select. As soon
    > as I switched to this earlier version of Flash, the site played the
    > Shockwave game without problem.
    >
    > I suspect that the newer version of Shockwave included in the Flash
    > Player does not work well on site created years ago for Shockwave. I
    > intend to notify Adobe.
    >
    > David


    As far as I know Flash and Shockwave are separate downloads, they're not
    offered as a bundle.

    The latest version of Flash is 9.0.115, and it's highly recommended to
    use it, as it fixes a number of security issues.

    For Windows there used to be different downloads for IE and Mozilla/FF
    in the past, not sure if that's still the case.

    I'm on Linux, and there is no Shockwave for Linux, so I'm not quite sure
    about the latest version, but I believe it's 10.2.

    You can check the installed version and test both here:
    http://www.adobe.com/shockwave/welcome/

    --
    Christian

  3. Re: Use Correct Flash Player for FF

    DJAckerman wrote:
    > I am starting this as a new thread because I think I've found out the
    > source of the problem in my thread called "Website with .swf file won't
    > load anymore".
    >
    > Adobe has Flash Player (with Shockwave software included, it seems).
    > I had version 9.0 r115 (which was recently downloaded) and it didn't
    > work on one site that gave the message "Sorry, Flash 5 needed" -- even
    > though the site worked fine for years. Using the addon Flash Switcher
    > (for Windows), it showed 9.0 r45 as the latest one to select. As soon
    > as I switched to this earlier version of Flash, the site played the
    > Shockwave game without problem.
    >
    > I suspect that the newer version of Shockwave included in the Flash
    > Player does not work well on site created years ago for Shockwave. I
    > intend to notify Adobe.
    >
    > David


    I suggest that you also write the designer of the site in question, and
    inform him that the site does not work with the latest flash player.

    Lee

+ Reply to Thread