Mouse Forward/Back Buttons don't work in 1.5.0.5 or 1.5.0.6 - Mozilla

This is a discussion on Mouse Forward/Back Buttons don't work in 1.5.0.5 or 1.5.0.6 - Mozilla ; After I upgraded to 1.5.0.5, I noticed that my forward and back mouse buttons weren't working anymore. They still work in IE, so I'm forced to think that it is firefox. When I went to .0.6, the buttons still don't ...

+ Reply to Thread
Page 1 of 2 1 2 LastLast
Results 1 to 20 of 23

Thread: Mouse Forward/Back Buttons don't work in 1.5.0.5 or 1.5.0.6

  1. Mouse Forward/Back Buttons don't work in 1.5.0.5 or 1.5.0.6

    After I upgraded to 1.5.0.5, I noticed that my forward and back mouse
    buttons weren't working anymore. They still work in IE, so I'm forced
    to think that it is firefox. When I went to .0.6, the buttons still
    don't work it ff, and still work in IE. Is there some little thing that
    I am just being stupid about or is this an actual issue? For the
    record, my mouse is a Logitech MX Laser, and I'm running WinXP SP2.

    Thanks for any help!

    Sheila

  2. Re: Mouse Forward/Back Buttons don't work in 1.5.0.5 or 1.5.0.6

    gwtc wrote:
    > Sheila Stading wrote:
    >> After I upgraded to 1.5.0.5, I noticed that my forward and back mouse
    >> buttons weren't working anymore. They still work in IE, so I'm forced
    >> to think that it is firefox.

    >
    > just because they work in IE doesn't mean anything. IE and FF are two
    > different products and not related.
    >


    No, but they used to work in firefox, and the buttons still work
    elsewhere, so it isn't the mouse driver. That was the point of that
    statement.

    I am not an idiot.

    Sheila

  3. Re: Mouse Forward/Back Buttons don't work in 1.5.0.5 or 1.5.0.6

    Sheila Stading wrote:
    > After I upgraded to 1.5.0.5, I noticed that my forward and back mouse
    > buttons weren't working anymore. They still work in IE, so I'm forced
    > to think that it is firefox.


    just because they work in IE doesn't mean anything. IE and FF are two
    different products and not related.

    --
    Maxims for the Internet Age: Speak softly and carry a cellular phone.

  4. Re: Mouse Forward/Back Buttons don't work in 1.5.0.5 or 1.5.0.6

    gwtc wrote:
    > Sheila Stading wrote:
    >> After I upgraded to 1.5.0.5, I noticed that my forward and back mouse
    >> buttons weren't working anymore. They still work in IE, so I'm forced
    >> to think that it is firefox.

    >
    > just because they work in IE doesn't mean anything. IE and FF are two
    > different products and not related.
    >


    I understand that. However, using the buttons in a different program
    was the first step of my troubleshooting. I eliminated it being a
    hardware problem (since the buttons are still operational and work in
    other programs, not JUST IE), which makes it a software problem.

    Sheila

  5. Re: Mouse Forward/Back Buttons don't work in 1.5.0.5 or 1.5.0.6

    Sheila Stading wrote:
    > gwtc wrote:
    >> Sheila Stading wrote:
    >>> After I upgraded to 1.5.0.5, I noticed that my forward and back mouse
    >>> buttons weren't working anymore. They still work in IE, so I'm
    >>> forced to think that it is firefox.

    >>
    >> just because they work in IE doesn't mean anything. IE and FF are two
    >> different products and not related.
    >>

    >
    > I understand that. However, using the buttons in a different program
    > was the first step of my troubleshooting. I eliminated it being a
    > hardware problem (since the buttons are still operational and work in
    > other programs, not JUST IE), which makes it a software problem.
    >
    > Sheila


    Okay test time.
    In Firefox, go to
    http://www.mozilla.com/
    now to to
    http://www.mozilla.org/

    Your back button should be accessible, and clicking it should take you
    back to mozilla.com. Does it?

  6. Re: Mouse Forward/Back Buttons don't work in 1.5.0.5 or 1.5.0.6

    Moz Champion (Dan) wrote:
    > Sheila Stading wrote:
    >> gwtc wrote:
    >>> Sheila Stading wrote:
    >>>> After I upgraded to 1.5.0.5, I noticed that my forward and back
    >>>> mouse buttons weren't working anymore. They still work in IE, so
    >>>> I'm forced to think that it is firefox.
    >>>
    >>> just because they work in IE doesn't mean anything. IE and FF are
    >>> two different products and not related.
    >>>

    >>
    >> I understand that. However, using the buttons in a different program
    >> was the first step of my troubleshooting. I eliminated it being a
    >> hardware problem (since the buttons are still operational and work in
    >> other programs, not JUST IE), which makes it a software problem.
    >>
    >> Sheila

    >
    > Okay test time.
    > In Firefox, go to
    > http://www.mozilla.com/
    > now to to
    > http://www.mozilla.org/
    >
    > Your back button should be accessible, and clicking it should take you
    > back to mozilla.com. Does it?



    NB
    for the back forward buttons to work, DONT click on the links in my
    message, type them into your browser.

  7. Re: Mouse Forward/Back Buttons don't work in 1.5.0.5 or 1.5.0.6

    Moz Champion (Dan) wrote:

    > Okay test time.
    > In Firefox, go to
    > http://www.mozilla.com/
    > now to to
    > http://www.mozilla.org/
    >
    > Your back button should be accessible, and clicking it should take you
    > back to mozilla.com. Does it?


    The software button (the button in firefox) works and takes me back to
    mozilla.com. The mouse buttons do not do anything. I have to go and
    click the arrow to go back.

    I know it's a minor problem, but it's been driving me nuts.

    Sheila

  8. Re: Mouse Forward/Back Buttons don't work in 1.5.0.5 or 1.5.0.6

    Moz Champion (Dan) wrote:
    >> Okay test time.
    >> In Firefox, go to
    >> http://www.mozilla.com/
    >> now to to
    >> http://www.mozilla.org/
    >>
    >> Your back button should be accessible, and clicking it should take you
    >> back to mozilla.com. Does it?

    >
    >
    > NB
    > for the back forward buttons to work, DONT click on the links in my
    > message, type them into your browser.


    I did type them in, and no go on the mouse buttons. I did notice that
    when I first hit the button you can see the cursor flash to the
    hourglass for an instant, but it never does anything.

    Sheila

  9. Re: Mouse Forward/Back Buttons don't work in 1.5.0.5 or 1.5.0.6

    Sheila Stading wrote:
    > Moz Champion (Dan) wrote:
    >
    >> Okay test time.
    >> In Firefox, go to
    >> http://www.mozilla.com/
    >> now to to
    >> http://www.mozilla.org/
    >>
    >> Your back button should be accessible, and clicking it should take you
    >> back to mozilla.com. Does it?

    >
    > The software button (the button in firefox) works and takes me back to
    > mozilla.com. The mouse buttons do not do anything. I have to go and
    > click the arrow to go back.
    >
    > I know it's a minor problem, but it's been driving me nuts.
    >
    > Sheila


    ?? the mouse buttons? They arent forward and back buttons. Unless you
    had some sort of extension or program to make the so, they are not built
    in default as back/forward controls

  10. Re: Mouse Forward/Back Buttons don't work in 1.5.0.5 or 1.5.0.6

    Moz Champion (Dan) wrote:

    > ?? the mouse buttons? They arent forward and back buttons. Unless you
    > had some sort of extension or program to make the so, they are not built
    > in default as back/forward controls


    Okay... I'm probably not making much sense.

    I have a 5 button mouse. Two buttons are configured for "forward" and
    "back" respectively. FF no longer recognizes these buttons when they
    are pressed. It used to without any additional add ons beyond the mouse
    drivers.

    Is that any clearer? I have a feeling I'm just not explaining my
    problem correctly.

    Sheila

  11. Re: Mouse Forward/Back Buttons don't work in 1.5.0.5 or 1.5.0.6

    Sheila Stading wrote:
    > Moz Champion (Dan) wrote:
    >
    >> ?? the mouse buttons? They arent forward and back buttons. Unless you
    >> had some sort of extension or program to make the so, they are not
    >> built in default as back/forward controls

    >
    > Okay... I'm probably not making much sense.
    >
    > I have a 5 button mouse. Two buttons are configured for "forward" and
    > "back" respectively. FF no longer recognizes these buttons when they
    > are pressed. It used to without any additional add ons beyond the mouse
    > drivers.
    >
    > Is that any clearer? I have a feeling I'm just not explaining my
    > problem correctly.
    >
    > Sheila


    Ah yes, much clearer, totally different problem.
    Have you tried re-installing the mouse drivers?

  12. Re: Mouse Forward/Back Buttons don't work in 1.5.0.5 or 1.5.0.6

    Moz Champion (Dan) wrote:
    >> Okay... I'm probably not making much sense.
    >>
    >> I have a 5 button mouse. Two buttons are configured for "forward" and
    >> "back" respectively. FF no longer recognizes these buttons when they
    >> are pressed. It used to without any additional add ons beyond the
    >> mouse drivers.
    >>
    >> Is that any clearer? I have a feeling I'm just not explaining my
    >> problem correctly.
    >>
    >> Sheila

    >
    > Ah yes, much clearer, totally different problem.
    > Have you tried re-installing the mouse drivers?


    Yes, twice. I blamed the mouse first, because I've never had a problem
    with ff. Should I try it a third time (third time's the charm)?

    Sheila

  13. Re: Mouse Forward/Back Buttons don't work in 1.5.0.5 or 1.5.0.6

    On Sun, 06 Aug 2006 14:21:24 -0700, gwtc wrote in message
    :

    > Sheila Stading wrote:
    >> After I upgraded to 1.5.0.5, I noticed that my forward and back mouse
    >> buttons weren't working anymore. They still work in IE, so I'm forced
    >> to think that it is firefox.

    >
    > just because they work in IE doesn't mean anything. IE and FF are two
    > different products and not related.


    Fortunately. ;-)

  14. Re: Mouse Forward/Back Buttons don't work in 1.5.0.5 or 1.5.0.6

    Shelia, if you are using Logitech's Set Point drivers go to your Logitech
    Control Panel, My Mouse and select buttons 5 & 6. Reset them to "keystroke
    assignment" and assign button 5 Alt+right and button 6 Alt+left. This is a
    standard issue with Logitech drivers in Firefox and is noted on Logitech's
    support site.


    "Sheila Stading" wrote in message
    news:d_CdnWwc3oV9xUvZnZ2dnUVZ_tGdnZ2d@mozilla.org. ..
    > After I upgraded to 1.5.0.5, I noticed that my forward and back mouse
    > buttons weren't working anymore. They still work in IE, so I'm forced to
    > think that it is firefox. When I went to .0.6, the buttons still don't
    > work it ff, and still work in IE. Is there some little thing that I am
    > just being stupid about or is this an actual issue? For the record, my
    > mouse is a Logitech MX Laser, and I'm running WinXP SP2.
    >
    > Thanks for any help!
    >
    > Sheila




  15. Re: Mouse Forward/Back Buttons don't work in 1.5.0.5 or 1.5.0.6

    Aqua wrote:
    > Shelia, if you are using Logitech's Set Point drivers go to your Logitech
    > Control Panel, My Mouse and select buttons 5 & 6. Reset them to "keystroke
    > assignment" and assign button 5 Alt+right and button 6 Alt+left. This is a
    > standard issue with Logitech drivers in Firefox and is noted on Logitech's
    > support site.
    >
    >
    > "Sheila Stading" wrote in message
    > news:d_CdnWwc3oV9xUvZnZ2dnUVZ_tGdnZ2d@mozilla.org. ..
    >> After I upgraded to 1.5.0.5, I noticed that my forward and back mouse
    >> buttons weren't working anymore. They still work in IE, so I'm forced to
    >> think that it is firefox. When I went to .0.6, the buttons still don't
    >> work it ff, and still work in IE. Is there some little thing that I am
    >> just being stupid about or is this an actual issue? For the record, my
    >> mouse is a Logitech MX Laser, and I'm running WinXP SP2.
    >>
    >> Thanks for any help!
    >>
    >> Sheila

    >
    >

    Thank you. Apparently I suck at reading the stuff on their page. It
    just seemed weird because it used to work.

    Works again now, so instead of blaming ff, I will go ahead and blame
    logitech.

    Thanks!

    Sheila

  16. Re: Mouse Forward/Back Buttons don't work in 1.5.0.5 or 1.5.0.6

    "Sheila Stading" wrote ...
    > After I upgraded to 1.5.0.5, I noticed that my forward and back mouse
    > buttons weren't working anymore. They still work in IE, so I'm forced
    > to think that it is firefox. When I went to .0.6, the buttons still
    > don't work it ff, and still work in IE. Is there some little thing that
    > I am just being stupid about or is this an actual issue? For the
    > record, my mouse is a Logitech MX Laser, and I'm running WinXP SP2.


    Hi Shelia,
    I don't know what you are going to see with Logitech drivers
    in your Control Panel settings, Mouse, but I can duplicate
    what you experience, if I override the default settings for Firefox.
    Settings, Control Panel, Mouse, check your default setting there
    on the "Buttons" tab, then on the same tab, press settings button
    (for other app;lications),
    and see you you have a separate set of buttons for Firefox
    where your side (or thumb) buttons are set to "None" instead'
    of your global default. Hope that works for you or you can translate
    that into Logitech mouse settings, because the rest of this is a lot
    more time consuming.


    I have a Microsoft Intellipoint mouse on a laptop, if I have it
    plugged into the PS/2 port and unplug it and and plug it back
    in it will reduce itself to a three button mouse, until I reboot
    and the intellipont (Point32) is added to started tasks again.
    But this is true for all applications.

    If I plug the mouse into a USB port, then I can unplug it and
    plug it back in without loss of buttons. But since it works in
    all your other applications, you might want to check your
    Control Settings, Mouse to see if you have made an exception for
    some applications like Firefox, or coded the other applications
    as exceptions.
    My Notes on Mouse Wheel and Button Settings
    http://www.mvps.org/dmcritchie/excel/mouse.txt
    There are several Firefox extensions that would mess with your
    middle-click button, but I don't know of any extension that would
    purposely mess with BACK or FORWARD buttons.

    If you are using the Logitech drivers you might try the Microsoft drivers
    (or vice versa) or swap your mouse with another brand (particularly if this
    is at work) and see it it is recognized or install more drivers.
    ---
    David McRitchie, for my notes customizing Firefox, see
    http://www.mvps.org/dmcritchie/firefox/firefox.htm



  17. Re: Mouse Forward/Back Buttons don't work in 1.5.0.5 or 1.5.0.6

    Sheila Stading wrote:
    > Moz Champion (Dan) wrote:
    >>> Okay... I'm probably not making much sense.
    >>>
    >>> I have a 5 button mouse. Two buttons are configured for "forward"
    >>> and "back" respectively. FF no longer recognizes these buttons when
    >>> they are pressed. It used to without any additional add ons beyond
    >>> the mouse drivers.
    >>>
    >>> Is that any clearer? I have a feeling I'm just not explaining my
    >>> problem correctly.
    >>>
    >>> Sheila

    >>
    >> Ah yes, much clearer, totally different problem.
    >> Have you tried re-installing the mouse drivers?

    >
    > Yes, twice. I blamed the mouse first, because I've never had a problem
    > with ff. Should I try it a third time (third time's the charm)?
    >
    > Sheila



    Another idea, the program in which you assign the button functions,
    ensure it is recognizing the new version of Firefox as the one its
    supposed to work with.

    i.e. re-assign the buttons to your current Firefox

  18. Re: Mouse Forward/Back Buttons don't work in 1.5.0.5 or 1.5.0.6


    "Sheila Stading" wrote in message
    news:EaCdnSJzXM8pH0vZnZ2dnUVZ_tGdnZ2d@mozilla.org. ..
    > Aqua wrote:
    >> Shelia, if you are using Logitech's Set Point drivers go to your Logitech
    >> Control Panel, My Mouse and select buttons 5 & 6. Reset them to
    >> "keystroke assignment" and assign button 5 Alt+right and button 6
    >> Alt+left. This is a standard issue with Logitech drivers in Firefox and
    >> is noted on Logitech's support site.
    >>
    >>
    >> "Sheila Stading" wrote in message
    >> news:d_CdnWwc3oV9xUvZnZ2dnUVZ_tGdnZ2d@mozilla.org. ..
    >>> After I upgraded to 1.5.0.5, I noticed that my forward and back mouse
    >>> buttons weren't working anymore. They still work in IE, so I'm forced
    >>> to think that it is firefox. When I went to .0.6, the buttons still
    >>> don't work it ff, and still work in IE. Is there some little thing that
    >>> I am just being stupid about or is this an actual issue? For the
    >>> record, my mouse is a Logitech MX Laser, and I'm running WinXP SP2.
    >>>
    >>> Thanks for any help!
    >>>
    >>> Sheila

    >>
    >>

    > Thank you. Apparently I suck at reading the stuff on their page. It just
    > seemed weird because it used to work.
    >
    > Works again now, so instead of blaming ff, I will go ahead and blame
    > logitech.
    >
    > Thanks!
    >
    > Sheila


    Actually Logitech claims that Firefox uses "non-standard commands" so you
    can blame ff. Or blame Logitech for not keeping up !



  19. Re: Mouse Forward/Back Buttons don't work in 1.5.0.5 or 1.5.0.6

    Sheila Stading wrote:
    > After I upgraded to 1.5.0.5, I noticed that my forward and back mouse
    > buttons weren't working anymore. They still work in IE, so I'm forced
    > to think that it is firefox. When I went to .0.6, the buttons still
    > don't work it ff, and still work in IE. Is there some little thing that
    > I am just being stupid about or is this an actual issue? For the
    > record, my mouse is a Logitech MX Laser, and I'm running WinXP SP2.
    >
    > Thanks for any help!
    >
    > Sheila


    No trouble here with forward and back buttons, but in Thunderbird my
    'application' buttons stopped working with 1.5.0.4. Probably something
    the Mozilla guys did that isn't what IE does. You might check to see if
    there is a more current driver version as Logitech updates drivers quite
    frequently.

  20. Re: Mouse Forward/Back Buttons don't work in 1.5.0.5 or 1.5.0.6

    Moz Champion (Dan) wrote:
    > Sheila Stading wrote:
    >> Moz Champion (Dan) wrote:
    >>
    >>> Okay test time.
    >>> In Firefox, go to
    >>> http://www.mozilla.com/
    >>> now to to
    >>> http://www.mozilla.org/
    >>>
    >>> Your back button should be accessible, and clicking it should take
    >>> you back to mozilla.com. Does it?

    >>
    >> The software button (the button in firefox) works and takes me back to
    >> mozilla.com. The mouse buttons do not do anything. I have to go and
    >> click the arrow to go back.
    >>
    >> I know it's a minor problem, but it's been driving me nuts.
    >>
    >> Sheila

    >
    > ?? the mouse buttons? They arent forward and back buttons. Unless you
    > had some sort of extension or program to make the so, they are not built
    > in default as back/forward controls


    Grin. Some of us have mice with more than two buttons. Like as many as
    5 on some of the better mice, if you count the wheel button... Where
    you been for the past few years?

+ Reply to Thread
Page 1 of 2 1 2 LastLast