Mark as Read When Previewed - Mozilla

This is a discussion on Mark as Read When Previewed - Mozilla ; I notice that the marking as read of messages viewed in the preview pane is disabled if viewing inline headers. Is this a bug or a feature? version 2.0.0.6 (20070728) Thanks....

+ Reply to Thread
Results 1 to 11 of 11

Thread: Mark as Read When Previewed

  1. Mark as Read When Previewed

    I notice that the marking as read of messages viewed in the preview pane
    is disabled if viewing inline headers. Is this a bug or a feature?

    version 2.0.0.6 (20070728)

    Thanks.

  2. Re: Mark as Read When Previewed

    bluerhinoceros wrote:
    > I notice that the marking as read of messages viewed in the preview pane
    > is disabled if viewing inline headers. Is this a bug or a feature?
    >
    > version 2.0.0.6 (20070728)
    >
    > Thanks.


    Um, there is no preview pane, there is the message pane, in which he
    message is displayed.

    But anyway. I am not understanding what you mean by '..if viewing inline
    headers."

    Perhaps if you explained how you get to this situation, and he steps you
    take to do so

  3. Re: Mark as Read When Previewed

    Moz Champion (Dan) wrote:
    > bluerhinoceros wrote:
    >> I notice that the marking as read of messages viewed in the preview
    >> pane is disabled if viewing inline headers. Is this a bug or a feature?
    >>
    >> version 2.0.0.6 (20070728)
    >>
    >> Thanks.

    >
    > Um, there is no preview pane, there is the message pane, in which he
    > message is displayed.
    >
    > But anyway. I am not understanding what you mean by '..if viewing inline
    > headers."
    >
    > Perhaps if you explained how you get to this situation, and he steps you
    > take to do so


    Sorry, "preview pane" is a carryover from another reader. Yes, I was
    referring to the Message Pane.

    If I single-click on a message in the top right pane (with Message Pane
    enabled), the bold font changes to normal, and the message is marked as
    Read (the message is displayed in the Message Pane).

    If I enable Inline Headers (either 1) click the
    quadranted-square-with-the-lower-right-arrow icon in upper left of the
    heading of the Message Pane beside "Subject" or 2) select View ->
    Headers -> Inline (All Only)) then the above action displays the message
    (along with complete headers) as expected, but does NOT mark the message
    as read.

    I hope this is sufficient for you to duplicate the issue.

    Thanks for your assistance.

    Cheers.

  4. Re: Mark as Read When Previewed

    bluerhinoceros wrote:
    > Moz Champion (Dan) wrote:
    >> bluerhinoceros wrote:
    >>> I notice that the marking as read of messages viewed in the preview
    >>> pane is disabled if viewing inline headers. Is this a bug or a feature?
    >>>
    >>> version 2.0.0.6 (20070728)
    >>>
    >>> Thanks.

    >>
    >> Um, there is no preview pane, there is the message pane, in which he
    >> message is displayed.
    >>
    >> But anyway. I am not understanding what you mean by '..if viewing
    >> inline headers."
    >>
    >> Perhaps if you explained how you get to this situation, and he steps
    >> you take to do so

    >
    > Sorry, "preview pane" is a carryover from another reader. Yes, I was
    > referring to the Message Pane.
    >
    > If I single-click on a message in the top right pane (with Message Pane
    > enabled), the bold font changes to normal, and the message is marked as
    > Read (the message is displayed in the Message Pane).
    >
    > If I enable Inline Headers (either 1) click the
    > quadranted-square-with-the-lower-right-arrow icon in upper left of the
    > heading of the Message Pane beside "Subject" or 2) select View ->
    > Headers -> Inline (All Only)) then the above action displays the message
    > (along with complete headers) as expected, but does NOT mark the message
    > as read.
    >
    > I hope this is sufficient for you to duplicate the issue.
    >
    > Thanks for your assistance.
    >
    > Cheers.


    ?? If you have a message in the message pane, it is marked read. And you
    concur with this. You said if you single click on a message in the top
    right pane (subject pane) the bold font changes and the message is
    displayed in the message pane.

    If you now click on the quadranted-square, the message is already marked
    read - so how can it be marked read again? (unless you used the mark
    button to unmark it of course)

    I don't have Headers--> Inline (All Only) I simply have Headers-->All
    or Headers-->Normal

    to show headers in the message pane you have already selected the
    message and it is marked read. Changing header view won't change this.
    If you selecte ALL header View and hit NEXT (to go to the next unread
    message) then that message will be unbolded in the subject pane and
    marked read

  5. Re: Mark as Read When Previewed

    Moz Champion (Dan) wrote:
    > bluerhinoceros wrote:
    >> Moz Champion (Dan) wrote:
    >>> bluerhinoceros wrote:
    >>>> I notice that the marking as read of messages viewed in the preview
    >>>> pane is disabled if viewing inline headers. Is this a bug or a feature?
    >>>>
    >>>> version 2.0.0.6 (20070728)
    >>>>
    >>>> Thanks.
    >>>
    >>> Um, there is no preview pane, there is the message pane, in which he
    >>> message is displayed.
    >>>
    >>> But anyway. I am not understanding what you mean by '..if viewing
    >>> inline headers."
    >>>
    >>> Perhaps if you explained how you get to this situation, and he steps
    >>> you take to do so

    >>
    >> Sorry, "preview pane" is a carryover from another reader. Yes, I was
    >> referring to the Message Pane.
    >>
    >> If I single-click on a message in the top right pane (with Message
    >> Pane enabled), the bold font changes to normal, and the message is
    >> marked as Read (the message is displayed in the Message Pane).
    >>
    >> If I enable Inline Headers (either 1) click the
    >> quadranted-square-with-the-lower-right-arrow icon in upper left of the
    >> heading of the Message Pane beside "Subject" or 2) select View ->
    >> Headers -> Inline (All Only)) then the above action displays the
    >> message (along with complete headers) as expected, but does NOT mark
    >> the message as read.
    >>
    >> I hope this is sufficient for you to duplicate the issue.
    >>
    >> Thanks for your assistance.
    >>
    >> Cheers.

    >
    > ?? If you have a message in the message pane, it is marked read. And you
    > concur with this. You said if you single click on a message in the top
    > right pane (subject pane) the bold font changes and the message is
    > displayed in the message pane.
    >
    > If you now click on the quadranted-square, the message is already marked
    > read - so how can it be marked read again? (unless you used the mark
    > button to unmark it of course)
    >
    > I don't have Headers--> Inline (All Only) I simply have Headers-->All
    > or Headers-->Normal
    >
    > to show headers in the message pane you have already selected the
    > message and it is marked read. Changing header view won't change this.
    > If you selecte ALL header View and hit NEXT (to go to the next unread
    > message) then that message will be unbolded in the subject pane and
    > marked read


    You're fooling with the old professor, aren't you? :-)

    I am of course not talking about the same message, how could I complain
    it wasn't getting marked "read" if it already was? I thought it self
    evident, but for the record... I note that a selected message is
    subsequently marked "read" (so that mechanism is working), change the
    header view to "Inline", then select a different message (by using the
    down arrow or "F" or randomly clicking on any unread message), and the
    message so selected does not get marked as "read" (so that mechanism has
    now stopped working). The only thing that changed in between was
    changing the header view to "Inline". I toggle off the "Inline" header
    view, and messages that are selected by any mechanism get marked as
    "read" again.

    My View -> Headers -> Inline has "(All only)" noted after it, I have no
    idea its significance. I'm using the version noted above, is it
    different from yours?

    I take it, then, that you are not witnessing this behaviour? Perhaps a
    side effect of an extension or addon?

    Cheers.

  6. Re: Mark as Read When Previewed

    On Aug 20, 11:55 am, bluerhinoceros wrote:
    > Ronald Killmer wrote:
    > > bluerhinoceros wrote:
    > >> Moz Champion (Dan) wrote:
    > >>> bluerhinoceros wrote:
    > >>>> Moz Champion (Dan) wrote:
    > >>>>> bluerhinoceros wrote:
    > >>>>>> I notice that the marking as read of messages viewed in the
    > >>>>>> preview pane is disabled if viewing inline headers. Is this a bug
    > >>>>>> or a feature?

    >
    > >>>>>> version 2.0.0.6 (20070728)

    >
    > >>>>>> Thanks.

    >
    > >>>>> Um, there is no preview pane, there is the message pane, in which
    > >>>>> he message is displayed.

    >
    > >>>>> But anyway. I am not understanding what you mean by '..if viewing
    > >>>>> inline headers."

    >
    > >>>>> Perhaps if you explained how you get to this situation, and he
    > >>>>> steps you take to do so

    >
    > >>>> Sorry, "preview pane" is a carryover from another reader. Yes, I was
    > >>>> referring to the Message Pane.

    >
    > >>>> If I single-click on a message in the top right pane (with Message
    > >>>> Pane enabled), the bold font changes to normal, and the message is
    > >>>> marked as Read (the message is displayed in the Message Pane).

    >
    > >>>> If I enable Inline Headers (either 1) click the
    > >>>> quadranted-square-with-the-lower-right-arrow icon in upper left of
    > >>>> the heading of the Message Pane beside "Subject" or 2) select View
    > >>>> -> Headers -> Inline (All Only)) then the above action displays the
    > >>>> message (along with complete headers) as expected, but does NOT mark
    > >>>> the message as read.

    >
    > >>>> I hope this is sufficient for you to duplicate the issue.

    >
    > >>>> Thanks for your assistance.

    >
    > >>>> Cheers.

    >
    > >>> ?? If you have a message in the message pane, it is marked read. And
    > >>> you concur with this. You said if you single click on a message in
    > >>> the top right pane (subject pane) the bold font changes and the
    > >>> message is displayed in the message pane.

    >
    > >>> If you now click on the quadranted-square, the message is already
    > >>> marked read - so how can it be marked read again? (unless you used
    > >>> the mark button to unmark it of course)

    >
    > >>> I don't have Headers--> Inline (All Only) I simply have Headers-->All
    > >>> or Headers-->Normal

    >
    > >>> to show headers in the message pane you have already selected the
    > >>> message and it is marked read. Changing header view won't change this.
    > >>> If you selecte ALL header View and hit NEXT (to go to the next unread
    > >>> message) then that message will be unbolded in the subject pane and
    > >>> marked read

    >
    > >> You're fooling with the old professor, aren't you? :-)

    >
    > >> I am of course not talking about the same message, how could I
    > >> complain it wasn't getting marked "read" if it already was? I thought
    > >> it self evident, but for the record... I note that a selected message
    > >> is subsequently marked "read" (so that mechanism is working), change
    > >> the header view to "Inline", then select a different message (by using
    > >> the down arrow or "F" or randomly clicking on any unread message), and
    > >> the message so selected does not get marked as "read" (so that
    > >> mechanism has now stopped working). The only thing that changed in
    > >> between was changing the header view to "Inline". I toggle off the
    > >> "Inline" header view, and messages that are selected by any mechanism
    > >> get marked as "read" again.

    >
    > >> My View -> Headers -> Inline has "(All only)" noted after it, I have
    > >> no idea its significance. I'm using the version noted above, is it
    > >> different from yours?

    >
    > >> I take it, then, that you are not witnessing this behaviour? Perhaps a
    > >> side effect of an extension or addon?

    >
    > >> Cheers.

    >
    > > You have got to be using an extension that is adding "Inline" to the
    > > View > Headers choices. The default Tb build only offers "All" or
    > > "Normal" and the twisty button in the headers bar has to be clicked to
    > > expand/collapse the bar for viewing more/less lines of the header.

    >
    > That was it. I tracked it down to Mnenhy, and have started a discussion
    > over there.
    >
    > Thanks.


    I just installed Thunderbird for the 1st time (and successfully
    imported all my old OE data) and am balanced between using TB or
    accepting the pre-installed Outlook Express. Immediately annoyed that
    in TB I cannot preview an email - basically I cannot rest the cursor
    on an Inbox line - without it changing to "Marked as Read". Any simple
    solution? Or revert to OE if this fusses me?


  7. Re: Mark as Read When Previewed

    sally@bb-china.com wrote:

    > I just installed Thunderbird for the 1st time (and successfully
    > imported all my old OE data) and am balanced between using TB or
    > accepting the pre-installed Outlook Express. Immediately annoyed that
    > in TB I cannot preview an email - basically I cannot rest the
    > cursor on an Inbox line - without it changing to "Marked as Read".
    > Any simple solution? Or revert to OE if this fusses me?
    >


    Goto Tools>Options>Advanced>General .

    Check 'Wait ... seconds before marking a message as read' and set time
    limit to some higher value like 360


  8. Re: Mark as Read When Previewed

    >
    > Goto Tools>Options>Advanced>General .
    >
    > Check 'Wait ... seconds before marking a message as read' and set time
    > limit to some higher value like 360


    Yep, already thought of that but I leave the email proggy open in a
    background Window with the cursor on the top email... eventually it
    will get set to "Marked as Read". Pity that a setting of 0 seconds
    could not denote "Don't mark as read unless I positively open the
    email"! Works just right in OE if you untick the mark message as as
    read box in Tools > Read settings.


  9. Re: Mark as Read When Previewed

    Thunderbird Leader sally@bb-china.com teletyped, On 8/24/2007 4:34 PM:
    >> Goto Tools>Options>Advanced>General .
    >>
    >> Check 'Wait ... seconds before marking a message as read' and set time
    >> limit to some higher value like 360
    >>

    >
    > Yep, already thought of that but I leave the email proggy open in a
    > background Window with the cursor on the top email... eventually it
    > will get set to "Marked as Read". Pity that a setting of 0 seconds
    > could not denote "Don't mark as read unless I positively open the
    > email"! Works just right in OE if you untick the mark message as as
    > read box in Tools > Read settings.
    >
    >

    Thunderbird does *NOT* have a preview. It has two view modes depending
    on how you divide the screen for 3-pane view, and a full size pane
    without the folders or headers in view. A safety preview is not needed
    because of the Tbird security model, it will not run any executables.

    --
    Ron K.
    Don't be a fonted,
    it's just type casting

  10. Re: Mark as Read When Previewed

    On 8/24/2007 1:34 PM, sally@bb-china.com wrote:
    >> Goto Tools>Options>Advanced>General .
    >>
    >> Check 'Wait ... seconds before marking a message as read' and set time
    >> limit to some higher value like 360

    >
    > Yep, already thought of that but I leave the email proggy open in a
    > background Window with the cursor on the top email... eventually it
    > will get set to "Marked as Read". Pity that a setting of 0 seconds
    > could not denote "Don't mark as read unless I positively open the
    > email"! Works just right in OE if you untick the mark message as as
    > read box in Tools > Read settings.
    >

    Go to Tools>>Advanced>>General and uncheck the WAIT. Messages will not
    be marked as read until they are actually read.

    --
    Irwin

    Please do not use my email address to make requests for help.

    Knowledge Base: http://kb.mozillazine.org/Main_Page

  11. Re: Mark as Read When Previewed

    sally@bb-china.com wrote:
    >> Goto Tools>Options>Advanced>General .
    >>
    >> Check 'Wait ... seconds before marking a message as read' and set time
    >> limit to some higher value like 360

    >
    > Yep, already thought of that but I leave the email proggy open in a
    > background Window with the cursor on the top email... eventually it
    > will get set to "Marked as Read". Pity that a setting of 0 seconds
    > could not denote "Don't mark as read unless I positively open the
    > email"! Works just right in OE if you untick the mark message as as
    > read box in Tools > Read settings.
    >

    Close preview pane. Double-click when you want to read a message.


    --
    Ron Hunter rphunter@charter.net

+ Reply to Thread